Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-493

Only fault-injected tests have to be executed by run-test-*-faul-inject targets; none of fault-injected tests need to be ran normal testing process

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.21.0
    • Fix Version/s: 0.21.0
    • Component/s: build, test
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      New fault injection related tests will be executed by non fault-injected targets (e.g. run-test-hdfs, run-test-hdfs-with-mr) over un-instrumented classes. Such behavior will be potentially misleading because fault-injected tests are likely to expect a different system's behavior when faults are injected into the classes.

      Similarly, new targets introduced by HDFS-475 - run-test-hdfs-fault-inject and run-test-hdfs-with-mr-fault-inject will run normal (non-FI) tests with faults turned on which is likely to fall because of aforementioned reasons.

      1. HDFS-493.patch
        4 kB
        Konstantin Boudnik
      2. HDFS-493.patch
        4 kB
        Konstantin Boudnik

        Issue Links

          Activity

          Konstantin Boudnik added a comment -

          A proposed fix for the issue

          Konstantin Boudnik added a comment -

          This patch creates a number of conditions for tests execution. This is needed to distinguish between FI-related and non-FI tests, because their sources are taken from different places and shouldn't interleave with each other.

          Konstantin Boudnik added a comment -

          In a sense these issues are related

          Konstantin Boudnik added a comment -

          Also, patch introduces the notion that FI related tests have a lightly different naming convention. E.g.

          <property name="test.include" value="TestFi*"/>
          

          this should be considered when new tests are developed

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12414019/HDFS-493.patch
          against trunk revision 794953.

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed core unit tests.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/26/testReport/
          Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/26/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/26/artifact/trunk/build/test/checkstyle-errors.html
          Console output: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/26/console

          This message is automatically generated.

          Tsz Wo Nicholas Sze added a comment -

          This may conflict with HDFS-458.

          Konstantin Boudnik added a comment -

          Resolving the conflicts caused by the fix of HDFS-458

          Tsz Wo Nicholas Sze added a comment -

          +1 patch looks good.

          Tsz Wo Nicholas Sze added a comment -

          Tried "ant run-test-hdfs" and "ant run-test-hdfs-fault-inject" with the codes posted in HDFS-483. Both worked fine.

          Since only build.xml is changed by the patch, test-patch and unit tests are not related. I will commit it soon.

          Tsz Wo Nicholas Sze added a comment -

          I have committed this. Thanks, Cos!


            People

            • Assignee:
              Konstantin Boudnik
              Reporter:
              Konstantin Boudnik
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development