Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0
    • Fix Version/s: 2.1.1-beta
    • Component/s: nfs
    • Labels:
      None

      Issue Links

        Activity

        Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk #1512 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1512/)
        fix hadoop-hdfs/CHANGES.txt for HDFS-4763 (brandonli: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1511521)

        Hudson added a comment -

        SUCCESS: Integrated in Hadoop-Hdfs-trunk #1485 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1485/)
        fix hadoop-hdfs/CHANGES.txt for HDFS-4763 (brandonli: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1511521)

        Hudson added a comment -

        SUCCESS: Integrated in Hadoop-Yarn-trunk #295 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/295/)
        fix hadoop-hdfs/CHANGES.txt for HDFS-4763 (brandonli: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1511521)

        Hudson added a comment -

        SUCCESS: Integrated in Hadoop-trunk-Commit #4226 (See https://builds.apache.org/job/Hadoop-trunk-Commit/4226/)
        fix hadoop-hdfs/CHANGES.txt for HDFS-4763 (brandonli: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1511521)

        Arpit Agarwal added a comment -

        +1 for the patch.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12595704/HDFS-4763.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-common-project/hadoop-common hadoop-hdfs-project/hadoop-hdfs.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/4761//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/4761//console

        This message is automatically generated.

        Brandon Li added a comment -

        NFS3 gateway works well with the portmap/rpcbind utility on most Linux distributions. So the user doesn't have to use the Hadoop portmap program provide here.

        The Hadoop portmap is useful on some Linux distributions:

        On some recent Linux distributions such as RHEL6.2, portmap utility is renamed/replaced by rpcbind. However, the rpcbind has a bug (https://bugzilla.redhat.com/show_bug.cgi?id=731542). Basically the problem is that, rpcbind checks whether the portmapping is from loopback interface and using privileged port. Here NFSv3 gateway is not using privileged port, and thus rpcbind returns "Client credential too weak" error. This bug exists in REHL 6.2 and fixed in Fedora 16. The workaround is to start rpcbind with "-i" option.

        Therefore, on RHEL6.2, the NFS3 gateway can not register itself if the rpcbind was not started with the workaround.

        Brandon Li added a comment -

        Uploaded the patch, which has the script change to start portmap and nfs3.


          People

          • Assignee:
            Brandon Li
            Reporter:
            Brandon Li
          • Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development