Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-4681

TestBlocksWithNotEnoughRacks#testCorruptBlockRereplicatedAcrossRacks fails using IBM java

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.5.2
    • Fix Version/s: 3.0.0-alpha1
    • Component/s: test
    • Labels:
      None
    • Environment:

      PowerPC Big Endian architecture

    • Target Version/s:

      Description

      TestBlocksWithNotEnoughRacks unit test fails with the following error message:
      --------------------------------------------------------------------------------------------
      testCorruptBlockRereplicatedAcrossRacks(org.apache.hadoop.hdfs.server.blockmanagement.TestBlocksWithNotEnoughRacks) Time elapsed: 8997 sec <<< FAILURE!
      org.junit.ComparisonFailure: Corrupt replica expected:<...��^EI�u�[�{���[$�\hF�[�R{O�L^S��g�#�O��׼��Wv��6u4Hd)FaŔ��W�0��H/�^ZU@�6�<02>���"$�

      {|�^@�-���|GvW��7g �/M��[U!eF�>^N^?�4pR�d��|��Ŵ7j^O^Sh�^@�nu�(�^C^Y�;I�Q�K^O����"c��� oKtE�*�����^\3u��]Ē:mŭ^^y�����^H��_^T�^Z����S����4�7�C�^G�_���\|^W�vo���zgU�lmJ)_vq~�+^Mo^G^O�W}

      �.�4���� ��6b�S�&G�?��m4FW#@����
      D5��}�Z�]���mfR^G#T-�N��̋�p���`�~��`�^F;�^C]> but was:<...��^EI�u�[�{���[$�\hF�[R{O�L^S��g�#�O��׼��Wv��6u4Hd)FaŔ��W�0��H/�^ZU@�6�<02>�"$�

      {|�^@�-���|GvW��7g �/M�[U!eF�>^N^?�4pR�d��|��Ŵ7j^O^Sh�^@�nu�(�^C^Y�;I�Q�K^O����"c��� oKtE�*�����^\3u��]Ē:mŭ^^y���^H��_^T�^Z����S���4�7�C�^G�_���\|^W�vo���zgU�lmJ)_vq~�+^Mo^G^O�W}

      �.�4���� ��6b�S�&G�?��m4FW#@����
      D5��}�Z�]���mfR^G#T-�N�̋�p���`�~��`�^F;�]>
      at org.junit.Assert.assertEquals(Assert.java:123)
      at org.apache.hadoop.hdfs.server.blockmanagement.TestBlocksWithNotEnoughRacks.testCorruptBlockRereplicatedAcrossRacks(TestBlocksWithNotEnoughRacks.java:229)

      1. HDFS-4681.patch
        0.9 kB
        Tian Hong Wang
      2. HDFS-4681-v1.patch
        4 kB
        Tian Hong Wang
      3. HDFS-4681-v2.patch
        4 kB
        Ayappan

        Issue Links

          Activity

          tianhonglouis Tian Hong Wang added a comment -

          The root cause is that the unit test code uses in.read() method to read the block content char by char., which will abandon the LF. So the best way is to use buffer to read the block content.

          hadoopqa Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12577969/HDFS-4681.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/4216//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/4216//console

          This message is automatically generated.

          tlipcon Todd Lipcon added a comment -

          It seems like converting random bytes to String is error prone in the first place. I think a better fix would be to add a utility to DFSTestUtil which returns the file as a byte[] instead of a String. Then we don't need to worry about encodings, linefeeds, etc.

          tianhonglouis Tian Hong Wang added a comment -

          Sure, Todd, add a utility to DFSTestUtil which returns byte[]. Change String comparison to byte[] comparison.

          hadoopqa Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12578160/HDFS-4681-v1.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/4218//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/4218//console

          This message is automatically generated.

          asanjar Amir Sanjar added a comment -

          any update on when this defect will be included? still breaks in 204 build. thanks

          sureshms Suresh Srinivas added a comment -

          HDFS-3267 already tracks this issue.

          Ayappan Ayappan added a comment -

          Any update on this defect? The target version still points to older version.

          Ayappan Ayappan added a comment -

          This issue is still there in the latest development version..
          The patch is not yet applied.

          hadoopqa Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12578160/HDFS-4681-v1.patch
          against trunk revision caecd9f.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          -1 eclipse:eclipse. The patch failed to build with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in .

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/8548//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/8548//console

          This message is automatically generated.

          Ayappan Ayappan added a comment -

          The build artifacts are missing from the build page.( https://builds.apache.org/job/PreCommit-HDFS-Build/8548/ ).
          The eclipse failure seems to be unrelated to this patch.

          Ayappan Ayappan added a comment -

          Any update on this ?

          hadoopqa Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12578160/HDFS-4681-v1.patch
          against trunk revision f92e503.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests in hadoop-hdfs-project/hadoop-hdfs:

          org.apache.hadoop.hdfs.server.namenode.TestFileTruncate

          Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/9208//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/9208//console

          This message is automatically generated.

          Ayappan Ayappan added a comment -

          TestFileTruncate failure seems to be unrelated to the patch

          hadoopqa Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12694769/HDFS-4681-v2.patch
          against trunk revision 0da53a3.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs.

          Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/9345//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/9345//console

          This message is automatically generated.

          Ayappan Ayappan added a comment -

          Can any maintainer commit this patch?

          Ayappan Ayappan added a comment -

          Any update on this ? This issue is lingering around for a long time.

          aw Allen Wittenauer added a comment -

          + 1 lgtm. I've committed this to trunk.

          Thanks!

          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #7229 (See https://builds.apache.org/job/Hadoop-trunk-Commit/7229/)
          HDFS-4681. TestBlocksWithNotEnoughRacks#testCorruptBlockRereplicatedAcrossRacks fails using IBM java (Ayappan via aw) (aw: rev dbc9b6433e9276057181cf4927cedf321acd354e)

          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/MiniDFSCluster.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/DFSTestUtil.java
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlocksWithNotEnoughRacks.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #119 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/119/)
          HDFS-4681. TestBlocksWithNotEnoughRacks#testCorruptBlockRereplicatedAcrossRacks fails using IBM java (Ayappan via aw) (aw: rev dbc9b6433e9276057181cf4927cedf321acd354e)

          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlocksWithNotEnoughRacks.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/DFSTestUtil.java
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/MiniDFSCluster.java
          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Yarn-trunk #853 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/853/)
          HDFS-4681. TestBlocksWithNotEnoughRacks#testCorruptBlockRereplicatedAcrossRacks fails using IBM java (Ayappan via aw) (aw: rev dbc9b6433e9276057181cf4927cedf321acd354e)

          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/DFSTestUtil.java
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlocksWithNotEnoughRacks.java
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/MiniDFSCluster.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Hdfs-trunk #2051 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2051/)
          HDFS-4681. TestBlocksWithNotEnoughRacks#testCorruptBlockRereplicatedAcrossRacks fails using IBM java (Ayappan via aw) (aw: rev dbc9b6433e9276057181cf4927cedf321acd354e)

          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlocksWithNotEnoughRacks.java
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/MiniDFSCluster.java
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/DFSTestUtil.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Hdfs-trunk-Java8 #110 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/110/)
          HDFS-4681. TestBlocksWithNotEnoughRacks#testCorruptBlockRereplicatedAcrossRacks fails using IBM java (Ayappan via aw) (aw: rev dbc9b6433e9276057181cf4927cedf321acd354e)

          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlocksWithNotEnoughRacks.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/MiniDFSCluster.java
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/DFSTestUtil.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #119 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/119/)
          HDFS-4681. TestBlocksWithNotEnoughRacks#testCorruptBlockRereplicatedAcrossRacks fails using IBM java (Ayappan via aw) (aw: rev dbc9b6433e9276057181cf4927cedf321acd354e)

          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/DFSTestUtil.java
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlocksWithNotEnoughRacks.java
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/MiniDFSCluster.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Mapreduce-trunk #2069 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2069/)
          HDFS-4681. TestBlocksWithNotEnoughRacks#testCorruptBlockRereplicatedAcrossRacks fails using IBM java (Ayappan via aw) (aw: rev dbc9b6433e9276057181cf4927cedf321acd354e)

          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/MiniDFSCluster.java
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/DFSTestUtil.java
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlocksWithNotEnoughRacks.java
          Ayappan Ayappan added a comment -

          Thanks Allen


            People

            • Assignee:
              Ayappan Ayappan
              Reporter:
              tianhonglouis Tian Hong Wang
            • Votes:
              1 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development