Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-446

Offline Image Viewer Ls visitor incorrectly says 'output file' instead of 'input file'

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.21.0
    • Fix Version/s: 0.21.0
    • Component/s: test, tools
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      In the finishAbnormally method of Ls Visitor it should be "input ended unexpectedly," not output. Trivial documentation change.

      1. HDFS-446.patch
        0.6 kB
        Jakob Homan
      2. HDFS-446.patch
        24 kB
        Jakob Homan

        Activity

        Jakob Homan added a comment -

        Attaching quick fix.

             [exec] -1 overall.  
             [exec] 
             [exec]     +1 @author.  The patch does not contain any @author tags.
             [exec] 
             [exec]     -1 tests included.  The patch doesn't appear to include any new or modified tests.
             [exec]                         Please justify why no new tests are needed for this patch.
             [exec]                         Also please list what manual steps were performed to verify this patch.
             [exec] 
             [exec]     -1 javadoc.  The javadoc tool appears to have generated 1 warning messages.
             [exec] 
             [exec]     +1 javac.  The applied patch does not increase the total number of javac compiler warnings.
             [exec] 
             [exec]     +1 findbugs.  The patch does not introduce any new Findbugs warnings.
             [exec] 
             [exec]     +1 release audit.  The applied patch does not increase the total number of release audit warnings.
        

        No new test as is output text change.

        Jakob Homan added a comment -

        submitting patch

        Jakob Homan added a comment -

        btw, test-patch technically failed:

        BUILD FAILED
        /private/tmp/ps5/hdfs/build.xml:1078: exec returned: 2

        but this is unrelated to the patch and I'm looking into it.

        Konstantin Shvachko added a comment -

        Could you please also fix some more cosmetic things here related to OIV.

        1. JavaDoc warnings:
          • ImageLoader.java:68: warning - @param argument "imageVersion" is not a parameter name.
          • ImageLoaderCurrent.java:155: warning - @param argument "numINUC" is not a parameter name.
          • LsImageVisitor.java:77: warning - Tag @throws cannot be used in field documentation. It can only be used in the following types of documentation: constructor, method.
        2. enum ImageElement should be in all capital letters as constants.
        3. "test.build.data" in testOIV should not be set to "/tmp", but rather to something relative to the current path say "build/test/oiv", like in TestHDFSServerPorts, so that clean build could automatically removed it.
        Jakob Homan added a comment -

        Canceling patch to address Konstantin's request.

        Jakob Homan added a comment -

        Updated patch per Konstantin's comments.

        Jakob Homan added a comment -

        submitting patch

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12412933/HDFS-446.patch
        against trunk revision 792310.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 10 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed core unit tests.

        -1 contrib tests. The patch failed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/11/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/11/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/11/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/11/console

        This message is automatically generated.

        Jakob Homan added a comment -

        Oy. The failing contrib test is unrelated. Hudson is currently broken for core tests, as it's looking for a target, " Target "create-c++-configure" does not exist in the project "Hadoop-Hdfs". ", which doesn't exist (as determined by Gary). I ran the unit tests locally and they all pass. Patch is good to go.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12412933/HDFS-446.patch
        against trunk revision 792310.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 10 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed core unit tests.

        -1 contrib tests. The patch failed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/13/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/13/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/13/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/13/console

        This message is automatically generated.

        Jakob Homan added a comment -

        Not sure why Hudson ran again. Failing contrib test is unrealted. Patch is still good to go.

        Konstantin Shvachko added a comment -

        I just committed this. Thank you Jakob.

        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #23 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Hdfs-trunk/23/)

        Tsz Wo Nicholas Sze added a comment -

        Hi Konstantin, should this belongs to BUG FIXES, instead of NEW FEATURES, in CHANGE.txt?

        Konstantin Shvachko added a comment -

        My mistake. I meant to add it to the IMPROVEMENTS section. It is definitely not a new feature. Not a bug either. Thanks.

        Tsz Wo Nicholas Sze added a comment -

        I have moved the message to the IMPROVEMENTS section.


          People

          • Assignee:
            Jakob Homan
            Reporter:
            Jakob Homan
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development