Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-439

HADOOP-5961 is incorrectly committed.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.21.0
    • Fix Version/s: 0.21.0
    • Component/s: None
    • Labels:
      None

      Description

      I committed HADOOP-5961 even though one of the test failures was caused by the patch. I didn't check properly.

      I will attach a patch.

      1. HDFS-439.patch
        0.9 kB
        Raghu Angadi

        Issue Links

          Activity

          Raghu Angadi created issue -
          Raghu Angadi made changes -
          Field Original Value New Value
          Link This issue relates to HADOOP-5961 [ HADOOP-5961 ]
          Nigel Daley made changes -
          Priority Major [ 3 ] Blocker [ 1 ]
          Description
          I committed HADOOP-5961 even though one of the test failures was caused by the patch. I didn't check properly.

          I will attach a patch.
          I committed HADOOP-5961 even though one of the test failures was caused by the patch. I didn't check properly.

          I will attach a patch.
          Raghu Angadi made changes -
          Project Hadoop Common [ 12310240 ] HDFS [ 12310942 ]
          Key HADOOP-6094 HDFS-439
          Affects Version/s 0.21.0 [ 12314046 ]
          Affects Version/s 0.21.0 [ 12313563 ]
          Fix Version/s 0.21.0 [ 12314046 ]
          Fix Version/s 0.21.0 [ 12313563 ]
          Raghu Angadi added a comment -

          I cannot reproduce NPE in TestHdfsProxy in my environment. But the attached patch should handle the NPE in the test failure.

          Raghu Angadi made changes -
          Attachment HDFS-439.patch [ 12411721 ]
          Raghu Angadi made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Kan Zhang added a comment -

          +1

          Raghu Angadi made changes -
          Status Patch Available [ 10002 ] Open [ 1 ]
          Raghu Angadi made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12411721/HDFS-439.patch
          against trunk revision 790733.

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed core unit tests.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/6/testReport/
          Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/6/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/6/artifact/trunk/build/test/checkstyle-errors.html
          Console output: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/6/console

          This message is automatically generated.

          zhiyong zhang made changes -
          Link This issue is depended upon by HDFS-473 [ HDFS-473 ]
          Tsz Wo Nicholas Sze added a comment -

          According to Zhiyong's comment, HDFS-473 is related to this. Do you agree?

          Raghu Angadi added a comment -

          Yes. We could not reproduce this but Hudson build with this patch does not have NPE. I am planning to commit this today.

          Raghu Angadi added a comment -

          I just committed this.

          Raghu Angadi made changes -
          Status Patch Available [ 10002 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Tom White made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Patch Available Patch Available Open Open
          13d 2h 31m 1 Raghu Angadi 08/Jul/09 01:54
          Open Open Patch Available Patch Available
          5d 2h 47m 2 Raghu Angadi 08/Jul/09 01:54
          Patch Available Patch Available Resolved Resolved
          2d 20h 3m 1 Raghu Angadi 10/Jul/09 21:57
          Resolved Resolved Closed Closed
          409d 23h 50m 1 Tom White 24/Aug/10 21:48

            People

            • Assignee:
              Raghu Angadi
              Reporter:
              Raghu Angadi
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development