Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.0
    • Fix Version/s: 1.2.0
    • Component/s: test
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      testMultipleSecondaryNameNodes doesn't shutdown the SecondaryNameNode which causes testCheckpoint to fail.

      Testcase: testCheckpoint took 2.736 sec
      Caused an ERROR
      Cannot lock storage C:\hdp1-2\build\test\data\dfs\namesecondary1. The directory is already locked.
      java.io.IOException: Cannot lock storage C:\hdp1-2\build\test\data\dfs\namesecondary1. The directory is already locked.
      at org.apache.hadoop.hdfs.server.common.Storage$StorageDirectory.lock(Storage.java:602)
      at org.apache.hadoop.hdfs.server.common.Storage$StorageDirectory.analyzeStorage(Storage.java:455)
      at org.apache.hadoop.hdfs.server.namenode.SecondaryNameNode$CheckpointStorage.recoverCreate(SecondaryNameNode.java:644)
      at org.apache.hadoop.hdfs.server.namenode.SecondaryNameNode.initialize(SecondaryNameNode.java:178)
      at org.apache.hadoop.hdfs.server.namenode.SecondaryNameNode.<init>(SecondaryNameNode.java:132)
      at org.apache.hadoop.hdfs.server.namenode.TestCheckpoint.startSecondaryNameNode(TestCheckpoint.java:560)
      at org.apache.hadoop.hdfs.server.namenode.TestCheckpoint.testCheckpoint(TestCheckpoint.java:596)

      This does not reproduce with JDK6 because the testcase execution order is different.

      1. HDFS-4358.patch
        1 kB
        Arpit Agarwal

        Activity

        Arpit Agarwal added a comment -

        The fix is to shutdown the SecondaryNameNode from testMultipleSecondaryNameNodes.

        Suresh Srinivas added a comment -

        +1

        Suresh Srinivas added a comment -

        Patch committed to branch-1. Thank you Arpit!

        Matt Foley added a comment -

        Closed upon release of Hadoop 1.2.0.


          People

          • Assignee:
            Arpit Agarwal
            Reporter:
            Arpit Agarwal
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development