Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-4310

fix test org.apache.hadoop.hdfs.server.datanode.TestStartSecureDataNode

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0-alpha1
    • Fix Version/s: 3.0.0-alpha1
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      the test org/apache/hadoop/hdfs/server/datanode/TestStartSecureDataNode catches exceptions and does not re-throw them. Due to that it passes even if it actually failed.

      1. HDFS-4310.patch
        2 kB
        Ivan A. Veselovsky

        Activity

        hudson Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #1285 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1285/)
        HDFS-4310. fix test org.apache.hadoop.hdfs.server.datanode.TestStartSecureDataNode Contributed by Ivan A. Veselovsky. (Revision 1421560)

        Result = SUCCESS
        atm : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1421560
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/datanode/TestStartSecureDataNode.java
        hudson Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #1254 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1254/)
        HDFS-4310. fix test org.apache.hadoop.hdfs.server.datanode.TestStartSecureDataNode Contributed by Ivan A. Veselovsky. (Revision 1421560)

        Result = FAILURE
        atm : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1421560
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/datanode/TestStartSecureDataNode.java
        hudson Hudson added a comment -

        Integrated in Hadoop-Yarn-trunk #65 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/65/)
        HDFS-4310. fix test org.apache.hadoop.hdfs.server.datanode.TestStartSecureDataNode Contributed by Ivan A. Veselovsky. (Revision 1421560)

        Result = SUCCESS
        atm : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1421560
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/datanode/TestStartSecureDataNode.java
        hudson Hudson added a comment -

        Integrated in Hadoop-trunk-Commit #3120 (See https://builds.apache.org/job/Hadoop-trunk-Commit/3120/)
        HDFS-4310. fix test org.apache.hadoop.hdfs.server.datanode.TestStartSecureDataNode Contributed by Ivan A. Veselovsky. (Revision 1421560)

        Result = SUCCESS
        atm : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1421560
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/datanode/TestStartSecureDataNode.java
        atm Aaron T. Myers added a comment -

        +1, the patch looks good to me.

        I've just committed this to trunk. Thanks a lot for the contribution, Ivan.

        hadoopqa Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12560833/HDFS-4310.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/3657//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/3657//console

        This message is automatically generated.

        atm Aaron T. Myers added a comment -

        OK, fine by me.

        iveselovsky Ivan A. Veselovsky added a comment -

        Hi, Aaron,
        yes , but the problem is that we should shutdown the minicluster in the finally block. And if another exception is thrown from here, we may lose the original exception thrown from the try

        { ... }

        block. So, such construction is somewhat more reliable.

        atm Aaron T. Myers added a comment -

        Hey Ivan, let's just have the test throw the exception without catching/printing first. An exception which is thrown by a test method will get printed to the log anyway, so there's no need to duplicate that behavior.


          People

          • Assignee:
            iveselovsky Ivan A. Veselovsky
            Reporter:
            iveselovsky Ivan A. Veselovsky
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development