Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-4288

NN accepts incremental BR as IBR in safemode

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 0.23.0, 2.0.0-alpha, 3.0.0
    • Fix Version/s: 2.0.3-alpha, 0.23.7
    • Component/s: namenode
    • Labels:
      None

      Description

      If a DN is ready to send an incremental BR and the NN goes down, the DN will repeatedly try to reconnect. The NN will then process the DN's incremental BR as an initial BR. The NN now thinks the DN has only a few blocks, and will ignore all subsequent BRs from that DN until out of safemode – which it may never do because of all the "missing" blocks on the affected DNs.

      1. HDFS-4288.branch-23.patch
        3 kB
        Daryn Sharp
      2. HDFS-4288.patch
        7 kB
        Daryn Sharp
      3. HDFS-4288.branch-23.patch
        10 kB
        Daryn Sharp
      4. HDFS-4288.patch
        8 kB
        Daryn Sharp

        Issue Links

          Activity

          Daryn Sharp added a comment -

          Non-23 branches appear to have a rudimentary fix for this issue. However it appears (haven't tested) that if a node registers in safe mode with 500 blocks, then bounces and re-registers with only 100 blocks because maybe a disk died, the NN will ignore that BR if it's still in safemode. The NN may come out of safe mode w/o realizing it doesn't really have all the replicas it needs, and probably won't issue replications until the next full BR is sent which increases the possibility of data loss.

          Aaron T. Myers added a comment -

          Non-23 branches appear to have a rudimentary fix for this issue.

          Can you point out what exactly it is in branch-2 and trunk which appears to have fixed this?

          Daryn Sharp added a comment -

          Suresh pointed me at HDFS-2753, which erroneously attributes the issue to HA.

          Daryn Sharp added a comment -

          I think the second issue I mentioned regarding a bounced DN's BR not being processed can be solved have updateRegInfo reset the flag that short-circuits safemode BR processing. I originally tried something that tracked the timestamp of the registration but I think this is much simpler. It'll be trivial to tweak the patch for the other branches.

          Aaron, if this is a reasonable fix, would you please help write some unit tests? I'm having difficulty figuring out how to introduce a mock, or how to manipulate a mini-cluster to force the sequence of events to reproduce (ie. sync out a few blocks, stop NN, finalize last block, bring NN up in safemode and trick it into staying in safemode, ensure block update is received followed by block report, ensure block manager knows of all blocks; stop dn, remove blocks, re-reg in safemode and ensure NN forgets the removed blocks). Plus I'm at a conference and don't have many cycles.

          Daryn Sharp added a comment -

          Any comments from anyone? Or any bright ideas on how to write tests? I'll manually test if that sufficient?

          Suresh Srinivas added a comment - - edited

          Suresh pointed me at HDFS-2753, which erroneously attributes the issue to HA

          To be fair, the context of that issue was HA.

          Suresh Srinivas added a comment -

          Thinking about the problem a bit, what we need is a way to indicate if this is the first block report from datanode itself. So adding a counter starting with 0 (to indicate first block report) in block reports from datanode to namenode should help solve the problem. With this we can get rid of the DatanodeDescriptor#firstBlockReport and related code. This will also solve issues related to DN restart and NN may not process the block report.

          Daryn Sharp added a comment -

          This will also solve issues related to DN restart and NN may not process the block report.

          True, but the boolean patch (simple incremental improvement on the existing trunk behavior) fixes both DN restart and reregistration after a broken connection. The NN cannot distinguish the two. So with a boolean, the NN (naively) processes the BR associated with every (re)registration.

          A sequence number, that relies on a sentinel value, allows the DN to dictate the NN's behavior. This works well for restart since we know we are starting from 0. For a rereg, block updates may have been lost, so the sequence number must be guaranteed to always be reset to 0. That's naive like the boolean, and might be hard or fragile to ensure it's always reset - in which case we might as well go with the boolean.

          Better yet, the logic would be to (seqNum == 0 || seqNum != lastSeqNum). However this requires writable/RPC changes on 23, and protobuf changes on trunk/2 and trying to ensure backwards compatibility with an optional protobuf field, etc. Would you be ok if I filed another jira?

          Suresh Srinivas added a comment -

          Better yet, the logic would be to (seqNum == 0 || seqNum != lastSeqNum). However this requires writable/RPC changes on 23, and protobuf changes on trunk/2 and trying to ensure backwards compatibility with an optional protobuf field, etc. Would you be ok if I filed another jira?

          Separate jira should be fine. We may want to mark this jira as 0.23 only.

          Daryn Sharp added a comment -

          The change does fix the DN restart issue for trunk/2. Other than a few tweaks to enable testing, it's a 1-line change for trunk. I'll post that patch, followed by an amended patch for 23.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12564286/HDFS-4288.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests in hadoop-hdfs-project/hadoop-hdfs:

          org.apache.hadoop.hdfs.TestPersistBlocks

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/3816//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/3816//console

          This message is automatically generated.

          Daryn Sharp added a comment -

          TestPersistBlocks failure is unrelated to this jira - I was very paranoid in debugging the failure. The problem is caused by the new retry IPC retry policies introduced by HA. I filed HDFS-4389.

          Kihwal Lee added a comment -

          +1 I ended up reviewing the patch while debugging the above test failure with Daryn.

          Todd Lipcon added a comment -

          The patch looks good.

          While we're in this area, do we need to reset any of the other fields in DatanodeDescriptor back to their defaults on re-reg? eg blockContentsStale, heartbeatedSinceFailover, needsKeyUpdate, etc? That is to say, I think this is a correct fix (and +1 to commit it), but wondering if you guys think we might have any other similar bugs that should be considered.

          Todd Lipcon added a comment -

          I committed this to branch-2 and to trunk. I'll let you guys commit to branch-0.23 at your own pace - hope that's OK.

          Hudson added a comment -

          Integrated in Hadoop-trunk-Commit #3247 (See https://builds.apache.org/job/Hadoop-trunk-Commit/3247/)
          HDFS-4288. NN accepts incremental BR as IBR in safemode. Contributed by Daryn Sharp. (Revision 1433755)

          Result = SUCCESS
          todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1433755
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockManager.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeDescriptor.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeManager.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlockManager.java
          Todd Lipcon added a comment -

          This now seems to be failing on precommit builds even though it passed its own precommit build above:
          java.lang.AssertionError: Number of blocks is inconcistent with the array length
          at org.apache.hadoop.hdfs.protocol.BlockListAsLongs.getNumberOfBlocks(BlockListAsLongs.java:204)
          at org.apache.hadoop.hdfs.protocol.BlockListAsLongs$BlockReportIterator.hasNext(BlockListAsLongs.java:153)
          at org.apache.hadoop.hdfs.server.blockmanagement.BlockManager.processFirstBlockReport(BlockManager.java:1672)
          at org.apache.hadoop.hdfs.server.blockmanagement.BlockManager.processReport(BlockManager.java:1558)
          at org.apache.hadoop.hdfs.server.blockmanagement.TestBlockManager.testSafeModeIBR(TestBlockManager.java:511)

          I'm able to reproduce locally as well. Not sure what changed on trunk between the precommit run last week and now, but seems to be causing issues. I'll revert this for now.

          Hudson added a comment -

          Integrated in Hadoop-trunk-Commit #3248 (See https://builds.apache.org/job/Hadoop-trunk-Commit/3248/)
          Revert r1433755: HDFS-4288. NN accepts incremental BR as IBR in safemode. Contributed by Daryn Sharp.

          This commit caused TestBlockManager to fail. (Revision 1433820)

          Result = SUCCESS
          todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1433820
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockManager.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeDescriptor.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeManager.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlockManager.java
          Hudson added a comment -

          Integrated in Hadoop-Yarn-trunk #98 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/98/)
          Revert r1433755: HDFS-4288. NN accepts incremental BR as IBR in safemode. Contributed by Daryn Sharp.

          This commit caused TestBlockManager to fail. (Revision 1433820)
          HDFS-4288. NN accepts incremental BR as IBR in safemode. Contributed by Daryn Sharp. (Revision 1433755)

          Result = SUCCESS
          todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1433820
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockManager.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeDescriptor.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeManager.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlockManager.java

          todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1433755
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockManager.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeDescriptor.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeManager.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlockManager.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #1287 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1287/)
          Revert r1433755: HDFS-4288. NN accepts incremental BR as IBR in safemode. Contributed by Daryn Sharp.

          This commit caused TestBlockManager to fail. (Revision 1433820)
          HDFS-4288. NN accepts incremental BR as IBR in safemode. Contributed by Daryn Sharp. (Revision 1433755)

          Result = FAILURE
          todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1433820
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockManager.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeDescriptor.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeManager.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlockManager.java

          todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1433755
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockManager.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeDescriptor.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeManager.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlockManager.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk #1315 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1315/)
          Revert r1433755: HDFS-4288. NN accepts incremental BR as IBR in safemode. Contributed by Daryn Sharp.

          This commit caused TestBlockManager to fail. (Revision 1433820)
          HDFS-4288. NN accepts incremental BR as IBR in safemode. Contributed by Daryn Sharp. (Revision 1433755)

          Result = FAILURE
          todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1433820
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockManager.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeDescriptor.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeManager.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlockManager.java

          todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1433755
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockManager.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeDescriptor.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeManager.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlockManager.java
          Daryn Sharp added a comment -

          Updated 23 patch, removed a seemingly unnecessary assert in trunk and 23 that prevented using a mock object. It was testing that the node is null or the class it was just explicitly casted to. The cast would have thrown an exception if it was invalid.

          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12565167/HDFS-4288.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/3848//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/3848//console

          This message is automatically generated.

          Daryn Sharp added a comment -

          This now seems to be failing on precommit builds even though it passed its own precommit build above: java.lang.AssertionError: Number of blocks is inconcistent with the array length

          This is caused by a bug in some of BlockListAsLongs ctors. I filed HDFS-4410 and used the "good" ctor in the latest patches.

          Daryn Sharp added a comment -

          @Todd: I forgot to mention it passed the apache pre-commit because asserts became disabled on trunk. Your internal builds must have asserts enabled. I filed HDFS-4410 about it.

          Daryn Sharp added a comment -

          Err, assert jira is HDFS-4411.

          Todd Lipcon added a comment -

          Hrm... it wasn't an internal build, but rather an HDFS precommit build which failed. See https://builds.apache.org/job/PreCommit-HDFS-Build/3845//testReport/ for example.

          Daryn Sharp added a comment -

          I encountered the issue when I manually enabled asserts. The latest patches resolve the issue by avoiding the buggy ctors.

          Kihwal Lee added a comment -

          +1 The test case in the latest patch seems avoiding the assertion failure.

          Hudson added a comment -

          Integrated in Hadoop-trunk-Commit #3295 (See https://builds.apache.org/job/Hadoop-trunk-Commit/3295/)
          HDFS-4288. NN accepts incremental BR as IBR in safemode. contributed by Daryn Sharp. (Revision 1440192)

          Result = SUCCESS
          kihwal : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1440192
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockInfo.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockManager.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeDescriptor.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeManager.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlockManager.java
          Kihwal Lee added a comment -

          Thanks Daryn. I committed this to branch-0.23, branch-2 and trunk.

          Hudson added a comment -

          Integrated in Hadoop-Yarn-trunk #112 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/112/)
          HDFS-4288. NN accepts incremental BR as IBR in safemode. contributed by Daryn Sharp. (Revision 1440192)

          Result = SUCCESS
          kihwal : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1440192
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockInfo.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockManager.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeDescriptor.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeManager.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlockManager.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-0.23-Build #510 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/510/)
          HDFS-4288. NN accepts incremental BR as IBR in safemode. Contributed by Daryn Sharp. (Revision 1440201)

          Result = SUCCESS
          kihwal : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1440201
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockInfo.java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockManager.java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeDescriptor.java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeManager.java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/protocol/DatanodeRegistration.java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlockManager.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #1301 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1301/)
          HDFS-4288. NN accepts incremental BR as IBR in safemode. contributed by Daryn Sharp. (Revision 1440192)

          Result = SUCCESS
          kihwal : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1440192
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockInfo.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockManager.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeDescriptor.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeManager.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlockManager.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk #1329 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1329/)
          HDFS-4288. NN accepts incremental BR as IBR in safemode. contributed by Daryn Sharp. (Revision 1440192)

          Result = SUCCESS
          kihwal : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1440192
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockInfo.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockManager.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeDescriptor.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeManager.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlockManager.java

            People

            • Assignee:
              Daryn Sharp
              Reporter:
              Daryn Sharp
            • Votes:
              0 Vote for this issue
              Watchers:
              15 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development