Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-2802 Support for RW/RO snapshots in HDFS
  3. HDFS-4189

rename getter method getMutableX and getXMutable to getXAndEnsureMutable

    XMLWordPrintableJSON

    Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: Snapshot (HDFS-2802)
    • Fix Version/s: Snapshot (HDFS-2802)
    • Component/s: namenode
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      The method names with the form "getMutableXxx" may be misleading. Let's rename them.

        Attachments

        1. h4189_20130130.patch
          28 kB
          Tsz-wo Sze
        2. h4189_20130131.patch
          28 kB
          Tsz-wo Sze

          Activity

            People

            • Assignee:
              szetszwo Tsz-wo Sze
              Reporter:
              brandonli Brandon Li
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: