Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-3819

Should check whether invalidate work percentage default value is not greater than 1.0f

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.2-alpha
    • Fix Version/s: 1.2.0, 2.0.2-alpha
    • Component/s: None
    • Labels:
      None

      Description

      In DFSUtil#getInvalidateWorkPctPerIteration we should also check that the configured value is not greater than 1.0f.

      1. HDFS-3819_branch1.1.patch
        2 kB
        Jing Zhao
      2. HDFS-3819.patch
        4 kB
        Jing Zhao
      3. HDFS-3819.patch
        4 kB
        Jing Zhao

        Issue Links

          Activity

          Aaron T. Myers added a comment -

          Hi Jing, please don't set the "fix version" field until the change is committed. Instead, please set the "target version" field to indicate what version you're targeting.

          Changing affects/targets versions to 2.2.0-alpha.

          Jing Zhao added a comment -

          Thanks Aaron! I also attach the patch for branch 1.1 for the same change.

          Aaron T. Myers added a comment -

          Cool, thanks Jing. You should mark the JIRA "patch available" when you upload a patch, so that the Jenkins pre-commit test-patch runs. You can do that by clicking the "submit patch" button. Note also that test-patch doesn't work on any branch except for trunk.

          Aaron T. Myers added a comment -

          The patch looks good to me. +1 pending Jenkins.

          Suresh Srinivas added a comment -

          Aaron, I am not able to login to builds.apache.org. Meanwhile, can you please trigger a precommit build for this jira.

          Aaron T. Myers added a comment -

          Certainly. I've just done so.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12541650/HDFS-3819.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          -1 findbugs. The patch appears to introduce 1 new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/3063//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HDFS-Build/3063//artifact/trunk/patchprocess/newPatchFindbugsWarningshadoop-hdfs.html
          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/3063//console

          This message is automatically generated.

          Jing Zhao added a comment -

          The findbug warning is not caused by this patch and has been fixed by HDFS-3837.

          Jitendra Nath Pandey added a comment -

          +1.

          Hudson added a comment -

          Integrated in Hadoop-Common-trunk-Commit #2621 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/2621/)
          HDFS-3819. Should check whether invalidate work percentage default value is not greater than 1.0f. Contributed by Jing Zhao. (Revision 1376185)

          Result = SUCCESS
          jitendra : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1376185
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/DFSUtil.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestReplicationPolicy.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk-Commit #2685 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/2685/)
          HDFS-3819. Should check whether invalidate work percentage default value is not greater than 1.0f. Contributed by Jing Zhao. (Revision 1376185)

          Result = SUCCESS
          jitendra : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1376185
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/DFSUtil.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestReplicationPolicy.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk-Commit #2649 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/2649/)
          HDFS-3819. Should check whether invalidate work percentage default value is not greater than 1.0f. Contributed by Jing Zhao. (Revision 1376185)

          Result = FAILURE
          jitendra : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1376185
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/DFSUtil.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestReplicationPolicy.java
          Jitendra Nath Pandey added a comment -

          Committed to trunk and branch-1. Thanks to Jing.

          Aaron T. Myers added a comment -

          Jitendra, did you not commit this to branch-2 as well? If you're going to commit something to trunk and branch-1, you should also commit it to branch-2.

          Also, please set the "fix version" field appropriately.

          Jitendra Nath Pandey added a comment -

          Committed to branch-2 as well. Thanks for pointing out Aaron.

          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #1143 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1143/)
          HDFS-3819. Should check whether invalidate work percentage default value is not greater than 1.0f. Contributed by Jing Zhao. (Revision 1376185)

          Result = FAILURE
          jitendra : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1376185
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/DFSUtil.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestReplicationPolicy.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk #1175 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1175/)
          HDFS-3819. Should check whether invalidate work percentage default value is not greater than 1.0f. Contributed by Jing Zhao. (Revision 1376185)

          Result = FAILURE
          jitendra : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1376185
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/DFSUtil.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestReplicationPolicy.java

            People

            • Assignee:
              Jing Zhao
              Reporter:
              Jing Zhao
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development