> 1. It would be good to move all the code from DataXceiver.run() that reads operations and the switch statement to DataTransferProtocol.Receiver and just call right opXXX() method implemented by subclasses
This is a good suggestion. I tried doing it before. It requires some logic changes. I would like to keep this a copy-and-paste patch. Let do it in a separated jira.
> 2. DataTransferProtocol.opBlockCheckSum() calls opCopyBlock() instead of opBlockCheckSum()
Thank you for the comments, Suresh.