Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-3399 BookKeeper option support for NN HA
  3. HDFS-3441

Race condition between rolling logs at active NN and purging at standby

    Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-alpha
    • Fix Version/s: 2.0.2-alpha
    • Component/s: None
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      Standby NN has got the ledgerlist with list of all files, including the inprogress file (with say inprogress_val1)
      Active NN has done finalization and created new inprogress file.
      Standby when proceeds further finds that the inprogress file which it had in the list is not present and NN gets shutdown

      NN Logs
      =========
      2012-05-17 22:15:03,867 INFO org.apache.hadoop.hdfs.server.namenode.FSImage: Image file of size 201 saved in 0 seconds.
      2012-05-17 22:15:03,874 INFO org.apache.hadoop.hdfs.server.namenode.ha.EditLogTailer: Triggering log roll on remote NameNode /xx.xx.xx.102:8020
      2012-05-17 22:15:03,923 INFO org.apache.hadoop.hdfs.server.namenode.NNStorageRetentionManager: Going to retain 2 images with txid >= 111
      2012-05-17 22:15:03,923 INFO org.apache.hadoop.hdfs.server.namenode.NNStorageRetentionManager: Purging old image FSImageFile(file=/home/May8/hadoop-3.0.0-SNAPSHOT/hadoop-root/dfs/name/current/fsimage_0000000000000000109, cpktTxId=0000000000000000109)
      2012-05-17 22:15:03,961 FATAL org.apache.hadoop.hdfs.server.namenode.FSEditLog: Error: purgeLogsOlderThan 0 failed for required journal (JournalAndStream(mgr=org.apache.hadoop.contrib.bkjournal.BookKeeperJournalManager@142e6767, stream=null))
      java.io.IOException: Exception reading ledger list from zk
      at org.apache.hadoop.contrib.bkjournal.BookKeeperJournalManager.getLedgerList(BookKeeperJournalManager.java:531)
      at org.apache.hadoop.contrib.bkjournal.BookKeeperJournalManager.purgeLogsOlderThan(BookKeeperJournalManager.java:444)
      at org.apache.hadoop.hdfs.server.namenode.JournalSet$5.apply(JournalSet.java:541)
      at org.apache.hadoop.hdfs.server.namenode.JournalSet.mapJournalsAndReportErrors(JournalSet.java:322)
      at org.apache.hadoop.hdfs.server.namenode.JournalSet.purgeLogsOlderThan(JournalSet.java:538)
      at org.apache.hadoop.hdfs.server.namenode.FSEditLog.purgeLogsOlderThan(FSEditLog.java:1011)
      at org.apache.hadoop.hdfs.server.namenode.NNStorageRetentionManager.purgeOldStorage(NNStorageRetentionManager.java:98)
      at org.apache.hadoop.hdfs.server.namenode.FSImage.purgeOldStorage(FSImage.java:900)
      at org.apache.hadoop.hdfs.server.namenode.FSImage.saveFSImageInAllDirs(FSImage.java:885)
      at org.apache.hadoop.hdfs.server.namenode.FSImage.saveNamespace(FSImage.java:822)
      at org.apache.hadoop.hdfs.server.namenode.ha.StandbyCheckpointer.doCheckpoint(StandbyCheckpointer.java:157)
      at org.apache.hadoop.hdfs.server.namenode.ha.StandbyCheckpointer.access$900(StandbyCheckpointer.java:52)
      at org.apache.hadoop.hdfs.server.namenode.ha.StandbyCheckpointer$CheckpointerThread.doWork(StandbyCheckpointer.java:279)
      at org.apache.hadoop.hdfs.server.namenode.ha.StandbyCheckpointer$CheckpointerThread.access$300(StandbyCheckpointer.java:200)
      at org.apache.hadoop.hdfs.server.namenode.ha.StandbyCheckpointer$CheckpointerThread$1.run(StandbyCheckpointer.java:220)
      at org.apache.hadoop.security.SecurityUtil.doAsLoginUserOrFatal(SecurityUtil.java:512)
      at org.apache.hadoop.hdfs.server.namenode.ha.StandbyCheckpointer$CheckpointerThread.run(StandbyCheckpointer.java:216)
      Caused by: org.apache.zookeeper.KeeperException$NoNodeException: KeeperErrorCode = NoNode for /nnedits/ledgers/inprogress_72
      at org.apache.zookeeper.KeeperException.create(KeeperException.java:111)
      at org.apache.zookeeper.KeeperException.create(KeeperException.java:51)
      at org.apache.zookeeper.ZooKeeper.getData(ZooKeeper.java:1113)
      at org.apache.zookeeper.ZooKeeper.getData(ZooKeeper.java:1142)
      at org.apache.hadoop.contrib.bkjournal.EditLogLedgerMetadata.read(EditLogLedgerMetadata.java:113)
      at org.apache.hadoop.contrib.bkjournal.BookKeeperJournalManager.getLedgerList(BookKeeperJournalManager.java:528)
      ... 16 more
      2012-05-17 22:15:03,963 INFO org.apache.hadoop.hdfs.server.namenode.NameNode: SHUTDOWN_MSG:

      ZK Data
      ================

      [zk: xx.xx.xx.55:2182(CONNECTED) 9] get /nnedits/ledgers/inprogress_74
      -40;59;116
      cZxid = 0x2be
      ctime = Thu May 17 22:15:03 IST 2012
      mZxid = 0x2be
      mtime = Thu May 17 22:15:03 IST 2012
      pZxid = 0x2be
      cversion = 0
      dataVersion = 0
      aclVersion = 0
      ephemeralOwner = 0x0
      dataLength = 10
      numChildren = 0

      1. HDFS-3441.patch
        4 kB
        Rakesh R
      2. HDFS-3441.3.patch
        8 kB
        Rakesh R
      3. HDFS-3441.3.patch
        8 kB
        Uma Maheswara Rao G
      4. HDFS-3441.2.patch
        8 kB
        Rakesh R
      5. HDFS-3441.1.patch
        6 kB
        Rakesh R

        Activity

        Rakesh R added a comment -

        Yeah, I have seen a race condition between the purgeLogsOlderThan() by Standby and the finalizeLogSegment() by Active.

        Cause: Following are the sequence of operations happening:
        1) When standby comes to purge, it is reading all the list of ledger logs including the inprogress_72 files.
        2) Meantime Active NN is finalizing the logSegment inprogress_72 and creating new inprogress_74.
        3) Now the Standby is reading the data of inprogress_72 to decide whether its inprogress or not and is throwing NoNodeException.

        I feel, the filtering of inprogress file could be done based on the file name itself, instead of reading the content and filtering based on the data like as follows:

        BookKeeperJournalManager.java

            List<String> ledgerNames = zkc.getChildren(ledgerPath, false);
              for (String ledgerName : ledgerNames) {
                if( !inProgressOk && ledgerName.contains("inprogress") ){
                  continue;
                }
                ledgers.add(EditLogLedgerMetadata.read(zkc, ledgerPath + "/" + ledgerName));
              }
            } catch (Exception e) {
              throw new IOException("Exception reading ledger list from zk", e);
            }
        
        Ivan Kelly added a comment -

        This solution looks good to me. Will you generate a patch?

        Rakesh R added a comment -

        Yeah, I'll update soon.

        Uma Maheswara Rao G added a comment -

        Similar issue can exist in FileJournalManager, but we are just ignoring any issues on delete.

        if (!file.delete())

        { // It's OK if we fail to delete something -- we'll catch it // next time we swing through this directory. LOG.warn("Could not delete " + file); }

        Yes, Agree with Rakesh, We can just ignore it.

        Rakesh R added a comment -

        I'm attaching initial patch for reference, this is what I have in my mind. Please review the fix. I'll add few tests.

        This has to be applied on top of HDFS-3058.

        When reviewing, I have seen few more race condition between
        1) finalizeLogSegment() and getInputStreams(),
        2) finalizeLogSegment() and getNumberOfTransactions()

        That is the reason I have ignored the NoNodeException in the patch. I feel, ignoring and continuing would not cause any inconsistencies.

        Ivan Kelly added a comment -

        Patch looks good to me. It would be good to have some testing though.

        Uma Maheswara Rao G added a comment -

        HDFS-3058 and HDFS-3452 committed. You have to re-base your patch along with your tests on top of that.

        Rakesh R added a comment -

        Thanks Ivan and Uma.
        Updated the patch by addressing the comments. Please review.

        Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12530189/HDFS-3441.1.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs/src/contrib/bkjournal.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/2544//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/2544//console

        This message is automatically generated.

        Ivan Kelly added a comment -

        the code of the patch looks good. I think the test should be a little lower level and more explicit though. Its not clear that the new code path is actually getting exercised. Make getLedgerList() package private, and test that when you getChildren() returns a list of ledgers, and some do not exist when the read occurs, that you still get the others back fine. For this you would have to use spy() instead of mock(), and just stub out the getData() method.

        Rakesh R added a comment -

        Thanks Ivan for the comments.
        I have attached the patch with modified test case. Please have a look on this.

        Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12530361/HDFS-3441.2.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs/src/contrib/bkjournal.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/2550//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/2550//console

        This message is automatically generated.

        Ivan Kelly added a comment -

        looks good. Just needs a small tweak in the test.

        + List<String> ledgerNames = new ArrayList<String>(1);
        + ledgerNames.add("editlog_120_121");

        ledgerNames is never used now.

        Rakesh R added a comment -

        Updated the patch by addressing the Ivan comments.

        Ivan Kelly added a comment -

        Latest patch is good. +1 from me.

        Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12530389/HDFS-3441.3.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs/src/contrib/bkjournal.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/2552//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/2552//console

        This message is automatically generated.

        Uma Maheswara Rao G added a comment -

        This is what i have committed. Resolved the TestBookKeeperJournalManager conflicts with HDFS-3423 and removed one unused import ArrayList in TestBookKeeperJournalManager.

        Uma Maheswara Rao G added a comment -

        I have committed this to trunk and branch-2. Thanks a lot, Rakesh for the patch.
        Thanks a lot, Ivan for the reviews!

        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #2324 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/2324/)
        HDFS-3441. Race condition between rolling logs at active NN and purging at standby. Contributed by Rakesh R. (Revision 1344874)

        Result = FAILURE
        umamahesh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1344874
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/contrib/bkjournal/src/main/java/org/apache/hadoop/contrib/bkjournal/BookKeeperJournalManager.java
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/contrib/bkjournal/src/test/java/org/apache/hadoop/contrib/bkjournal/TestBookKeeperJournalManager.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #2379 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/2379/)
        HDFS-3441. Race condition between rolling logs at active NN and purging at standby. Contributed by Rakesh R. (Revision 1344874)

        Result = SUCCESS
        umamahesh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1344874
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/contrib/bkjournal/src/main/java/org/apache/hadoop/contrib/bkjournal/BookKeeperJournalManager.java
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/contrib/bkjournal/src/test/java/org/apache/hadoop/contrib/bkjournal/TestBookKeeperJournalManager.java
        Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #2307 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/2307/)
        HDFS-3441. Race condition between rolling logs at active NN and purging at standby. Contributed by Rakesh R. (Revision 1344874)

        Result = SUCCESS
        umamahesh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1344874
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/contrib/bkjournal/src/main/java/org/apache/hadoop/contrib/bkjournal/BookKeeperJournalManager.java
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/contrib/bkjournal/src/test/java/org/apache/hadoop/contrib/bkjournal/TestBookKeeperJournalManager.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #1063 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1063/)
        HDFS-3441. Race condition between rolling logs at active NN and purging at standby. Contributed by Rakesh R. (Revision 1344874)

        Result = SUCCESS
        umamahesh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1344874
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/contrib/bkjournal/src/main/java/org/apache/hadoop/contrib/bkjournal/BookKeeperJournalManager.java
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/contrib/bkjournal/src/test/java/org/apache/hadoop/contrib/bkjournal/TestBookKeeperJournalManager.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #1097 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1097/)
        HDFS-3441. Race condition between rolling logs at active NN and purging at standby. Contributed by Rakesh R. (Revision 1344874)

        Result = SUCCESS
        umamahesh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1344874
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/contrib/bkjournal/src/main/java/org/apache/hadoop/contrib/bkjournal/BookKeeperJournalManager.java
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/contrib/bkjournal/src/test/java/org/apache/hadoop/contrib/bkjournal/TestBookKeeperJournalManager.java

          People

          • Assignee:
            Rakesh R
            Reporter:
            suja s
          • Votes:
            0 Vote for this issue
            Watchers:
            10 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development