Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-3417

Rename BalancerDatanode#getName to getDisplayName to be consistent with Datanode

VotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Closed
    • Minor
    • Resolution: Fixed
    • 2.0.0-alpha
    • 2.0.2-alpha
    • datanode
    • None
    • Reviewed

    Description

      Let's rename BalancerDatanode#getName to getDisplayName to be consistent with Datanode, since it's used for logging. Also makes the code less confusing as "getName" in the context of DataNode/Node usually refers to a network location, not a display name.

      Attachments

        1. hdfs-3417.txt
          4 kB
          Eli Collins

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            eli Eli Collins
            eli2 Eli Collins
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Issue deployment