Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.0.0-alpha
    • Fix Version/s: None
    • Component/s: None
    • Labels:

      Description

      The "Starting a new period" line gets logged on DNs every 5 seconds with the default interval. Looks like this is because startNewPeriod is called by scanBlockPoolSlice every 5 seconds and it does an invo level log.

      2012-05-11 18:54:09,412 INFO org.apache.hadoop.hdfs.server.datanode.BlockPoolSliceScanner: Periodic Block Verification Scanner initialized with interval 504 hours for block pool BP-132016845-172.29.122.91-1336787527316.
      ...
      2012-05-11 18:54:14,216 INFO org.apache.hadoop.hdfs.server.datanode.BlockPoolSliceScanner: Starting a new period : work left in prev period : 0.00%

        Issue Links

          Activity

          Eli Collins created issue -
          Eli Collins made changes -
          Field Original Value New Value
          Description The "Starting a new period" line gets logged on DNs every 5 seconds with the default interval. Looks like this is because startNewPeriod is called by scanBlockPoolSlice every 5 seconds and it does an invo level log.

          {format}
          2012-05-11 18:54:09,412 INFO org.apache.hadoop.hdfs.server.datanode.BlockPoolSliceScanner: Periodic Block Verification Scanner initialized with interval 504 hours for block pool BP-132016845-172.29.122.91-1336787527316.
          ...
          2012-05-11 18:54:14,216 INFO org.apache.hadoop.hdfs.server.datanode.BlockPoolSliceScanner: Starting a new period : work left in prev period : 0.00%
          {format}
          The "Starting a new period" line gets logged on DNs every 5 seconds with the default interval. Looks like this is because startNewPeriod is called by scanBlockPoolSlice every 5 seconds and it does an invo level log.

          2012-05-11 18:54:09,412 INFO org.apache.hadoop.hdfs.server.datanode.BlockPoolSliceScanner: Periodic Block Verification Scanner initialized with interval 504 hours for block pool BP-132016845-172.29.122.91-1336787527316.
          ...
          2012-05-11 18:54:14,216 INFO org.apache.hadoop.hdfs.server.datanode.BlockPoolSliceScanner: Starting a new period : work left in prev period : 0.00%
          Uma Maheswara Rao G added a comment -

          Hi Eli, This duplicate of HDFS-3194?
          We noticed this issue.

          Uma Maheswara Rao G added a comment -

          Problem is due to logRolling.

          Eli Collins added a comment -

          Yup, closing as a dupe. Thanks Uma.

          Eli Collins made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Duplicate [ 3 ]
          Eli Collins made changes -
          Link This issue duplicates HDFS-3194 [ HDFS-3194 ]
          Eli Collins made changes -
          Link This issue is related to HDFS-3803 [ HDFS-3803 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              Eli Collins
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development