Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.24.0, 1.1.0
    • Fix Version/s: 1.1.0
    • Component/s: None
    • Labels:
    • Hadoop Flags:
      Reviewed
    • Target Version/s:

      Description

      Aaron has the following comments on TestStorageRestore in HDFS-3127.

      1. removeStorageAccess, restoreAccess, and numStorageDirs can all be made private
      2. numStorageDirs can be made static
      3. Rather than do set(Readable/Executable/Writable), use FileUtil.chmod(...).
      4. Please put the contents of the test in a try/finally, with the calls to shutdown the cluster and the 2NN in the finally block.
      5. Some lines are over 80 chars.
      6. No need for the numDatanodes variable - it's only used in one place.
      7. Instead of "xwr" use "rwx", which I think is a more common way of describing permissions.
      1. HDFS-3131.branch-1.patch
        6 kB
        Brandon Li
      2. HDFS-3131.patch
        3 kB
        Brandon Li
      3. HDFS-3131.patch
        3 kB
        Brandon Li

        Issue Links

          Activity

          Tsz Wo Nicholas Sze created issue -
          Aaron T. Myers made changes -
          Field Original Value New Value
          Labels newbie
          Affects Version/s 0.24.0 [ 12317653 ]
          Target Version/s 0.24.0 [ 12317653 ]
          Tsz Wo Nicholas Sze made changes -
          Assignee Brandon Li [ brandonli ]
          Tsz Wo Nicholas Sze made changes -
          Link This issue is related to HDFS-3127 [ HDFS-3127 ]
          Brandon Li made changes -
          Attachment HDFS-3131.patch [ 12519744 ]
          Brandon Li made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Release Note added test case to make sure that restore failure doesn't stop checkpoint process
          Brandon Li made changes -
          Affects Version/s 1.1.0 [ 12317959 ]
          Brandon Li made changes -
          Target Version/s 0.24.0 [ 12317653 ] 0.24.0, 1.1.0 [ 12317653, 12317959 ]
          Brandon Li made changes -
          Attachment HDFS-3131.branch-1.patch [ 12519752 ]
          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12519752/HDFS-3131.branch-1.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          -1 patch. The patch command could not apply the patch.

          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/2087//console

          This message is automatically generated.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12519744/HDFS-3131.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          -1 findbugs. The patch appears to introduce 1 new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests:
          org.apache.hadoop.hdfs.TestGetBlocks
          org.apache.hadoop.cli.TestHDFSCLI

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/2086//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HDFS-Build/2086//artifact/trunk/hadoop-hdfs-project/patchprocess/newPatchFindbugsWarningshadoop-hdfs.html
          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/2086//console

          This message is automatically generated.

          Brandon Li made changes -
          Attachment HDFS-3131.patch [ 12520018 ]
          Brandon Li added a comment -

          The test failures and warnings are not caused by this patch. The warnings were fixed in HDFS-3132.

          Aaron, could you please review the patch?

          Thanks,
          Brandon

          Aaron T. Myers added a comment -

          Hey Brandon, both the branch-1 and trunk patches look great to me. Thanks a lot for making them!

          +1, I'll commit this momentarily to both branches.

          Brandon Li added a comment -

          Thank you, Aaron!

          Aaron T. Myers added a comment -

          I've just committed this to trunk and branch-1.

          Thanks a lot for the contribution, Brandon.

          Aaron T. Myers made changes -
          Status Patch Available [ 10002 ] Resolved [ 5 ]
          Hadoop Flags Reviewed [ 10343 ]
          Release Note added test case to make sure that restore failure doesn't stop checkpoint process
          Target Version/s 1.1.0, 0.24.0 [ 12317959, 12317653 ] 0.24.0, 1.1.0 [ 12317653, 12317959 ]
          Fix Version/s 0.24.0 [ 12317653 ]
          Fix Version/s 1.1.0 [ 12317959 ]
          Resolution Fixed [ 1 ]
          Hudson added a comment -

          Integrated in Hadoop-Common-trunk-Commit #1933 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/1933/)
          HDFS-3131. Improve TestStorageRestore. Contributed by Brandon Li. (Revision 1305688)

          Result = SUCCESS
          atm : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1305688
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestStorageRestore.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk-Commit #2008 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/2008/)
          HDFS-3131. Improve TestStorageRestore. Contributed by Brandon Li. (Revision 1305688)

          Result = SUCCESS
          atm : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1305688
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestStorageRestore.java
          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12520018/HDFS-3131.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests:
          org.apache.hadoop.cli.TestHDFSCLI
          org.apache.hadoop.hdfs.TestGetBlocks
          org.apache.hadoop.hdfs.server.namenode.TestValidateConfigurationSettings
          org.apache.hadoop.hdfs.server.namenode.TestStartup

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/2101//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/2101//console

          This message is automatically generated.

          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk-Commit #1946 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/1946/)
          HDFS-3131. Improve TestStorageRestore. Contributed by Brandon Li. (Revision 1305688)

          Result = FAILURE
          atm : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1305688
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestStorageRestore.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #997 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/997/)
          HDFS-3131. Improve TestStorageRestore. Contributed by Brandon Li. (Revision 1305688)

          Result = FAILURE
          atm : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1305688
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestStorageRestore.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk #1032 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1032/)
          HDFS-3131. Improve TestStorageRestore. Contributed by Brandon Li. (Revision 1305688)

          Result = SUCCESS
          atm : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1305688
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestStorageRestore.java
          Arun C Murthy made changes -
          Fix Version/s 0.24.0 [ 12317653 ]
          Target Version/s 1.1.0, 0.24.0 [ 12317959, 12317653 ] 0.24.0, 1.1.0 [ 12317653, 12317959 ]
          Matt Foley added a comment -

          Closed upon release of Hadoop-1.1.0.

          Matt Foley made changes -
          Status Resolved [ 5 ] Closed [ 6 ]

            People

            • Assignee:
              Brandon Li
              Reporter:
              Tsz Wo Nicholas Sze
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development