Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-2546

The C HDFS API should work with secure HDFS

    Details

    • Type: New Feature New Feature
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.0.0-alpha
    • Fix Version/s: None
    • Component/s: libhdfs
    • Labels:
      None

      Description

      Right now, the libhdfs will not work with Kerberos Hadoop. In case libhdfs is still being supported, it must fully work with Kerberized instances of HDFS.

        Issue Links

          Activity

          Harsh J created issue -
          Ambar Hegde added a comment -

          I am working on this.

          Harsh J made changes -
          Field Original Value New Value
          Link This issue is duplicated by HDFS-3568 [ HDFS-3568 ]
          Harsh J made changes -
          Link This issue is required by HDFS-3568 [ HDFS-3568 ]
          Harsh J added a comment -

          Hi Ambar,

          Would you have a chance to push out a patch (even WIP one is fine) soon for this? Let us know how we can help.

          Thanks!

          Colin Patrick McCabe made changes -
          Link This issue is duplicated by HDFS-3568 [ HDFS-3568 ]
          Eli Collins made changes -
          Link This issue is required by HDFS-3568 [ HDFS-3568 ]
          Aaron T. Myers added a comment -

          With the commit of HDFS-3568, can we resolve this? Or is there more to do here?

          Aaron T. Myers made changes -
          Link This issue is related to HDFS-3568 [ HDFS-3568 ]
          Harsh J added a comment -

          Resolving as dupe of HDFS-3568

          Harsh J made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Duplicate [ 3 ]
          Allen Wittenauer made changes -
          Affects Version/s 2.0.0-alpha [ 12320353 ]
          Affects Version/s 0.24.0 [ 12317653 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              Harsh J
            • Votes:
              0 Vote for this issue
              Watchers:
              9 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development