Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-2383

TestDfsOverAvroRpc is failing on 0.22

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.22.0
    • Fix Version/s: 0.22.0
    • Component/s: test
    • Labels:
      None

      Description

      TestDfsOverAvroRpc.testWorkingDirectory() is failing. Possible the result of Avro upgrade.

      1. removeAfroPRCTest.patch
        2 kB
        Konstantin Shvachko

        Issue Links

          Activity

          Hudson added a comment -

          Integrated in Hadoop-Hdfs-22-branch #95 (See https://builds.apache.org/job/Hadoop-Hdfs-22-branch/95/)
          HDFS-2383. Remove TestDfsOverAvroRpc for 0.22 branch. Contributed by Konstantin Shvachko.

          shv : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1177392
          Files :

          • /hadoop/common/branches/branch-0.22/hdfs/CHANGES.txt
          • /hadoop/common/branches/branch-0.22/hdfs/src/test/hdfs/org/apache/hadoop/hdfs/TestDfsOverAvroRpc.java
          Konstantin Shvachko added a comment -

          I committed this to 0.22 branch.

          Konstantin Shvachko added a comment -

          The removes Avro RPC test.

          Konstantin Shvachko added a comment -

          I agree. But looking at the changes involved, I'd prefer to remove the test for 0.22 branch.

          Aaron T. Myers added a comment -

          Hey Konstantin, this looks like a duplicate of HDFS-2298 to me. Do you agree?

          Konstantin Shvachko added a comment -

          Here is the stack trace:

          Testcase: testWorkingDirectory took 1 sec
          	Caused an ERROR
          Two methods with same name: delete
          org.apache.avro.AvroTypeException: Two methods with same name: delete
          	at org.apache.avro.reflect.ReflectData.getProtocol(ReflectData.java:394)
          	at org.apache.avro.ipc.reflect.ReflectResponder.<init>(ReflectResponder.java:36)
          	at org.apache.hadoop.ipc.AvroRpcEngine.createResponder(AvroRpcEngine.java:184)
          	at org.apache.hadoop.ipc.AvroRpcEngine$TunnelResponder.<init>(AvroRpcEngine.java:191)
          	at org.apache.hadoop.ipc.AvroRpcEngine.getServer(AvroRpcEngine.java:218)
          	at org.apache.hadoop.ipc.RPC.getServer(RPC.java:382)
          	at org.apache.hadoop.hdfs.server.namenode.NameNode.initialize(NameNode.java:368)
          	at org.apache.hadoop.hdfs.server.namenode.NameNode.<init>(NameNode.java:576)
          	at org.apache.hadoop.hdfs.server.namenode.NameNode.<init>(NameNode.java:569)
          	at org.apache.hadoop.hdfs.server.namenode.NameNode.createNameNode(NameNode.java:1538)
          	at org.apache.hadoop.hdfs.MiniDFSCluster.initMiniDFSCluster(MiniDFSCluster.java:445)
          	at org.apache.hadoop.hdfs.MiniDFSCluster.<init>(MiniDFSCluster.java:176)
          	at org.apache.hadoop.hdfs.MiniDFSCluster.<init>(MiniDFSCluster.java:71)
          	at org.apache.hadoop.hdfs.MiniDFSCluster$Builder.build(MiniDFSCluster.java:168)
          	at org.apache.hadoop.hdfs.TestLocalDFS.testWorkingDirectory(TestLocalDFS.java:64)
          	at org.apache.hadoop.hdfs.TestDfsOverAvroRpc.testWorkingDirectory(TestDfsOverAvroRpc.java:30)
          

            People

            • Assignee:
              Konstantin Shvachko
              Reporter:
              Konstantin Shvachko
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development