Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-2299

TestOfflineEditsViewer is failing on trunk

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-alpha
    • Fix Version/s: 3.0.0-alpha1
    • Component/s: test
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      The relevant bit of the error:

      -------------------------------------------------------------------------------
      Test set: org.apache.hadoop.hdfs.tools.offlineEditsViewer.TestOfflineEditsViewer
      -------------------------------------------------------------------------------
      Tests run: 2, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 5.652 sec <<< FAILURE!
      testStored(org.apache.hadoop.hdfs.tools.offlineEditsViewer.TestOfflineEditsViewer)  Time elapsed: 0.038 sec  <<< FAILURE!
      java.lang.AssertionError: Reference XML edits and parsed to XML should be same
      
      1. HDFS-2299.1.patch
        2 kB
        Uma Maheswara Rao G
      2. HDFS-2299.2.patch
        1.0 kB
        Uma Maheswara Rao G
      3. HDFS-2299.patch
        2 kB
        Uma Maheswara Rao G
      4. HDFS-2299.patch
        3 kB
        Uma Maheswara Rao G

        Activity

        atm Aaron T. Myers added a comment -

        The full stack trace:

        -------------------------------------------------------------------------------
        Test set: org.apache.hadoop.hdfs.tools.offlineEditsViewer.TestOfflineEditsViewer
        -------------------------------------------------------------------------------
        Tests run: 2, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 5.652 sec <<< FAILURE!
        testStored(org.apache.hadoop.hdfs.tools.offlineEditsViewer.TestOfflineEditsViewer)  Time elapsed: 0.038 sec  <<< FAILURE!
        java.lang.AssertionError: Reference XML edits and parsed to XML should be same
          at org.junit.Assert.fail(Assert.java:91)
          at org.junit.Assert.assertTrue(Assert.java:43)
          at org.apache.hadoop.hdfs.tools.offlineEditsViewer.TestOfflineEditsViewer.testStored(TestOfflineEditsViewer.java:140)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
          at java.lang.reflect.Method.invoke(Method.java:597)
          at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:44)
          at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:15)
          at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:41)
          at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:20)
          at org.junit.internal.runners.statements.RunBefores.evaluate(RunBefores.java:28)
          at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:76)
          at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:50)
          at org.junit.runners.ParentRunner$3.run(ParentRunner.java:193)
          at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:52)
          at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:191)
          at org.junit.runners.ParentRunner.access$000(ParentRunner.java:42)
          at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:184)
          at org.junit.runners.ParentRunner.run(ParentRunner.java:236)
          at org.apache.maven.surefire.junit4.JUnit4TestSet.execute(JUnit4TestSet.java:59)
          at org.apache.maven.surefire.suite.AbstractDirectoryTestSuite.executeTestSet(AbstractDirectoryTestSuite.java:120)
          at org.apache.maven.surefire.suite.AbstractDirectoryTestSuite.execute(AbstractDirectoryTestSuite.java:145)
          at org.apache.maven.surefire.Surefire.run(Surefire.java:104)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
          at java.lang.reflect.Method.invoke(Method.java:597)
          at org.apache.maven.surefire.booter.SurefireBooter.runSuitesInProcess(SurefireBooter.java:290)
          at org.apache.maven.surefire.booter.SurefireBooter.main(SurefireBooter.java:1017)
        
        umamaheswararao Uma Maheswara Rao G added a comment -

        Hi Aaron,

        I analyzed the root cause for this failure.
        I think as part of some release audit comment fixes, Apache header has been added in editStored.xml file.

        But this testcase will generate one editsStoredParsedXml file. This file will not contain that apache header.
        Actually we need not compare that content. So, excluded them from comparison.

        Thanks
        Uma

        atm Aaron T. Myers added a comment -

        Thanks for looking into this Uma. I think a better solution would be to just remove the offending header from editsStored.xml. There's no reason it needs to be there, and I don't think we should rework the test to account for it.

        umamaheswararao Uma Maheswara Rao G added a comment -

        But that will introduce the release audit warning.but no harm.
        Is that fine?

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12492275/HDFS-2299.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 4 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests:

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/1179//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HDFS-Build/1179//artifact/trunk/patchprocess/newPatchFindbugsWarningshadoop-hdfs.html
        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/1179//console

        This message is automatically generated.

        atm Aaron T. Myers added a comment -

        Yes, that's fine. Just make sure that test-patch doesn't complain. I believe you do this by upping the number of OK_RELEASEAUDIT_WARNINGS in the relevant test-patch.properties file.

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12492281/HDFS-2299.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 9 new or modified tests.

        -1 patch. The patch command could not apply the patch.

        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/1180//console

        This message is automatically generated.

        atm Aaron T. Myers added a comment -

        +1, the latest patch looks good to me. I've just committed this.

        Thanks a lot, Uma.

        hudson Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #820 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/820/)
        HDFS-2299. TestOfflineEditsViewer is failing on trunk. (Uma Maheswara Rao G via atm)

        atm : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1164192
        Files :

        • /hadoop/common/trunk/dev-support/test-patch.properties
        • /hadoop/common/trunk/hadoop-hdfs-project/dev-support/test-patch.properties
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/resources/editsStored.xml
        hudson Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #897 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/897/)
        HDFS-2299. TestOfflineEditsViewer is failing on trunk. (Uma Maheswara Rao G via atm)

        atm : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1164192
        Files :

        • /hadoop/common/trunk/dev-support/test-patch.properties
        • /hadoop/common/trunk/hadoop-hdfs-project/dev-support/test-patch.properties
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/resources/editsStored.xml
        tlipcon Todd Lipcon added a comment -

        Rather than upping OK_RELEASEAUDIT_WARNINGS, I think it's better to add this file to the list of exclusions in hadoop-common-project/hadoop-common/pom.xml in the apache-rat-plugin configuration section. Mind reverting this and fixing again with that method of exclusion?

        hudson Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #830 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/830/)
        HDFS-2299. TestOfflineEditsViewer is failing on trunk. (Uma Maheswara Rao G via atm)

        atm : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1164192
        Files :

        • /hadoop/common/trunk/dev-support/test-patch.properties
        • /hadoop/common/trunk/hadoop-hdfs-project/dev-support/test-patch.properties
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/resources/editsStored.xml
        atm Aaron T. Myers added a comment -

        Rather than upping OK_RELEASEAUDIT_WARNINGS, I think it's better to add this file to the list of exclusions in hadoop-common-project/hadoop-common/pom.xml in the apache-rat-plugin configuration section.

        Good point, Todd. I should've said that in the first place.

        I've reverted this commit. Uma, would you mind updating the patch to use a RAT exclusion instead of upping OK_RELEASE_AUDIT_WARNINGS? My apologies for steering you wrong with my feedback.

        umamaheswararao Uma Maheswara Rao G added a comment -

        Hi Todd & Aaron,

        Thanks a lot for taking a look.

        @Todd

        Rather than upping OK_RELEASEAUDIT_WARNINGS, I think it's better to add this file to the list of exclusions in hadoop-common-project/hadoop-common/pom.xml in the apache-rat-plugin configuration section. Mind reverting this and fixing again with that method of exclusion?

        Really nice suggestion.

        @Aaron

        My apologies for steering you wrong with my feedback.

        No problem. I will update the patch accordingly.

        Thanks
        Uma

        atm Aaron T. Myers added a comment -

        Hey Uma, I'm surprised that the RAT exclusion should be placed in the hadoop-common pom.xml, instead of the hadoop-hdfs pom.xml. Did you test that the latest patch does not in fact increase the number of reported RAT warnings?

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12492646/HDFS-2299.1.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 6 new or modified tests.

        -1 patch. The patch command could not apply the patch.

        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/1187//console

        This message is automatically generated.

        hudson Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #780 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/780/)
        HDFS-2299. TestOfflineEditsViewer is failing on trunk. (Uma Maheswara Rao G via atm)

        atm : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1164192
        Files :

        • /hadoop/common/trunk/dev-support/test-patch.properties
        • /hadoop/common/trunk/hadoop-hdfs-project/dev-support/test-patch.properties
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/resources/editsStored.xml
        hudson Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #804 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/804/)
        HDFS-2299. TestOfflineEditsViewer is failing on trunk. (Uma Maheswara Rao G via atm)

        atm : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1164192
        Files :

        • /hadoop/common/trunk/dev-support/test-patch.properties
        • /hadoop/common/trunk/hadoop-hdfs-project/dev-support/test-patch.properties
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/resources/editsStored.xml
        umamaheswararao Uma Maheswara Rao G added a comment -

        Hey Aaron, Yes, I ran the test-patch.It did not show any warnings.
        It looks to me that we need not even add exclude tag in RAT configuration item.Because HDFS already has that excluded. Because of that it did not show any warnings if i add/don't add in common.adding exclude tag is no use in common.

        In HDFS pom.xml:

         <exclude>src/test/resources/data*</exclude>
         <exclude>src/test/resources/editStored*</exclude>
         <exclude>src/test/resources/empty-file</exclude>
        

        I just removed the Apache header from editStored.xml.

        Test-Patch results:

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 6 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        Thanks
        Uma

        atm Aaron T. Myers added a comment -

        Thanks a lot for reworking the patch, Uma. I've just committed the latest one.

        hudson Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #824 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/824/)
        HDFS-2299. TestOfflineEditsViewer is failing on trunk. (Uma Maheswara Rao G via atm)

        atm : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1164624
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/resources/editsStored.xml
        hudson Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #901 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/901/)
        HDFS-2299. TestOfflineEditsViewer is failing on trunk. (Uma Maheswara Rao G via atm)

        atm : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1164624
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/resources/editsStored.xml
        hudson Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #834 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/834/)
        HDFS-2299. TestOfflineEditsViewer is failing on trunk. (Uma Maheswara Rao G via atm)

        atm : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1164624
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/resources/editsStored.xml
        hudson Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #781 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/781/)
        HDFS-2299. TestOfflineEditsViewer is failing on trunk. (Uma Maheswara Rao G via atm)

        atm : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1164624
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/resources/editsStored.xml
        hudson Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #805 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/805/)
        HDFS-2299. TestOfflineEditsViewer is failing on trunk. (Uma Maheswara Rao G via atm)

        atm : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1164624
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/resources/editsStored.xml

          People

          • Assignee:
            umamaheswararao Uma Maheswara Rao G
            Reporter:
            atm Aaron T. Myers
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development