Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-2144

If SNN shuts down during initialization it does not log the cause

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.23.0
    • Fix Version/s: 0.23.0
    • Component/s: namenode
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      SNN should log messages when it shuts down because of authentication issues.

      1. HDFS-2144.1.patch
        0.5 kB
        Ravi Prakash
      2. HDFS-2144.2.patch
        0.5 kB
        Ravi Prakash

        Activity

        Ravi Prakash created issue -
        Ravi Prakash added a comment -

        This was again discovered by Arpit Gupta!

        Here is the info from the log

        2011-05-20 22:08:41,806 INFO org.apache.hadoop.hdfs.server.namenode.SecondaryNameNode: STARTUP_MSG:
        /************************************************************
        STARTUP_MSG: Starting SecondaryNameNode
        STARTUP_MSG: host = localhost/127.0.0.1
        STARTUP_MSG: args = []
        STARTUP_MSG: version = 0.22.0.1105190202
        STARTUP_MSG: classpath =
        ..............

        ......

        STARTUP_MSG: build =
        git://git.apache.org -r
        e46832994ee3402918135d1a5bd0b21ed58f5ed0; compiled by 'myusername' on Thu May 19 02:11:11 PDT 2011
        ************************************************************/
        2011-05-20 22:08:42,119 INFO org.apache.hadoop.hdfs.server.namenode.SecondaryNameNode: SHUTDOWN_MSG:
        /************************************************************

        Now this happened because the snn was setup to be behind a virtual host which fails as the 203.3 patch is yet to be
        merged.

        The log should have some message that states the error

        Ravi Prakash added a comment -

        Attaching patch. Not adding tests because its a very small change and I tried writing a test but it was overly complicated (no interface to add an appender to org.apache.commons.logging.Log and couldn't figure out how to mock the constructor )
        Could someone please review and commit?

        Ravi Prakash made changes -
        Field Original Value New Value
        Attachment HDFS-2144.1.patch [ 12486887 ]
        Aaron T. Myers added a comment -

        Hey Ravi, patch looks pretty good. My only comment is that the warning level should probably be FATAL not ERROR.

        I'll commit it pending that change.

        Ravi Prakash added a comment -

        Thanks for the review Aaron!

        Ravi Prakash made changes -
        Attachment HDFS-2144.2.patch [ 12486934 ]
        Ravi Prakash made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Suresh Srinivas added a comment -

        Aaron, can you please commit this change, if you are happy with the latest patch.

        Aaron T. Myers added a comment -

        Updating the JIRA description to more accurately reflect this change.

        Aaron T. Myers made changes -
        Summary SNN shuts down because of auth issues but does not log it If SNN shuts down during initialization it does not log the cause
        Aaron T. Myers added a comment -

        I've just committed this. Thanks a lot, Ravi!

        And thanks, Suresh, for bringing it to my attention.

        Aaron T. Myers made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Hadoop Flags [Reviewed]
        Resolution Fixed [ 1 ]
        Aaron T. Myers made changes -
        Fix Version/s 0.23.0 [ 12315571 ]
        Affects Version/s 0.23.0 [ 12315571 ]
        Component/s name-node [ 12312926 ]
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #804 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/804/)
        HDFS-2144. If SNN shuts down during initialization it does not log the cause. (Ravi Prakash via atm)

        atm : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1150927
        Files :

        • /hadoop/common/trunk/hdfs/CHANGES.txt
        • /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/server/namenode/SecondaryNameNode.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #736 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/736/)
        HDFS-2144. If SNN shuts down during initialization it does not log the cause. (Ravi Prakash via atm)

        atm : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1150927
        Files :

        • /hadoop/common/trunk/hdfs/CHANGES.txt
        • /hadoop/common/trunk/hdfs/src/java/org/apache/hadoop/hdfs/server/namenode/SecondaryNameNode.java
        Arun C Murthy made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Ravi Prakash
            Reporter:
            Ravi Prakash
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development