Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-2000

Missing deprecation for io.bytes.per.checksum

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.22.0, 0.23.0
    • Fix Version/s: 0.22.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Hadoop long ago deprecated the configuration "io.bytes.per.checksum" in favor of "dfs.bytes-per-checksum", but when the programmatic deprecation support was added, we didn't add an entry for this pair.

      This is causing some tests to fail on branch-0.22 since the inclusion of HADOOP-7287, since some tests which were inadvertently using default config values are now having their settings actually picked up.

      1. hdfs-2000-22.0.patch
        0.7 kB
        Aaron T. Myers

        Activity

        Aaron T. Myers created issue -
        Aaron T. Myers added a comment -

        Here's a patch for 0.22, which should also apply cleanly to trunk. No tests are included, but I can confirm that the presence of this patch fixes the TestFiRename test which had been broken on branch-0.22 since the commit of HADOOP-7287.

        Aaron T. Myers made changes -
        Field Original Value New Value
        Attachment hdfs-2000-22.0.patch [ 12480475 ]
        Aaron T. Myers made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Eli Collins added a comment -

        +1 pending Hudson

        Eli Collins made changes -
        Hadoop Flags [Reviewed]
        Fix Version/s 0.23.0 [ 12315571 ]
        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12480475/hdfs-2000-22.0.patch
        against trunk revision 1127759.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these core unit tests:
        org.apache.hadoop.hdfs.TestDFSStorageStateRecovery
        org.apache.hadoop.hdfs.TestQuota

        +1 contrib tests. The patch passed contrib unit tests.

        +1 system test framework. The patch passed system test framework compile.

        Test results: https://builds.apache.org/hudson/job/PreCommit-HDFS-Build/626//testReport/
        Findbugs warnings: https://builds.apache.org/hudson/job/PreCommit-HDFS-Build/626//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Console output: https://builds.apache.org/hudson/job/PreCommit-HDFS-Build/626//console

        This message is automatically generated.

        Aaron T. Myers added a comment -

        No tests are included, but I can confirm that the presence of this patch fixes the TestFiRename test which had been broken on branch-0.22 since the commit of HADOOP-7287.

        I'm pretty sure the failed tests are unrelated.

        Eli Collins added a comment -

        The TestQuota timeout is unrelated.

        Eli Collins added a comment -

        I've committed this to 22 and trunk. Thanks atm!

        Eli Collins made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #678 (See https://builds.apache.org/hudson/job/Hadoop-Hdfs-trunk/678/)
        HDFS-2000. Missing deprecation for io.bytes.per.checksum. Contributed by Aaron T. Myers

        eli : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1127819
        Files :

        • /hadoop/hdfs/trunk/src/java/org/apache/hadoop/hdfs/HdfsConfiguration.java
        • /hadoop/hdfs/trunk/CHANGES.txt
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #688 (See https://builds.apache.org/hudson/job/Hadoop-Hdfs-trunk-Commit/688/)

        Hudson added a comment -

        Integrated in Hadoop-Hdfs-22-branch #61 (See https://builds.apache.org/hudson/job/Hadoop-Hdfs-22-branch/61/)

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Patch Available Patch Available
        13m 33s 1 Aaron T. Myers 26/May/11 00:39
        Patch Available Patch Available Resolved Resolved
        8h 26m 1 Eli Collins 26/May/11 09:05

          People

          • Assignee:
            Aaron T. Myers
            Reporter:
            Aaron T. Myers
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development