- The class is better to be just a Map instead of a SortedMap.
- The value type is better to be DFSOutputStream instead of OutputStream.
- The variable name is better to be filesBeingWritten instead of pendingCreates since we have append.
Arun C Murthy made changes -
|Status||Resolved [ 5 ]||Closed [ 6 ]|
|Status||Patch Available [ 10002 ]||Resolved [ 5 ]|
|Fix Version/s||0.23.0 [ 12315571 ]|
|Resolution||Fixed [ 1 ]|
|Component/s||hdfs client [ 12312928 ]|
|Status||Open [ 1 ]||Patch Available [ 10002 ]|