Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-1869

mkdirs should use the supplied permission for all of the created directories

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.23.0
    • Fix Version/s: 0.23.0, 0.24.0
    • Component/s: namenode
    • Labels:
      None
    • Hadoop Flags:
      Reviewed
    • Release Note:
      A multi-level mkdir is now POSIX compliant. Instead of creating intermediate directories with the permissions of the parent directory, intermediate directories are created with permission bits of rwxrwxrwx (0777) as modified by the current umask, plus write and search permission for the owner.
      Show
      A multi-level mkdir is now POSIX compliant. Instead of creating intermediate directories with the permissions of the parent directory, intermediate directories are created with permission bits of rwxrwxrwx (0777) as modified by the current umask, plus write and search permission for the owner.

      Description

      Mkdirs only uses the supplied FsPermission for the last directory of the path. Paths 0..N-1 will all inherit the parent dir's permissions even if inheritPermission is false. This is a regression from somewhere around 0.20.9 and does not follow posix semantics.

      1. HDFS-1869-4.patch
        18 kB
        Daryn Sharp
      2. HDFS-1869-3.patch
        17 kB
        Daryn Sharp
      3. HDFS-1869-2.patch
        17 kB
        Daryn Sharp
      4. HDFS-1869.patch
        2 kB
        Daryn Sharp

        Issue Links

          Activity

          Daryn Sharp added a comment -

          Mkdirs will now honor the inheritPermission flag correctly. If false, the user's requested perms are used.

          Note that files that have auto-generated directories still implicitly inherit permissions.

          I find the entire concept of inheriting permissions to be dubious, so I'd like guidance on whether I should fix the file issue on this jira or a new jira?

          John George added a comment -

          +1. looks good.

          Tsz Wo Nicholas Sze added a comment -

          Would it work if the given permission does not have x, for example 0600?

          Daryn Sharp added a comment -

          Yes, it should. I worried about the same thing, but I believe I found existing code that implicitly assumed 0300 on dir creates and/or the namenode didn't bother checking permissions as it created the intermediate directories. My memory is a bit foggy, I'll double check.

          Tsz Wo Nicholas Sze added a comment -

          I think it is good to add a unit test for the 0600 case. It would also illustrate what is the expected behavior.

          BTW, have you verified it on BSD unix? We should make it the same as BSD, which our implementation is based on.

          Daryn Sharp added a comment -

          Ok, test will be added. I haven't tested on *BSD due to easy access, but I have tested on Darwin. However, the bsd man page for mkdir states:

          -p Create intermediate directories as required. If this option is not specified, the full path prefix of each operand must already exist. On the other hand, with this option specified, no error will be reported if a directory given as an operand already exists. Intermediate directories are created with permission bits of rwxrwxrwx (0777) as modified by the current umask, plus write and search permission for the owner.

          Will double check that write and search are indeed implicitly added.

          Daryn Sharp added a comment -

          Creating a multi-level dir with 0600 creates all dirs with 0600 – will post test shortly. So it works as expected in the aspect of "you get the permissions you asked for".

          It's neglecting to implicitly add u+rx. In unix this is required since mkdir -p does a series of mkdir/chdir, so u+rx is required to do the chdir calls. In hdfs it's not necessary since it verifies permissions in the directory where the mkdir originates, and then creates all the dirs with no permission checking. Do want the u+rx behavior added too? If so, would it be ok to be done on a separate jira?

          Tsz Wo Nicholas Sze added a comment -

          > It's neglecting to implicitly add u+rx. ...

          Should it be "u+wx", no "r"?

          I think it is better to implicitly add "u+wx", which is the required permission.

          Daryn Sharp added a comment -

          The change wasn't quite as straightforward as I hoped.

          There was code down in the bowels of INodeDirectory's addChild() that would use inheritPermission to get the parent dir's permission and apply u+wx before creation. the inheritPermission flag was being passed down through many levels of callstacks.

          It doesn't seem to make sense for the inode to be deciding the semantics of the filesystem. The inheriting of permissions only applies to intermediate directories, so why isn't mkdirs simply passing the appropriate permissions as it iterates over the directory components to create?

          I moved the code that tweaks the permissions for intermediate directories up from INodeDirectory to FSDirectory's mkdirs. I also removed the unnecessary inheritPermission argument from many method signatures.

          Note that if a file or symlink is created whereby it requires intermediate dirs to be auto-created, then the old inherit behavior is used to create the directories. It's not possible for the namenode to correctly divine the permissions for the intermediate dirs from the permissions for the file. I considered taking a swag at applying +x to each permission slot that was not 0. However that can produce some bizarre cases.

          In the end, I decided to not address the file and symlinks since it would be (imho) masking an underlying flaw in the api. Ie. auto-vivication of directories instead of an explicit mkdir with permissions.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12479530/HDFS-1869-2.patch
          against trunk revision 1104579.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 9 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these core unit tests:
          org.apache.hadoop.hdfs.TestDFSStorageStateRecovery
          org.apache.hadoop.hdfs.TestFileConcurrentReader
          org.apache.hadoop.tools.TestJMXGet

          +1 contrib tests. The patch passed contrib unit tests.

          +1 system test framework. The patch passed system test framework compile.

          Test results: https://builds.apache.org/hudson/job/PreCommit-HDFS-Build/549//testReport/
          Findbugs warnings: https://builds.apache.org/hudson/job/PreCommit-HDFS-Build/549//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Console output: https://builds.apache.org/hudson/job/PreCommit-HDFS-Build/549//console

          This message is automatically generated.

          Daryn Sharp added a comment -

          Tests that failed are not related to this bug. Most have historically failed, and the rest failed due to too many open fds.

          Sanjay Radia added a comment -

          Daryn, have you determined if the semantics of mkdirs changed some time or if this bug always existed.

          Daryn Sharp added a comment -

          Yes, mkdirs used to be posix compliant, but was subsequently broken. This is directly related to the linked HADOOP bug that mentioned the problem being introduced sometime after 0.20.9. The broken behavior was introduced when another feature was added (my memory is fuzzy, I think it was quotas).

          Todd Lipcon added a comment -

          It would be great to track down which JIRA it was that broke this upstream as well. I don't think it could be quotas since they've been around since 0.17 or so iirc.

          Daryn Sharp added a comment -

          A general question: do we favor the fs being posix compliant, or maintaining idiosyncrasies?

          Tsz Wo Nicholas Sze added a comment -

          Hi Daryn,

          Given there are so many incompatible changes in 0.23, I favor posix compliant.

          BTW, your patch is stale. Could you update it?

          Daryn Sharp added a comment -

          After resolving the upmerge conflicts, I was puzzling over exactly what I'd done before. I realized there's a much cleaner and more efficient way to construct the parent dir's perms. Will post a new patch soon.

          Daryn Sharp added a comment -

          It's been merged up-to-date, thanks to Anupam Seth.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12500466/HDFS-1869-3.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 9 new or modified tests.

          -1 patch. The patch command could not apply the patch.

          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/1427//console

          This message is automatically generated.

          Daryn Sharp added a comment -

          Looks like the build is broken, not this patch.

          HDFS-1869 patch is being downloaded at Mon Oct 24 15:51:44 UTC 2011 from
          http://issues.apache.org/jira/secure/attachment/12500466/HDFS-1869-3.patch
          cp: cannot stat `/home/jenkins/buildSupport/lib/*': No such file or directory
          
          Tsz Wo Nicholas Sze added a comment -

          +1 patch look good.

          Jenkins is going to shut down (shown from its web page). Let's resubmit it tomorrow.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12500466/HDFS-1869-3.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 9 new or modified tests.

          -1 patch. The patch command could not apply the patch.

          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/1467//console

          This message is automatically generated.

          Daryn Sharp added a comment -

          diff'ed from the top of tree

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12500950/HDFS-1869-4.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 9 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests:
          org.apache.hadoop.hdfs.TestFileAppend2
          org.apache.hadoop.hdfs.TestBalancerBandwidth

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/1468//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/1468//console

          This message is automatically generated.

          Tsz Wo Nicholas Sze added a comment -

          I have committed this. Thanks, Daryn!

          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk-Commit #1176 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/1176/)
          HDFS-1869. mkdirs should use the supplied permission for all of the created directories. Contributed by Daryn Sharp

          szetszwo : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1189546
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSDirectory.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/INodeDirectory.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestFsLimits.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/security/TestPermission.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/unit/org/apache/hadoop/hdfs/server/namenode/TestINodeFile.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-0.23-Commit #64 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Commit/64/)
          svn merge -c 1189546 from trunk for HDFS-1869.

          szetszwo : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1189547
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/main/java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSDirectory.java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/INodeDirectory.java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestFsLimits.java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/security/TestPermission.java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/test/unit/org/apache/hadoop/hdfs/server/namenode/TestINodeFile.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk-Commit #1238 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/1238/)
          HDFS-1869. mkdirs should use the supplied permission for all of the created directories. Contributed by Daryn Sharp

          szetszwo : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1189546
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSDirectory.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/INodeDirectory.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestFsLimits.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/security/TestPermission.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/unit/org/apache/hadoop/hdfs/server/namenode/TestINodeFile.java
          Hudson added a comment -

          Integrated in Hadoop-Common-trunk-Commit #1161 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/1161/)
          HDFS-1869. mkdirs should use the supplied permission for all of the created directories. Contributed by Daryn Sharp

          szetszwo : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1189546
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSDirectory.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/INodeDirectory.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestFsLimits.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/security/TestPermission.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/unit/org/apache/hadoop/hdfs/server/namenode/TestINodeFile.java
          Hudson added a comment -

          Integrated in Hadoop-Common-0.23-Commit #67 (See https://builds.apache.org/job/Hadoop-Common-0.23-Commit/67/)
          svn merge -c 1189546 from trunk for HDFS-1869.

          szetszwo : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1189547
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/main/java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSDirectory.java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/INodeDirectory.java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestFsLimits.java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/security/TestPermission.java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/test/unit/org/apache/hadoop/hdfs/server/namenode/TestINodeFile.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-0.23-Commit #68 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Commit/68/)
          svn merge -c 1189546 from trunk for HDFS-1869.

          szetszwo : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1189547
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/main/java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSDirectory.java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/INodeDirectory.java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestFsLimits.java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/security/TestPermission.java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/test/unit/org/apache/hadoop/hdfs/server/namenode/TestINodeFile.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-0.23-Build #52 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/52/)
          svn merge -c 1189546 from trunk for HDFS-1869.

          szetszwo : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1189547
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/main/java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSDirectory.java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/INodeDirectory.java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestFsLimits.java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/security/TestPermission.java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/test/unit/org/apache/hadoop/hdfs/server/namenode/TestINodeFile.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk #873 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/873/)
          HDFS-1869. mkdirs should use the supplied permission for all of the created directories. Contributed by Daryn Sharp

          szetszwo : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1189546
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSDirectory.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/INodeDirectory.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestFsLimits.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/security/TestPermission.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/unit/org/apache/hadoop/hdfs/server/namenode/TestINodeFile.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-0.23-Build #64 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Build/64/)
          svn merge -c 1189546 from trunk for HDFS-1869.

          szetszwo : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1189547
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/main/java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSDirectory.java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/INodeDirectory.java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestFsLimits.java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/security/TestPermission.java
          • /hadoop/common/branches/branch-0.23/hadoop-hdfs-project/hadoop-hdfs/src/test/unit/org/apache/hadoop/hdfs/server/namenode/TestINodeFile.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #845 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/845/)
          HDFS-1869. mkdirs should use the supplied permission for all of the created directories. Contributed by Daryn Sharp

          szetszwo : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1189546
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSDirectory.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/INodeDirectory.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestFsLimits.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/security/TestPermission.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/unit/org/apache/hadoop/hdfs/server/namenode/TestINodeFile.java

            People

            • Assignee:
              Daryn Sharp
              Reporter:
              Daryn Sharp
            • Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development