Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-1861

Rename dfs.datanode.max.xcievers and bump its default value

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.22.0, 0.23.0
    • Component/s: datanode
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Reasonably sized jobs and HBase easily exhaust the current default for dfs.datanode.max.xcievers. 4096 works better in practice.

      Let's also deprecate it in favor of a more intuitive name, eg dfs.datanode.max.receiver.threads.

        Attachments

        1. hdfs-1861-1.patch
          4 kB
          Eli Collins
        2. hdfs-1861-2.patch
          4 kB
          Eli Collins

          Activity

            People

            • Assignee:
              eli Eli Collins
              Reporter:
              eli Eli Collins
            • Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: