Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-1618

configure files that are generated as part of the released tarball need to have executable bit set

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.22.0
    • Fix Version/s: 0.22.0
    • Component/s: build
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Currently the configure files that are packaged in a tarball are rw-rw-r-

      1. HDFS-1618.patch
        1.0 kB
        Roman Shaposhnik

        Activity

        Roman Shaposhnik created issue -
        Roman Shaposhnik added a comment -

        Patch attached

        Roman Shaposhnik made changes -
        Field Original Value New Value
        Attachment HDFS-1618.patch [ 12470746 ]
        Konstantin Boudnik added a comment -

        +1 patch looks good. Let's run it through usual validation cycle.

        Roman Shaposhnik made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12470746/HDFS-1618.patch
        against trunk revision 1069561.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these core unit tests:
        org.apache.hadoop.hdfs.TestFileConcurrentReader

        -1 contrib tests. The patch failed contrib unit tests.

        +1 system test framework. The patch passed system test framework compile.

        Test results: https://hudson.apache.org/hudson/job/PreCommit-HDFS-Build/159//testReport/
        Findbugs warnings: https://hudson.apache.org/hudson/job/PreCommit-HDFS-Build/159//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Console output: https://hudson.apache.org/hudson/job/PreCommit-HDFS-Build/159//console

        This message is automatically generated.

        Roman Shaposhnik added a comment -

        -1 core tests. The patch failed these core unit tests:

        org.apache.hadoop.hdfs.TestFileConcurrentReader

        Looks like it also fails on trunk. Not caused by the change

        -1 tests included. The patch doesn't appear to include any new or modified tests.

        This is a build change – hence no new tests

        Konstantin Boudnik made changes -
        Fix Version/s 0.22.0 [ 12314241 ]
        Affects Version/s 0.22.0 [ 12314241 ]
        Component/s build [ 12312925 ]
        Hadoop Flags [Reviewed]
        Konstantin Boudnik added a comment -

        I have just committed this to trunk and branch-0.22. Thanks Roman!

        Konstantin Boudnik made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #541 (See https://hudson.apache.org/hudson/job/Hadoop-Hdfs-trunk-Commit/541/)
        HDFS-1618. configure files that are generated as part of the released tarball need to have executable bit set. Contributed by Roman Shaposhnik

        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #643 (See https://builds.apache.org/hudson/job/Hadoop-Hdfs-trunk/643/)

        Konstantin Shvachko made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Patch Available Patch Available
        23h 33m 1 Roman Shaposhnik 10/Feb/11 22:38
        Patch Available Patch Available Resolved Resolved
        1d 5h 52m 1 Konstantin Boudnik 12/Feb/11 04:30
        Resolved Resolved Closed Closed
        303d 1h 48m 1 Konstantin Shvachko 12/Dec/11 06:18

          People

          • Assignee:
            Roman Shaposhnik
            Reporter:
            Roman Shaposhnik
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development