Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-14729

Upgrade Bootstrap and jQuery versions used in HDFS UIs

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.3.0
    • Component/s: ui
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      The current versions of bootstrap and jquery have multiple medium severity CVEs reported till date and needs to be updated to the latest versions with no reported CVEs.

       

      I suggest updating the following libraries:

      Library From version To version
      Bootstrap 3.3.7 3.4.1
      jQuery 3.3.1 3.4.1

        Attachments

        1. HDFS-14729.v1.patch
          2.63 MB
          Vivek Ratnavel Subramanian

          Issue Links

            Activity

              People

              • Assignee:
                vivekratnavel Vivek Ratnavel Subramanian
                Reporter:
                vivekratnavel Vivek Ratnavel Subramanian
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: