Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-1454

Update the documentation to reflect true client caching strategy

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.20.2
    • Fix Version/s: 0.22.0
    • Component/s: documentation, hdfs-client
    • Labels:
      None
    • Hadoop Flags:
      Reviewed
    • Tags:
      doc
    1. HDFS-1454-reop.r1.diff
      1 kB
      Harsh J
    2. HDFS-1454-reop.r1.diff
      1 kB
      Harsh J
    3. HDFS-1454.r1.diff
      4 kB
      Harsh J

      Activity

      Jeff Hammerbacher created issue -
      Harsh J made changes -
      Field Original Value New Value
      Assignee Harsh J Chouraria [ qwertymaniac ]
      Harsh J added a comment -

      Initial docfix patch that gets rid of the staging talk.

      Harsh J made changes -
      Attachment HDFS-1454.r1.diff [ 12481320 ]
      Todd Lipcon added a comment -

      +1 pending Hudson. Thanks Harsh! It's amazing this inaccuracy has persisted for so many years.

      Harsh J made changes -
      Status Open [ 1 ] Patch Available [ 10002 ]
      Affects Version/s 0.20.2 [ 12314204 ]
      Fix Version/s 0.23.0 [ 12315571 ]
      Tags doc
      Hadoop QA added a comment -

      +1 overall. Here are the results of testing the latest attachment
      http://issues.apache.org/jira/secure/attachment/12481320/HDFS-1454.r1.diff
      against trunk revision 1130870.

      +1 @author. The patch does not contain any @author tags.

      +0 tests included. The patch appears to be a documentation patch that doesn't require tests.

      +1 javadoc. The javadoc tool did not generate any warning messages.

      +1 javac. The applied patch does not increase the total number of javac compiler warnings.

      +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

      +1 release audit. The applied patch does not increase the total number of release audit warnings.

      +1 core tests. The patch passed core unit tests.

      +1 contrib tests. The patch passed contrib unit tests.

      +1 system test framework. The patch passed system test framework compile.

      Test results: https://builds.apache.org/hudson/job/PreCommit-HDFS-Build/700//testReport/
      Findbugs warnings: https://builds.apache.org/hudson/job/PreCommit-HDFS-Build/700//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
      Console output: https://builds.apache.org/hudson/job/PreCommit-HDFS-Build/700//console

      This message is automatically generated.

      Todd Lipcon added a comment -

      Committed to trunk and 22. Thanks Harsh.

      Todd Lipcon made changes -
      Status Patch Available [ 10002 ] Resolved [ 5 ]
      Hadoop Flags [Reviewed]
      Fix Version/s 0.22.0 [ 12314241 ]
      Fix Version/s 0.23.0 [ 12315571 ]
      Resolution Fixed [ 1 ]
      Hudson added a comment -

      Integrated in Hadoop-Hdfs-trunk-Commit #711 (See https://builds.apache.org/hudson/job/Hadoop-Hdfs-trunk-Commit/711/)
      HDFS-1454. Update the documentation to reflect that clients don't write blocks to local disk before copying to HDFS. Contributed by Harsh J Chouraria.

      todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1131223
      Files :

      • /hadoop/hdfs/trunk/src/docs/src/documentation/content/xdocs/hdfs_design.xml
      • /hadoop/hdfs/trunk/CHANGES.txt
      Hudson added a comment -

      Integrated in Hadoop-Hdfs-trunk #688 (See https://builds.apache.org/hudson/job/Hadoop-Hdfs-trunk/688/)

      Eli Collins added a comment -

      DataNode starts receiving the data in small portions (4 KB),

      Why 4k? DFS_CLIENT_WRITE_PACKET_SIZE_DEFAULT is 64k.

      Harsh J added a comment -

      @Eli - Failed to actually verify the entire documents. Patch was intended to only remove staging, but I should've fixed other things as well I guess.

      Harsh J made changes -
      Resolution Fixed [ 1 ]
      Status Resolved [ 5 ] Reopened [ 4 ]
      Harsh J added a comment -

      Fix the default packet size.

      Harsh J made changes -
      Attachment HDFS-1454-reop.r1.diff [ 12481533 ]
      Harsh J made changes -
      Attachment HDFS-1454-reop.r1.diff [ 12481535 ]
      Todd Lipcon added a comment -

      hrm, since we already committed this a few days ago, can we actually open a new JIRA? seems easier to track, since this is a different issue elsewhere in the doc, right?

      Harsh J added a comment -

      Re-resolving per Todd's suggestion.

      Opened: HDFS-2036

      Harsh J made changes -
      Status Reopened [ 4 ] Resolved [ 5 ]
      Resolution Fixed [ 1 ]
      Hudson added a comment -

      Integrated in Hadoop-Hdfs-22-branch #61 (See https://builds.apache.org/hudson/job/Hadoop-Hdfs-22-branch/61/)

      Konstantin Shvachko made changes -
      Status Resolved [ 5 ] Closed [ 6 ]
      Transition Time In Source Status Execution Times Last Executer Last Execution Date
      Open Open Patch Available Patch Available
      233d 10h 8m 1 Harsh J 03/Jun/11 18:49
      Patch Available Patch Available Resolved Resolved
      2h 55m 1 Todd Lipcon 03/Jun/11 21:44
      Resolved Resolved Reopened Reopened
      2d 7h 23m 1 Harsh J 06/Jun/11 05:07
      Reopened Reopened Resolved Resolved
      19m 1 Harsh J 06/Jun/11 05:26
      Resolved Resolved Closed Closed
      189d 1h 51m 1 Konstantin Shvachko 12/Dec/11 06:18

        People

        • Assignee:
          Harsh J
          Reporter:
          Jeff Hammerbacher
        • Votes:
          1 Vote for this issue
          Watchers:
          4 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development