Another thing missing from the docs as they are in v2:
from Steve L on
I don't want an enum though, I'd like a string. Why? Let's us and implementation classes add new methods without renegotiating the source tree. For example, on S3a, I could add the new attributes "s3a:delayed-commit", blobstore:put-on-close ( the latter being something which other blobstores could also do), etc. Some convention that for store-specific options, we use a prefix, so as to stop incompatibilities.
The docs should call out that the options from store implementations should use a prefix. Preferably also state a suggested place implementors should doc the options they provide (based on whatever we do for documenting the stores in HADOOP-14402)