Looks good overall, thanks Manoj! I'm assuming this was done with an IDE refactor.
One small comment, on
HDFS-11314 Kai Zheng recommended we rename the getters from getSystemPolicyByID to getPolicyByID, shall we do the same here and call it getDefaultECPolicy?
Also if you don't mind, I'd like to handle this after
HDFS-11314 goes in, since I think it's pretty close and likely to conflict with this one.