Details

    • Target Version/s:
    • Hadoop Flags:
      Incompatible change
    • Release Note:
      The "rs-default" codec has been renamed to simply "rs" for simplicity. Previous configuration keys like "io.erasurecode.codec.rs-default" have also been renamed to match.

      Description

      I think it's confusing (and verbose) that our RS code is named "rs-default" instead of just "rs", partially because we also have the idea of setting a default implementation for each codec. Let's rename it for simplicity.

      This is an incompatible change since it affects some configuration keys.

        Attachments

        1. HDFS-11427.001.patch
          32 kB
          Andrew Wang
        2. HDFS-11427.002.patch
          31 kB
          Andrew Wang

          Activity

            People

            • Assignee:
              andrew.wang Andrew Wang
              Reporter:
              andrew.wang Andrew Wang
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: