Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-11273

Move TransferFsImage#doGetUrl function to a Util class

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0.0-alpha2
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      TransferFsImage#doGetUrl downloads files from the specified url and stores them in the specified storage location. HDFS-4025 plans to synchronize the log segments in JournalNodes. If a log segment is missing from a JN, the JN downloads it from another JN which has the required log segment. We need TransferFsImage#doGetUrl and TransferFsImage#receiveFile to accomplish this.
      So we propose to move the said functions to a Utility class so as to be able to use it for JournalNode syncing as well, without duplication of code.

        Attachments

        1. HDFS-11273.000.patch
          20 kB
          Hanisha Koneru
        2. HDFS-11273.001.patch
          21 kB
          Hanisha Koneru
        3. HDFS-11273.002.patch
          23 kB
          Hanisha Koneru
        4. HDFS-11273.003.patch
          28 kB
          Hanisha Koneru
        5. HDFS-11273.004.patch
          36 kB
          Hanisha Koneru
        6. HDFS-11273-branch-2.001.patch
          35 kB
          Hanisha Koneru

          Issue Links

            Activity

              People

              • Assignee:
                hanishakoneru Hanisha Koneru
                Reporter:
                hanishakoneru Hanisha Koneru
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: