Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-111

UnderReplicationBlocks should use generic types

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Not A Problem
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      1. HADOOP-659 introduced new class UnderReplicationBlocks, and
      two new warnings about use of generic types
      TreeSet<Block>[] priorityQueues = new TreeSet[LEVEL];
      Iterator<Block>[] iterator = new Iterator[LEVEL];
      should resp. read
      TreeSet<Block>[] priorityQueues = new TreeSet<Block>[LEVEL];
      Iterator<Block>[] iterator = new Iterator<Block>[LEVEL];

      2. I'd rename class UnderReplicationBlocks to UnderReplicatedBlocks while it is still internal.

        Activity

        Harsh J made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Not A Problem [ 8 ]
        Owen O'Malley made changes -
        Field Original Value New Value
        Project Hadoop Common [ 12310240 ] HDFS [ 12310942 ]
        Key HADOOP-1026 HDFS-111
        Component/s dfs [ 12310710 ]
        Konstantin Shvachko created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Konstantin Shvachko
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development