Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0.0-alpha2
    • Component/s: None
    • Labels:
      None
    • Environment:

      JDK 1.8.0_91 on Mac OS X Yosemite 10.10.5

      Description

      On my Mac, TestFileChecksum has been been failing since HDFS-10460. However, the jenkins jobs have not reported the failures. Maybe it's an issue with my Mac or JDK.

      9 out of 21 tests failed.

      java.lang.AssertionError: Checksum mismatches!
      
      	at org.junit.Assert.fail(Assert.java:88)
      	at org.junit.Assert.assertTrue(Assert.java:41)
      	at org.apache.hadoop.hdfs.TestFileChecksum.testStripedFileChecksumWithMissedDataBlocksRangeQuery(TestFileChecksum.java:227)
      	at org.apache.hadoop.hdfs.TestFileChecksum.testStripedFileChecksumWithMissedDataBlocksRangeQuery10(TestFileChecksum.java:336)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:498)
      	at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:47)
      	at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
      	at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:44)
      	at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:17)
      	at org.junit.internal.runners.statements.FailOnTimeout$StatementThread.run(FailOnTimeout.java:74)
      
      

        Issue Links

          Activity

          jojochuang Wei-Chiu Chuang added a comment -

          Kai Zheng can you please take a look?

          drankye Kai Zheng added a comment -

          Sure, Chuang. I will look at it when back to office. Thanks.

          drankye Kai Zheng added a comment -

          It's not Mac only. I repeated it on my Linux desktop. SammiChen, would you help with this? Thanks.

          Sammi SammiChen added a comment -

          Hi, Kai, sure, I will look into it.

          Sammi SammiChen added a comment -

          TestFileChecksum tests all passed on my Linux server. My JDK is "1.8.0_65".

          Hi Wei-Chiu Chuang and Kai, can I know your JAVA version?

          jojochuang Wei-Chiu Chuang added a comment -

          Kai Zheng that's interesting. Thanks for confirming with me.
          I am on JDK 1.8.0_91 on Mac OS X Yosemite 10.10.5.

          jojochuang Wei-Chiu Chuang added a comment - - edited

          I ran the tests in multiple JDK versions ranging from JDK 1.8.0_05 to JDK 1.8.0_102 on CentOS 6.5 (I tested both with/without native libisal library), and I got the following error for all tests in TestFileChecksum.:

          Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 7.46 sec <<< FAILURE! - in org.apache.hadoop.hdfs.TestFileChecksum
          testStripedFileChecksumWithMissedDataBlocksRangeQuery5(org.apache.hadoop.hdfs.TestFileChecksum) Time elapsed: 7.269 sec <<< ERROR!
          java.lang.OutOfMemoryError: unable to create new native thread
          at java.lang.Thread.start0(Native Method)
          at java.lang.Thread.start(Thread.java:714)
          at io.netty.util.concurrent.ThreadPerTaskExecutor.execute(ThreadPerTaskExecutor.java:33)
          at io.netty.util.concurrent.SingleThreadEventExecutor.doStartThread(SingleThreadEventExecutor.java:692)
          at io.netty.util.concurrent.SingleThreadEventExecutor.shutdownGracefully(SingleThreadEventExecutor.java:499)
          at io.netty.util.concurrent.MultithreadEventExecutorGroup.shutdownGracefully(MultithreadEventExecutorGroup.java:160)
          at io.netty.util.concurrent.AbstractEventExecutorGroup.shutdownGracefully(AbstractEventExecutorGroup.java:70)
          at org.apache.hadoop.hdfs.server.datanode.web.DatanodeHttpServer.close(DatanodeHttpServer.java:259)
          at org.apache.hadoop.hdfs.server.datanode.DataNode.shutdown(DataNode.java:1932)
          at org.apache.hadoop.hdfs.MiniDFSCluster.shutdownDataNodes(MiniDFSCluster.java:1985)
          at org.apache.hadoop.hdfs.MiniDFSCluster.shutdown(MiniDFSCluster.java:1962)
          at org.apache.hadoop.hdfs.MiniDFSCluster.shutdown(MiniDFSCluster.java:1936)
          at org.apache.hadoop.hdfs.MiniDFSCluster.shutdown(MiniDFSCluster.java:1929)
          at org.apache.hadoop.hdfs.MiniDFSCluster.initMiniDFSCluster(MiniDFSCluster.java:870)
          at org.apache.hadoop.hdfs.MiniDFSCluster.<init>(MiniDFSCluster.java:491)
          at org.apache.hadoop.hdfs.MiniDFSCluster$Builder.build(MiniDFSCluster.java:450)
          at org.apache.hadoop.hdfs.TestFileChecksum.setup(TestFileChecksum.java:78)

          Maybe it's just my env issue. Can't tell.

          jojochuang Wei-Chiu Chuang added a comment -

          SammiChen did you see NPE like the following in your tests? I am seeing the NPE which is reproducible consistently.

          java.lang.NullPointerException
          at org.apache.hadoop.hdfs.server.datanode.DataNode.bpRegistrationSucceeded(DataNode.java:1498)
          at org.apache.hadoop.hdfs.server.datanode.BPOfferService.registrationSucceeded(BPOfferService.java:361)
          at org.apache.hadoop.hdfs.server.datanode.BPServiceActor.register(BPServiceActor.java:749)
          at org.apache.hadoop.hdfs.server.datanode.BPServiceActor.connectToNNAndHandshake(BPServiceActor.java:279)
          at org.apache.hadoop.hdfs.server.datanode.BPServiceActor.run(BPServiceActor.java:782)

          Sammi SammiChen added a comment -

          Hi Wei-Chiu Chuang, "java.lang.OutOfMemoryError" indicate that JVM run out of memory. I would suggest you increase JVM heap memory using "-Xmx<size>" option, and then run the test case again.

          Sammi SammiChen added a comment -

          Hi Wei-CHiu, I'd like to know how you launch the TestFileChecksum test case, beside the IDE(such as Eclipse) or directly from the Linux command console?
          And I don't see any NullPointerException in my tests. I had one of my co-worker run the TestFileChecksum. The test also passed in his environment.

          jojochuang Wei-Chiu Chuang added a comment -

          Hi Sammi,
          I ran the tests on Mac in IntelliJ and in command console. And I ran them in command console on Linux.

          The NPE appeared twice and then it disappeared in my env so maybe it's not related.

          jojochuang Wei-Chiu Chuang added a comment -

          I increase heap size of the surefire plugin to 10240mb. It ran longer but still failed with the same error, and the log is full of "Too many open files" error. I also set ulimit -u 10240 to increase my max user threads but still no go. This machine has 64GB memory. The code I'm running is compiled with ISA-L native lib.

          jojochuang Wei-Chiu Chuang added a comment -

          But I had no problem running other tests.

          Sammi SammiChen added a comment -

          Don't worry! I am doing investigation using Kai's environment since the problem is reproducible in his environment.

          jojochuang Wei-Chiu Chuang added a comment -

          I have two local Hadoop repo, one is built with native isa-l lib and the other is not. The one without the native lib failed while the other passed. It seems java based codec doesn't work as expected.

          I also have other tests where if I specifically corrupt 1, 2 or 3 strips out of 9, it does not recover if hadoop is built without native lib.

          jojochuang Wei-Chiu Chuang added a comment -

          Bump priority to critical as it seems to generate corrupt data.

          Sammi SammiChen added a comment -

          Hi Wei-Chiu Chuang, it's found out that this "Checksum mismatches" issue is because the second checksum(the one with block reconstruct) is wrong. The checksum is wrong is not because the reconstructed block content is wrong. It's because the code reuses an existing DataChecksum object while forgets to reset this checksum object state to initial state before using it. So the checksum is contaminated by its old state. I have upload the patch to address this issue.

          Sammi SammiChen added a comment -

          Initial patch

          jojochuang Wei-Chiu Chuang added a comment -

          Hi SammiChen that's great finding!

          I am still curious why the test only fails without native ISA-L library. Would it be possible to add a test to force tests to use non-native codec? Is that the right way to add a regression test?
          Kai Zheng Zhe Zhang would you like to review this patch?

          Thanks

          drankye Kai Zheng added a comment -

          Thanks Sammi for the patch. It sounds reasonable.

          Sure WeiChiu. Could you help verify the fix works for you or not in your repos? Thanks in advance.

          jojochuang Wei-Chiu Chuang added a comment -

          Cool. I've verified the patch passed TestFileChecksum tests in my Mac. This is great!

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 18s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
          +1 mvninstall 9m 12s trunk passed
          +1 compile 0m 55s trunk passed
          +1 checkstyle 0m 27s trunk passed
          +1 mvnsite 1m 3s trunk passed
          +1 mvneclipse 0m 16s trunk passed
          +1 findbugs 2m 9s trunk passed
          +1 javadoc 0m 52s trunk passed
          +1 mvninstall 0m 55s the patch passed
          +1 compile 0m 51s the patch passed
          +1 javac 0m 51s the patch passed
          +1 checkstyle 0m 27s the patch passed
          +1 mvnsite 1m 0s the patch passed
          +1 mvneclipse 0m 12s the patch passed
          +1 whitespace 0m 0s The patch has no whitespace issues.
          +1 findbugs 2m 7s the patch passed
          +1 javadoc 0m 42s the patch passed
          -1 unit 47m 2s hadoop-hdfs in the patch failed.
          +1 asflicense 0m 17s The patch does not generate ASF License warnings.
          70m 8s



          Reason Tests
          Timed out junit tests org.apache.hadoop.hdfs.server.datanode.TestHSync
            org.apache.hadoop.hdfs.server.datanode.TestDataNodeRollingUpgrade
            org.apache.hadoop.hdfs.server.datanode.fsdataset.impl.TestLazyWriter
            org.apache.hadoop.hdfs.server.datanode.fsdataset.impl.TestSpaceReservation
            org.apache.hadoop.hdfs.server.datanode.TestFsDatasetCache



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:9560f25
          JIRA Issue HDFS-10935
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12835079/HDFS-10935-v1.patch
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux fb13960ae5a3 3.13.0-92-generic #139-Ubuntu SMP Tue Jun 28 20:42:26 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / dbd2057
          Default Java 1.8.0_101
          findbugs v3.0.0
          unit https://builds.apache.org/job/PreCommit-HDFS-Build/17271/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs.txt
          Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/17271/testReport/
          modules C: hadoop-hdfs-project/hadoop-hdfs U: hadoop-hdfs-project/hadoop-hdfs
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/17271/console
          Powered by Apache Yetus 0.4.0-SNAPSHOT http://yetus.apache.org

          This message was automatically generated.

          drankye Kai Zheng added a comment -

          Thanks Wei-Chiu Chuang for helping verify the fix.

          The patch LGTM and +1. Will commit it shortly.

          hudson Hudson added a comment -

          SUCCESS: Integrated in Jenkins build Hadoop-trunk-Commit #10681 (See https://builds.apache.org/job/Hadoop-trunk-Commit/10681/)
          HDFS-10935. TestFileChecksum fails in some cases. Contributed by Sammi (kai.zheng: rev 287effff9327450240d65e27e31bed2649a7a100)

          • (edit) hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/erasurecode/StripedBlockChecksumReconstructor.java
          drankye Kai Zheng added a comment -

          Committed to trunk. Thanks Wei-Chiu Chuang for reporting/verifying this and SammiChen for digging into the fix and contribution.

          andrew.wang Andrew Wang added a comment -

          Did we file a follow-on JIRA to test both the Java coder as well as ISA-L in the unit tests? This is important for coverage.

          jojochuang Wei-Chiu Chuang added a comment -

          Correct, Andrew. I forgot to address that concern. Filing a follow-up jira now.


            People

            • Assignee:
              Sammi SammiChen
              Reporter:
              jojochuang Wei-Chiu Chuang
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development