I started to document the project hierarchy of Ozone and found that to subproject name is very confusing:
1. framework: it supposed to be similar to the common but share the classes only between server side projects (om/scm/...). I propose to call it server-common
2. container-service: While we have historical reasons why it's a separated project, but today we can call it datanode and remove hadoop-ozone/datanode.
While I can learn both the specific names, for new contributors it can help if we use more straightforward names.
In this patch I would like to fix the first item (framework --> common-server)