HBase
  1. HBase
  2. HBASE-9825

LoadIncrementalHFiles fails to load from remote cluster in hadoop 2

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 0.94.12
    • Fix Version/s: None
    • Component/s: hadoop2
    • Labels:
      None

      Description

      Running on hadoop 2, LoadIncrementalHFiles gives the following exception when loading from a remote cluster.

      org.apache.hadoop.hbase.mapreduce.LoadIncrementalHFiles$3@455e455e, java.io.IOException: j ava.io.IOException: java.lang.UnsupportedOperationException: Immutable Configuration
              at org.apache.hadoop.hbase.regionserver.CompoundConfiguration.setClass(CompoundConfiguration.java:516)
              at org.apache.hadoop.ipc.RPC.setProtocolEngine(RPC.java:195)
              at org.apache.hadoop.hdfs.NameNodeProxies.createNNProxyWithClientProtocol(NameNodeProxies.java:250)
              at org.apache.hadoop.hdfs.NameNodeProxies.createNonHAProxy(NameNodeProxies.java:169)
              at org.apache.hadoop.hdfs.NameNodeProxies.createProxy(NameNodeProxies.java:130)
              at org.apache.hadoop.hdfs.DFSClient.<init>(DFSClient.java:482)
              at org.apache.hadoop.hdfs.DFSClient.<init>(DFSClient.java:445)
              at org.apache.hadoop.hdfs.DistributedFileSystem.initialize(DistributedFileSystem.java:136)
              at org.apache.hadoop.fs.FileSystem.createFileSystem(FileSystem.java:2429)
              at org.apache.hadoop.fs.FileSystem.access$200(FileSystem.java:88)
              at org.apache.hadoop.fs.FileSystem$Cache.getInternal(FileSystem.java:2463)
              at org.apache.hadoop.fs.FileSystem$Cache.get(FileSystem.java:2445)
              at org.apache.hadoop.fs.FileSystem.get(FileSystem.java:363)
              at org.apache.hadoop.fs.Path.getFileSystem(Path.java:283)
              at org.apache.hadoop.hbase.regionserver.Store.assertBulkLoadHFileOk(Store.java:571)
              at org.apache.hadoop.hbase.regionserver.HRegion.bulkLoadHFiles(HRegion.java:3689)
              at org.apache.hadoop.hbase.regionserver.HRegion.bulkLoadHFiles(HRegion.java:3637)
              at org.apache.hadoop.hbase.regionserver.HRegionServer.bulkLoadHFiles(HRegionServer.java:2939)
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
              at java.lang.reflect.Method.invoke(Method.java:611)
              at org.apache.hadoop.hbase.ipc.WritableRpcEngine$Server.call(WritableRpcEngine.java:320)
              at org.apache.hadoop.hbase.ipc.HBaseServer$Handler.run(HBaseServer.java:1426)
              at org.apache.hadoop.hbase.client.ServerCallable.withRetries(ServerCallable.java:186)
              at org.apache.hadoop.hbase.mapreduce.LoadIncrementalHFiles.tryAtomicRegionLoad(LoadIncrementalHFiles.java:567)
              at org.apache.hadoop.hbase.mapreduce.LoadIncrementalHFiles$1.call(LoadIncrementalHFiles.java:317)
              at org.apache.hadoop.hbase.mapreduce.LoadIncrementalHFiles$1.call(LoadIncrementalHFiles.java:315)
      

      This does not happen when loading from the same FileSystem.

        Issue Links

          Activity

          Jerry He added a comment -

          Fixed by Ted with HBASE-9819.

          Jerry He added a comment -

          Verified the problem has been fixed with HBASE-9819.
          Thanks, Ted.

          Ted Yu added a comment -

          HBASE-9819 has been integrated to 0.94

          Mind verifying whether this is fixed ?

          Jerry He added a comment -

          Thanks, Ted.

          Then let's wait for HBASE-9819.
          If HBASE-9819 is not going in shortly, will you be ok with this simple patch?

          Ted Yu added a comment -

          HBASE-9819 proposed to backport HBASE-8372

          That would be preferred solution in my opinion.

          Jerry He added a comment -

          We have some options here.
          We can either backport HBASE-8372 to 0.94, which probably will solve this problem.
          Or I am attaching a simple patch for a 0.94 fix only.

          Jerry He added a comment -

          This is the same root cause as described in HBase-8347, which was fixed in HBASE-8372.
          But HBASE-8372 was not put into 0.94.


            People

            • Assignee:
              Ted Yu
              Reporter:
              Jerry He
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development