HBase
  1. HBase
  2. HBASE-9251

list_namespace_tables seems to fail

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.95.2
    • Fix Version/s: 0.98.0, 0.96.0
    • Component/s: None
    • Labels:
      None

      Description

      I was trying the RC0 of 0.95.2. and was on the shell trying to list tables in a namespace. I tried listing tables in the 'hbase' namespace and in a namespace I created. The listing fails:

      hbase(main):008:0> list_namespace_tables 'hbase'
      TABLE
      
      ERROR: org.apache.hadoop.hbase.client.RetriesExhaustedException: Failed after attempts=7, exceptions:
      Fri Aug 16 17:47:17 UTC 2013, org.apache.hadoop.hbase.client.RpcRetryingCaller@2313b44d, org.apache.hadoop.hbase.ipc.RemoteWithExtrasException(java.io.IOException): java.io.IOException: Illegal character <58> at 5. User-space table qualifiers can only contain 'alphanumeric characters': i.e. [a-zA-Z_0-9-.]: hbase:meta
              at org.apache.hadoop.hbase.ipc.RpcServer.call(RpcServer.java:2194)
              at org.apache.hadoop.hbase.ipc.RpcServer$Handler.run(RpcServer.java:1861)
      Caused by: java.lang.IllegalArgumentException: Illegal character <58> at 5. User-space table qualifiers can only contain 'alphanumeric characters': i.e. [a-zA-Z_0-9-.]: hbase:meta
              at org.apache.hadoop.hbase.TableName.isLegalTableQualifierName(TableName.java:155)
              at org.apache.hadoop.hbase.TableName.isLegalTableQualifierName(TableName.java:125)
              at org.apache.hadoop.hbase.TableName.finishValueOf(TableName.java:249)
              at org.apache.hadoop.hbase.TableName.valueOf(TableName.java:242)
              at org.apache.hadoop.hbase.master.HMaster.listTableNamesByNamespace(HMaster.java:3130)
              at org.apache.hadoop.hbase.master.HMaster.listTableNamesByNamespace(HMaster.java:3063)
              at org.apache.hadoop.hbase.protobuf.generated.MasterAdminProtos$MasterAdminService$2.callBlockingMethod(MasterAdminProtos.java:27764)
              at org.apache.hadoop.hbase.ipc.RpcServer.call(RpcServer.java:2156)
              ... 1 more
      
      1. 9251.patch
        1 kB
        Andrew Purtell

        Activity

        Hudson added a comment -

        SUCCESS: Integrated in hbase-0.95-on-hadoop2 #251 (See https://builds.apache.org/job/hbase-0.95-on-hadoop2/251/)
        HBASE-9251. list_namespace_tables seems to fail (apurtell: rev 1515184)

        • /hbase/branches/0.95/hbase-server/src/main/java/org/apache/hadoop/hbase/master/HMaster.java
        • /hbase/branches/0.95/hbase-server/src/test/ruby/hbase/admin_test.rb
        Hudson added a comment -

        SUCCESS: Integrated in HBase-TRUNK-on-Hadoop-2.0.0 #685 (See https://builds.apache.org/job/HBase-TRUNK-on-Hadoop-2.0.0/685/)
        HBASE-9251. list_namespace_tables seems to fail (apurtell: rev 1515185)

        • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/master/HMaster.java
        • /hbase/trunk/hbase-server/src/test/ruby/hbase/admin_test.rb
        Hudson added a comment -

        FAILURE: Integrated in hbase-0.95 #466 (See https://builds.apache.org/job/hbase-0.95/466/)
        HBASE-9251. list_namespace_tables seems to fail (apurtell: rev 1515184)

        • /hbase/branches/0.95/hbase-server/src/main/java/org/apache/hadoop/hbase/master/HMaster.java
        • /hbase/branches/0.95/hbase-server/src/test/ruby/hbase/admin_test.rb
        Hudson added a comment -

        SUCCESS: Integrated in HBase-TRUNK #4409 (See https://builds.apache.org/job/HBase-TRUNK/4409/)
        HBASE-9251. list_namespace_tables seems to fail (apurtell: rev 1515185)

        • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/master/HMaster.java
        • /hbase/trunk/hbase-server/src/test/ruby/hbase/admin_test.rb
        Andrew Purtell added a comment -

        Committed to trunk and 0.95.

        -------------------------------------------------------
         T E S T S
        -------------------------------------------------------
        Running org.apache.hadoop.hbase.client.TestShell
        Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 133.84 sec
        
        Results :
        
        Tests run: 1, Failures: 0, Errors: 0, Skipped: 0
        
        stack added a comment -

        +1 Go for it.

        Andrew Purtell added a comment -

        Actual problem, not a validation issue. Attached patch also adds coverage to TestShell.

        Andrew Purtell added a comment - - edited

        Will add coverage to TestShell for this.

        Andrew Purtell added a comment -

        We should relax this check in TableName since a system TableName can have "illegal" characters.

        Or I can go back to having the list table names API return strings, but TableName is used elsewhere so that would be inconsistent.


          People

          • Assignee:
            Andrew Purtell
            Reporter:
            Devaraj Das
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development