HBase
  1. HBase
  2. HBASE-8219

Align Offline Merge with Online Merge

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.95.0
    • Fix Version/s: 0.98.0, 0.95.2
    • Component/s: regionserver
    • Labels:
      None
    • Hadoop Flags:
      Reviewed
    • Tags:
      0.96notable

      Description

      After HBASE-7403 we now have two different tools for online and offline merge, and the result produced by the two are different. (the online one works with snapshots, the offline not)

      We should remove the offline one, or align it to the online code.
      Most of the offline code in HRegion.merge() can be replaced with the one in RegionMergeTransaction, used by the online version.

      1. hbase-8219v3.patch
        8 kB
        chunhui shen
      2. hbase-8219v2.patch
        8 kB
        chunhui shen
      3. hbase-8219v1.patch
        8 kB
        chunhui shen

        Activity

        Matteo Bertozzi created issue -
        Ted Yu added a comment -

        Recent discussion on mailing list didn't come to conclusion of removing offline merge.

        We can consider alignment.

        Jean-Marc Spaggiari added a comment -

        I agree too. We should not remove it. So the only option here will be to allign it.

        Matteo Bertozzi, are you going to work on that? Or mayne chunhui shen is the best person for that?

        Ted Yu made changes -
        Field Original Value New Value
        Summary Align Offline and Online Merge Align Offline Merge with Online Merge
        Matteo Bertozzi added a comment -

        I missed the remove discussion, but I'm +1 on it since the offline requires the cluster to be down.
        Should we consider this jira as fixing the offline merge in 0.94 just to don't break snapshots?

        chunhui shen added a comment -

        +1 on making offline merge not break snapshots,
        it would change a little code which we only need create reference files instead of moving files in offline merge

        Jean-Marc Spaggiari added a comment -

        chunhui shen are you going to take care of that?

        chunhui shen added a comment -

        Alignment or just fixing the snapshots break?

        I'm glad to make a patch for this if you trust me.

        Jean-Marc Spaggiari added a comment -

        Alligning the 2 will fix the snapshots break, no?

        Jonathan Hsieh added a comment -

        I like the idea of having them share common code, and don't like the idea of removing offline at the moment.

        chunhui shen made changes -
        Assignee chunhui shen [ zjushch ]
        chunhui shen added a comment -

        Making a patch for alignment.

        Also fix a bug when choosing the startkey and endkey of merged region in online merge.(It could be caused if one merging region's range contains another's)

        chunhui shen made changes -
        Attachment hbase-8219v1.patch [ 12576094 ]
        chunhui shen made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Ted Yu added a comment -
        +      throw new IOException("Unable to merge region " + a + " and " + b);
        

        'merge region' -> 'merge regions'

        +      dstRegion = rmt.execute(null, null);
        

        Looking into execute() method:

            HRegion mergedRegion = createMergedRegion(server, services);
            openMergedRegion(server, services, mergedRegion);
            transitionZKNode(server, services);
            return mergedRegion;
        

        The second and third calls wouldn't have effect because server is null.
        So if we expose createMergedRegion() as public method, we can call it directly.

        Sergey Shelukhin added a comment -

        (It could be caused if one merging region's range contains another's)

        Is it a legal condition?

        Enis Soztutar added a comment -

        Some dev@ discussions for this was at: http://search-hadoop.com/m/j2Szb1U3Bzf/online+merge&subj=Re+How+to+replace+MetaUtils+ScannerListener+

        I agree that there should be one tool called Merge, which would work in online mode or offline mode. I was suggesting to get rid of offline one, because on the longer term, it does not make sense to have offline split / merge code. But let's keep the offline merge for now, and reevaluate when the time comes.

        Jean-Marc Spaggiari added a comment -

        Sergey Shelukhin I don't think it's a legal condition, but it might allow you to merge 2 regions having boundaries issues... And then create a cleaned one.

        Enis Soztutar added a comment -

        BTW, in this issue or a follow up, let's merge org.apache.hadoop.hbase.util.Merge, org.apache.hadoop.hbase.util.HMerge, and the recent online merge bits. Maybe we can also implement hbase shell bindings for online one.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12576094/hbase-8219v1.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 hadoop2.0. The patch compiles against the hadoop 2.0 profile.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 lineLengths. The patch does not introduce lines longer than 100

        -1 site. The patch appears to cause mvn site goal to fail.

        -1 core tests. The patch failed these unit tests:
        org.apache.hadoop.hbase.master.TestSplitLogManager

        Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/5046//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5046//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-protocol.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5046//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-client.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5046//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-examples.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5046//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop1-compat.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5046//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5046//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5046//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5046//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
        Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/5046//console

        This message is automatically generated.

        chunhui shen added a comment -

        The second and third calls wouldn't have effect because server is null.So if we expose createMergedRegion() as public method, we can call it directly.

        merged.openHRegion(reporter) is also called in RegionMergeTransaction#openMergedRegion.

        Maybe we can also implement hbase shell bindings for online one.

        Shell command of online region is already done(HBASE-8189)

        IMHO,
        1.We should fix the snapshot break caused by offline merge now
        2.Do some easy alignment about the code of online merge and offline merge, since we plan to remove offline merge in a futuer moment

        chunhui shen added a comment -

        Addressing Ted's comment

        chunhui shen made changes -
        Attachment hbase-8219v2.patch [ 12576331 ]
        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12576331/hbase-8219v2.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 hadoop2.0. The patch compiles against the hadoop 2.0 profile.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 lineLengths. The patch does not introduce lines longer than 100

        +1 site. The mvn site goal succeeds with this patch.

        +1 core tests. The patch passed unit tests in .

        Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/5077//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5077//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5077//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-client.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5077//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5077//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-protocol.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5077//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5077//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop1-compat.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5077//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-examples.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/5077//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
        Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/5077//console

        This message is automatically generated.

        Ted Yu added a comment -

        +1 from me.

        Matteo Bertozzi added a comment -

        A compaction is called on the merge region, this means that after that call the region will not have reference files, but the real data. right?
        so at this point the other two regions are removed by using the archiver, are they empty after the compaction? they should, right... maybe add an assert there.

        if what I have said above is true, I'm +1 on the patch (with the assert if you want)

        chunhui shen added a comment -

        the other two regions are removed by using the archiver,are they empty after the compaction?

        what does the 'empty' mean? After the compaction, the two regions' storefiles are still in their directory. Then archiving these files (may be used for snapshot) by archiver

        chunhui shen added a comment -

        Patch v3: take a check whether merged region has reference after the compaction

        chunhui shen made changes -
        Attachment hbase-8219v3.patch [ 12576482 ]
        chunhui shen added a comment -

        Matteo Bertozzi
        What do you think about the latest patch ?

        Matteo Bertozzi added a comment -

        +1 on patch v3

        chunhui shen added a comment -

        Committed to trunk and 0.95,
        Thanks for the review,matteo, ted

        chunhui shen made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Hadoop Flags Reviewed [ 10343 ]
        Fix Version/s 0.98.0 [ 12323143 ]
        Fix Version/s 0.95.2 [ 12320040 ]
        Resolution Fixed [ 1 ]
        Hudson added a comment -

        Integrated in hbase-0.95-on-hadoop2 #62 (See https://builds.apache.org/job/hbase-0.95-on-hadoop2/62/)
        HBASE-8219 Align Offline Merge with Online Merge (Revision 1465953)

        Result = FAILURE
        zjushch :
        Files :

        • /hbase/branches/0.95/hbase-server/src/main/java/org/apache/hadoop/hbase/regionserver/HRegion.java
        • /hbase/branches/0.95/hbase-server/src/main/java/org/apache/hadoop/hbase/regionserver/RegionMergeTransaction.java
        Hudson added a comment -

        Integrated in hbase-0.95 #135 (See https://builds.apache.org/job/hbase-0.95/135/)
        HBASE-8219 Align Offline Merge with Online Merge (Revision 1465953)

        Result = FAILURE
        zjushch :
        Files :

        • /hbase/branches/0.95/hbase-server/src/main/java/org/apache/hadoop/hbase/regionserver/HRegion.java
        • /hbase/branches/0.95/hbase-server/src/main/java/org/apache/hadoop/hbase/regionserver/RegionMergeTransaction.java
        Hudson added a comment -

        Integrated in HBase-TRUNK-on-Hadoop-2.0.0 #489 (See https://builds.apache.org/job/HBase-TRUNK-on-Hadoop-2.0.0/489/)
        HBASE-8219 Align Offline Merge with Online Merge (Revision 1465943)

        Result = FAILURE
        zjushch :
        Files :

        • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/regionserver/HRegion.java
        • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/regionserver/RegionMergeTransaction.java
        Hudson added a comment -

        Integrated in HBase-TRUNK #4046 (See https://builds.apache.org/job/HBase-TRUNK/4046/)
        HBASE-8219 Align Offline Merge with Online Merge (Revision 1465943)

        Result = FAILURE
        zjushch :
        Files :

        • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/regionserver/HRegion.java
        • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/regionserver/RegionMergeTransaction.java
        Sergey Shelukhin added a comment -

        The merge of the merges has been merged

        stack made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        stack made changes -
        Tags 0.96notable

          People

          • Assignee:
            chunhui shen
            Reporter:
            Matteo Bertozzi
          • Votes:
            0 Vote for this issue
            Watchers:
            10 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development