Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-6775

Use ZK.multi when available for HBASE-6710 0.92/0.94 compatibility fix

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 0.94.2
    • Fix Version/s: 0.94.4
    • Component/s: Zookeeper
    • Labels:
      None
    • Release Note:
      Hide
      hbase.zookeeper.useMulti
      Instructs HBase to make use of ZooKeeper's multi-update functionality.
      + This allows certain ZooKeeper operations to complete more quickly and prevents some issues
      + with rare ZooKeeper failure scenarios (see the release note of HBASE-6710 for an example).
      + IMPORTANT: only set this to true if all ZooKeeper servers in the cluster are on version 3.4+
      + and will not be downgraded. ZooKeeper versions before 3.4 do not support multi-update and will
      + not fail gracefully if multi-update is invoked (see ZOOKEEPER-1495).
      Show
      hbase.zookeeper.useMulti Instructs HBase to make use of ZooKeeper's multi-update functionality. + This allows certain ZooKeeper operations to complete more quickly and prevents some issues + with rare ZooKeeper failure scenarios (see the release note of HBASE-6710 for an example). + IMPORTANT: only set this to true if all ZooKeeper servers in the cluster are on version 3.4+ + and will not be downgraded. ZooKeeper versions before 3.4 do not support multi-update and will + not fail gracefully if multi-update is invoked (see ZOOKEEPER-1495 ).

      Description

      This issue introduces the ability for the HMaster to make use of ZooKeeper's multi-update functionality. This allows certain ZooKeeper operations to complete more quickly and prevents some issues with rare ZooKeeper failure scenarios (see the release note of HBASE-6710 for an example). This feature is off by default; to enable set "hbase.zookeeper.useMulti" to true in the configuration of the HMaster.

      IMPORTANT: "hbase.zookeeper.useMulti" should only be set to true if all ZooKeeper servers in the cluster are on version 3.4+ and will not be downgraded. ZooKeeper versions before 3.4 do not support multi-update and will not fail gracefully if multi-update is invoked (see ZOOKEEPER-1495).

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                gchanan Gregory Chanan
                Reporter:
                gchanan Gregory Chanan
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: