HBase
  1. HBase
  2. HBASE-5680

Improve compatibility warning about HBase with Hadoop 0.23.x

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.90.6, 0.92.1, 0.94.0, 0.95.2
    • Fix Version/s: 0.94.0, 0.95.0
    • Component/s: master
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Hmaster is not able to start because of the following error
      Please find the following error
      ----------------------------
      2012-03-30 11:12:19,487 FATAL org.apache.hadoop.hbase.master.HMaster: Unhandled exception. Starting shutdown.
      java.lang.NoClassDefFoundError: org/apache/hadoop/hdfs/protocol/FSConstants$SafeModeAction
      at org.apache.hadoop.hbase.util.FSUtils.waitOnSafeMode(FSUtils.java:524)
      at org.apache.hadoop.hbase.master.MasterFileSystem.checkRootDir(MasterFileSystem.java:324)
      at org.apache.hadoop.hbase.master.MasterFileSystem.createInitialFileSystemLayout(MasterFileSystem.java:127)
      at org.apache.hadoop.hbase.master.MasterFileSystem.<init>(MasterFileSystem.java:112)
      at org.apache.hadoop.hbase.master.HMaster.finishInitialization(HMaster.java:496)
      at org.apache.hadoop.hbase.master.HMaster.run(HMaster.java:363)
      at java.lang.Thread.run(Thread.java:662)
      Caused by: java.lang.ClassNotFoundException: org.apache.hadoop.hdfs.protocol.FSConstants$SafeModeAction
      at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
      at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
      ... 7 more
      There is a change in the FSConstants

        Activity

        Hide
        Uma Maheswara Rao G added a comment -

        I remember, in 23 Version FSConstants has been deprecated.

        @Deprecated
        public abstract class FSConstants extends HdfsConstants {
        }
        

        And also HdfsConstants marked as InterfaceAudience.Private

        @InterfaceAudience.Private
        public class HdfsConstants {
        

        I just commented in HDFS-1599, accessing something internal to DFS will create difficulties in later times for migrating the versions with Hadoop right. no?

        Show
        Uma Maheswara Rao G added a comment - I remember, in 23 Version FSConstants has been deprecated. @Deprecated public abstract class FSConstants extends HdfsConstants { } And also HdfsConstants marked as InterfaceAudience.Private @InterfaceAudience.Private public class HdfsConstants { I just commented in HDFS-1599 , accessing something internal to DFS will create difficulties in later times for migrating the versions with Hadoop right. no?
        Hide
        Ted Yu added a comment -

        Using reflection should solve this problem.

        Show
        Ted Yu added a comment - Using reflection should solve this problem.
        Hide
        Jonathan Hsieh added a comment - - edited

        The master runs on top of hadoop 0.23.x
        apache 0.92.1 recompiled with the security profile on (-Psecurity) and with -Dhadoop.profile=23
        apache 0.94.0rc0 recompiled with the security profile on (-Psecurity) and with -Dhadoop.profile=23

        The master fails on top of hadoop 0.23.x with the class not found error in these cases:
        apache 0.92.1 right out of tarball
        apache 0.92.1 with the security profile off with -Dhadoop.profile=23
        apache 0.94.0rc0 right out of tarball.
        apache 0.94.0rc0 security right out of tarball.
        apache 0.94.0rc0 with the security profile off with -Dhadoop.profile=23

        Show
        Jonathan Hsieh added a comment - - edited The master runs on top of hadoop 0.23.x apache 0.92.1 recompiled with the security profile on (-Psecurity) and with -Dhadoop.profile=23 apache 0.94.0rc0 recompiled with the security profile on (-Psecurity) and with -Dhadoop.profile=23 The master fails on top of hadoop 0.23.x with the class not found error in these cases: apache 0.92.1 right out of tarball apache 0.92.1 with the security profile off with -Dhadoop.profile=23 apache 0.94.0rc0 right out of tarball. apache 0.94.0rc0 security right out of tarball. apache 0.94.0rc0 with the security profile off with -Dhadoop.profile=23
        Hide
        Jonathan Hsieh added a comment -

        Tried it again, and actually – if you recompile using -Dhadoop.profile=23 without the security profile the Master comes up and does not encounter the problem.

        (I probably had the wrong hadoop jars in my hbase classpath).

        So it boils down to needing to recompile hbase against hadoop 23.

        Maybe we should catch this exception and warn the user to recompile HBase, or possibly put out yet another package that is compiled against 23.

        Show
        Jonathan Hsieh added a comment - Tried it again, and actually – if you recompile using -Dhadoop.profile=23 without the security profile the Master comes up and does not encounter the problem. (I probably had the wrong hadoop jars in my hbase classpath). So it boils down to needing to recompile hbase against hadoop 23. Maybe we should catch this exception and warn the user to recompile HBase, or possibly put out yet another package that is compiled against 23.
        Hide
        ramkrishna.s.vasudevan added a comment -

        @Jon
        Let me try once again. I tried compiling using 23 profile. May be i missed something. Will try again and update on that. Thanks

        Show
        ramkrishna.s.vasudevan added a comment - @Jon Let me try once again. I tried compiling using 23 profile. May be i missed something. Will try again and update on that. Thanks
        Hide
        Jonathan Hsieh added a comment - - edited

        @Ram – when I did it i used 'mvn package -DskipTests -Dhadoop.profile=23' and then ran from a copy of the dir generated in target/hbase-xxx/hbase-xxx. If you run from the directory you ran the mvn command in, I think hbase scripts will pick up hbase from that dir, or possibly the 1.0.0 version from the ~/.m2 dir. I think this is what caught me the first time I tried this.

        Show
        Jonathan Hsieh added a comment - - edited @Ram – when I did it i used 'mvn package -DskipTests -Dhadoop.profile=23' and then ran from a copy of the dir generated in target/hbase-xxx/hbase-xxx. If you run from the directory you ran the mvn command in, I think hbase scripts will pick up hbase from that dir, or possibly the 1.0.0 version from the ~/.m2 dir. I think this is what caught me the first time I tried this.
        Hide
        ramkrishna.s.vasudevan added a comment -

        @Jon
        'mvn package -DskipTests -Dhadoop.profile=23' - used this command to generate a jar of 0.94.

        We have 0.94 installation. Already our installation is having only 0.23.1 hadoop jars in the classpath. Now we replaced the jar created from step 1 and tried again. Ended up in getting the same exception. Are we missing something here?

        Show
        ramkrishna.s.vasudevan added a comment - @Jon 'mvn package -DskipTests -Dhadoop.profile=23' - used this command to generate a jar of 0.94. We have 0.94 installation. Already our installation is having only 0.23.1 hadoop jars in the classpath. Now we replaced the jar created from step 1 and tried again. Ended up in getting the same exception. Are we missing something here?
        Hide
        Jonathan Hsieh added a comment -

        Hm.. I didn't add all the hadoop 23 jars – I added:

        hadoop-auth-*.jar
        hadoop-common-*.jar
        hadoop-hdfs-*.jar

        I didn't add any of the mapreduce or yarn jars maybe that has something to do with it. A lot of the recompile was due to changes in MR2 (classes turned into interfaces, and shims to allow compilation). Can you try moving those jars out of the way?

        By just including those jars, I've run some recompiled mr jobs using a command line like this:

        HADOOP_HOME=`hbase classpath` hadoop jar xxx.jar <Class> <args..>

        Show
        Jonathan Hsieh added a comment - Hm.. I didn't add all the hadoop 23 jars – I added: hadoop-auth-*.jar hadoop-common-*.jar hadoop-hdfs-*.jar I didn't add any of the mapreduce or yarn jars maybe that has something to do with it. A lot of the recompile was due to changes in MR2 (classes turned into interfaces, and shims to allow compilation). Can you try moving those jars out of the way? By just including those jars, I've run some recompiled mr jobs using a command line like this: HADOOP_HOME=`hbase classpath` hadoop jar xxx.jar <Class> <args..>
        Hide
        ramkrishna.s.vasudevan added a comment -

        @Jon
        Its working now. Cleared all the classes inside target and regenerated. Thanks Jon.

        Show
        ramkrishna.s.vasudevan added a comment - @Jon Its working now. Cleared all the classes inside target and regenerated. Thanks Jon.
        Hide
        Jonathan Hsieh added a comment -

        I feel like to resolve this we should give the user some sort of warning about needing to recompile against hadoop23 (or vice versa if a version compiled against hadoop23 is attempts to run against a hadoop 1.0.0/0.20.x based hdfs). Thoughts?

        Show
        Jonathan Hsieh added a comment - I feel like to resolve this we should give the user some sort of warning about needing to recompile against hadoop23 (or vice versa if a version compiled against hadoop23 is attempts to run against a hadoop 1.0.0/0.20.x based hdfs). Thoughts?
        Hide
        stack added a comment -



        Yes. Unless someone has a bit of reflection jujitsu they can apply here. It'd be a PITA shipping four tgzs. Two is already too many.

        Show
        stack added a comment - Yes. Unless someone has a bit of reflection jujitsu they can apply here. It'd be a PITA shipping four tgzs. Two is already too many.
        Hide
        Lars Hofhansl added a comment -

        What's the general feeling w.r.t. to 0.94.0? Should I hold off RC1 for this?

        Show
        Lars Hofhansl added a comment - What's the general feeling w.r.t. to 0.94.0? Should I hold off RC1 for this?
        Hide
        ramkrishna.s.vasudevan added a comment -

        Can we patch HBase side to give a warning log for this?

        Show
        ramkrishna.s.vasudevan added a comment - Can we patch HBase side to give a warning log for this?
        Hide
        Jonathan Hsieh added a comment -

        I started one that emits a better warning, need to test still.

        Sent from my iPhone

        Show
        Jonathan Hsieh added a comment - I started one that emits a better warning, need to test still. Sent from my iPhone
        Hide
        Jonathan Hsieh added a comment -

        This is my test result – new actionable FATAL warning message in master log:

        2012-04-05 22:51:34,267 FATAL master.HMaster (HMaster.java:abort(1385)) - HBase is having a problem with its Hadoop jars.  You may need to recompile HBase against Hadoop version 0.23.0-cdh4b1 or change your hadoop jars to start properly
        java.lang.NoClassDefFoundError: org/apache/hadoop/hdfs/protocol/FSConstants$SafeModeAction
                at org.apache.hadoop.hbase.util.FSUtils.waitOnSafeMode(FSUtils.java:524)
                at org.apache.hadoop.hbase.master.MasterFileSystem.checkRootDir(MasterFileSystem.java:324)
                at org.apache.hadoop.hbase.master.MasterFileSystem.createInitialFileSystemLayout(MasterFileSystem.java:127)
                at org.apache.hadoop.hbase.master.MasterFileSystem.<init>(MasterFileSystem.java:112)
                at org.apache.hadoop.hbase.master.HMaster.finishInitialization(HMaster.java:479)
                at org.apache.hadoop.hbase.master.HMaster.run(HMaster.java:342)
                at java.lang.Thread.run(Thread.java:662)
        Caused by: java.lang.ClassNotFoundException: org.apache.hadoop.hdfs.protocol.FSConstants$SafeModeAction
                at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
                at java.security.AccessController.doPrivileged(Native Method)
                at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
                at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
                at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
                at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
                ... 7 more
        
        Show
        Jonathan Hsieh added a comment - This is my test result – new actionable FATAL warning message in master log: 2012-04-05 22:51:34,267 FATAL master.HMaster (HMaster.java:abort(1385)) - HBase is having a problem with its Hadoop jars. You may need to recompile HBase against Hadoop version 0.23.0-cdh4b1 or change your hadoop jars to start properly java.lang.NoClassDefFoundError: org/apache/hadoop/hdfs/protocol/FSConstants$SafeModeAction at org.apache.hadoop.hbase.util.FSUtils.waitOnSafeMode(FSUtils.java:524) at org.apache.hadoop.hbase.master.MasterFileSystem.checkRootDir(MasterFileSystem.java:324) at org.apache.hadoop.hbase.master.MasterFileSystem.createInitialFileSystemLayout(MasterFileSystem.java:127) at org.apache.hadoop.hbase.master.MasterFileSystem.<init>(MasterFileSystem.java:112) at org.apache.hadoop.hbase.master.HMaster.finishInitialization(HMaster.java:479) at org.apache.hadoop.hbase.master.HMaster.run(HMaster.java:342) at java.lang. Thread .run( Thread .java:662) Caused by: java.lang.ClassNotFoundException: org.apache.hadoop.hdfs.protocol.FSConstants$SafeModeAction at java.net.URLClassLoader$1.run(URLClassLoader.java:202) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:190) at java.lang. ClassLoader .loadClass( ClassLoader .java:306) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301) at java.lang. ClassLoader .loadClass( ClassLoader .java:247) ... 7 more
        Hide
        Jonathan Hsieh added a comment -

        Attached version tested on 0.94.

        Show
        Jonathan Hsieh added a comment - Attached version tested on 0.94.
        Hide
        Jonathan Hsieh added a comment -

        How to test:

        • Setup hadoop hdfs 0.23.x cluster.
        • Compile against 1.0.x hadoop. mvn clean package -DskipTests
        • Make HBASE_HOME ./target/hbase-version/hbase-version
        • Replace hadoop jars in ./target/hbase-version/hbase-version/lib/ with hadoop 23 jars.
        • start hbase.
        • Look at master log.
        Show
        Jonathan Hsieh added a comment - How to test: Setup hadoop hdfs 0.23.x cluster. Compile against 1.0.x hadoop. mvn clean package -DskipTests Make HBASE_HOME ./target/hbase-version/hbase-version Replace hadoop jars in ./target/hbase-version/hbase-version/lib/ with hadoop 23 jars. start hbase. Look at master log.
        Hide
        Jonathan Hsieh added a comment -

        Patch applies on 0.90/0.92/0.94/0.96.

        Show
        Jonathan Hsieh added a comment - Patch applies on 0.90/0.92/0.94/0.96.
        Hide
        ramkrishna.s.vasudevan added a comment -

        @Jon
        Looks good to me. Thanks.

        Show
        ramkrishna.s.vasudevan added a comment - @Jon Looks good to me. Thanks.
        Hide
        Ted Yu added a comment -

        Is cdh4b1 the only 0.23 distro ?

        Show
        Ted Yu added a comment - Is cdh4b1 the only 0.23 distro ?
        Hide
        Jonathan Hsieh added a comment -

        if you look the patch, it takes the HadoopVersionAnnotation value that's compiled into the hadoop jar that is linked in. I tested against CDH Hadoop 23 in this case but if you use apache Hadoop 0.23.1 it will say that.

        Sent from my iPhone

        Show
        Jonathan Hsieh added a comment - if you look the patch, it takes the HadoopVersionAnnotation value that's compiled into the hadoop jar that is linked in. I tested against CDH Hadoop 23 in this case but if you use apache Hadoop 0.23.1 it will say that. Sent from my iPhone
        Hide
        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12521651/hbase-5680-94.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests:
        org.apache.hadoop.hbase.io.hfile.TestForceCacheImportantBlocks

        Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/1428//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/1428//artifact/trunk/patchprocess/newPatchFindbugsWarnings.html
        Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/1428//console

        This message is automatically generated.

        Show
        Hadoop QA added a comment - -1 overall. Here are the results of testing the latest attachment http://issues.apache.org/jira/secure/attachment/12521651/hbase-5680-94.patch against trunk revision . +1 @author. The patch does not contain any @author tags. -1 tests included. The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch. +1 javadoc. The javadoc tool did not generate any warning messages. +1 javac. The applied patch does not increase the total number of javac compiler warnings. +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings. +1 release audit. The applied patch does not increase the total number of release audit warnings. -1 core tests. The patch failed these unit tests: org.apache.hadoop.hbase.io.hfile.TestForceCacheImportantBlocks Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/1428//testReport/ Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/1428//artifact/trunk/patchprocess/newPatchFindbugsWarnings.html Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/1428//console This message is automatically generated.
        Hide
        Ted Yu added a comment -

        Thanks for the reply, Jon.

        Show
        Ted Yu added a comment - Thanks for the reply, Jon.
        Hide
        stack added a comment -

        +1 on patch

        Show
        stack added a comment - +1 on patch
        Hide
        Jonathan Hsieh added a comment -

        Failed test worked locally for me, and is unrelated.

        Commiting to 0.90/0.92/0.94/trunk. Thanks for taking a look ram, ted, stack!

        Show
        Jonathan Hsieh added a comment - Failed test worked locally for me, and is unrelated. Commiting to 0.90/0.92/0.94/trunk. Thanks for taking a look ram, ted, stack!
        Hide
        Hudson added a comment -

        Integrated in HBase-TRUNK #2720 (See https://builds.apache.org/job/HBase-TRUNK/2720/)
        HBASE-5680 Improve compatibility warning about HBase with Hadoop 0.23.x (Revision 1310429)

        Result = SUCCESS
        jmhsieh :
        Files :

        • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/master/HMaster.java
        Show
        Hudson added a comment - Integrated in HBase-TRUNK #2720 (See https://builds.apache.org/job/HBase-TRUNK/2720/ ) HBASE-5680 Improve compatibility warning about HBase with Hadoop 0.23.x (Revision 1310429) Result = SUCCESS jmhsieh : Files : /hbase/trunk/src/main/java/org/apache/hadoop/hbase/master/HMaster.java
        Hide
        Hudson added a comment -

        Integrated in HBase-0.94 #93 (See https://builds.apache.org/job/HBase-0.94/93/)
        HBASE-5680 Improve compatibility warning about HBase with Hadoop 0.23.x (Revision 1310433)

        Result = SUCCESS
        jmhsieh :
        Files :

        • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/master/HMaster.java
        Show
        Hudson added a comment - Integrated in HBase-0.94 #93 (See https://builds.apache.org/job/HBase-0.94/93/ ) HBASE-5680 Improve compatibility warning about HBase with Hadoop 0.23.x (Revision 1310433) Result = SUCCESS jmhsieh : Files : /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/master/HMaster.java
        Hide
        Hudson added a comment -

        Integrated in HBase-0.92 #360 (See https://builds.apache.org/job/HBase-0.92/360/)
        HBASE-5680 Improve compatibility warning about HBase with Hadoop 0.23.x (Revision 1310434)

        Result = SUCCESS
        jmhsieh :
        Files :

        • /hbase/branches/0.92/CHANGES.txt
        • /hbase/branches/0.92/src/main/java/org/apache/hadoop/hbase/master/HMaster.java
        Show
        Hudson added a comment - Integrated in HBase-0.92 #360 (See https://builds.apache.org/job/HBase-0.92/360/ ) HBASE-5680 Improve compatibility warning about HBase with Hadoop 0.23.x (Revision 1310434) Result = SUCCESS jmhsieh : Files : /hbase/branches/0.92/CHANGES.txt /hbase/branches/0.92/src/main/java/org/apache/hadoop/hbase/master/HMaster.java
        Hide
        Hudson added a comment -

        Integrated in HBase-TRUNK-security #161 (See https://builds.apache.org/job/HBase-TRUNK-security/161/)
        HBASE-5680 Improve compatibility warning about HBase with Hadoop 0.23.x (Revision 1310429)

        Result = FAILURE
        jmhsieh :
        Files :

        • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/master/HMaster.java
        Show
        Hudson added a comment - Integrated in HBase-TRUNK-security #161 (See https://builds.apache.org/job/HBase-TRUNK-security/161/ ) HBASE-5680 Improve compatibility warning about HBase with Hadoop 0.23.x (Revision 1310429) Result = FAILURE jmhsieh : Files : /hbase/trunk/src/main/java/org/apache/hadoop/hbase/master/HMaster.java
        Hide
        Hudson added a comment -

        Integrated in HBase-0.94-security #8 (See https://builds.apache.org/job/HBase-0.94-security/8/)
        HBASE-5680 Improve compatibility warning about HBase with Hadoop 0.23.x (Revision 1310433)

        Result = SUCCESS
        jmhsieh :
        Files :

        • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/master/HMaster.java
        Show
        Hudson added a comment - Integrated in HBase-0.94-security #8 (See https://builds.apache.org/job/HBase-0.94-security/8/ ) HBASE-5680 Improve compatibility warning about HBase with Hadoop 0.23.x (Revision 1310433) Result = SUCCESS jmhsieh : Files : /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/master/HMaster.java
        Hide
        Hudson added a comment -

        Integrated in HBase-0.92-security #105 (See https://builds.apache.org/job/HBase-0.92-security/105/)
        HBASE-5680 Improve compatibility warning about HBase with Hadoop 0.23.x (Revision 1310434)

        Result = FAILURE
        jmhsieh :
        Files :

        • /hbase/branches/0.92/CHANGES.txt
        • /hbase/branches/0.92/src/main/java/org/apache/hadoop/hbase/master/HMaster.java
        Show
        Hudson added a comment - Integrated in HBase-0.92-security #105 (See https://builds.apache.org/job/HBase-0.92-security/105/ ) HBASE-5680 Improve compatibility warning about HBase with Hadoop 0.23.x (Revision 1310434) Result = FAILURE jmhsieh : Files : /hbase/branches/0.92/CHANGES.txt /hbase/branches/0.92/src/main/java/org/apache/hadoop/hbase/master/HMaster.java
        Hide
        dangyifei added a comment -

        如何解决的呢?我还是没有明白

        Show
        dangyifei added a comment - 如何解决的呢?我还是没有明白
        Hide
        Jean-Daniel Cryans added a comment -

        dangyifei You might want to write in English in the future as this the common language we use.

        So, Google Translate is telling me that you don't know how solve this? Considering that this issue was closed a year ago, you might want to go to the user mailing list (http://hbase.apache.org/mail-lists.html) and ask a more specific question there, including how exactly it doesn't work for you.

        Show
        Jean-Daniel Cryans added a comment - dangyifei You might want to write in English in the future as this the common language we use. So, Google Translate is telling me that you don't know how solve this? Considering that this issue was closed a year ago, you might want to go to the user mailing list ( http://hbase.apache.org/mail-lists.html ) and ask a more specific question there, including how exactly it doesn't work for you.
        Hide
        dangyifei added a comment -

        Thank you!This issue yesterday afternoon has been resolved, that causes this error hadoop version is not compatible with the process of compiling forget to specify in the pom.xml hadoop version.

        Show
        dangyifei added a comment - Thank you!This issue yesterday afternoon has been resolved, that causes this error hadoop version is not compatible with the process of compiling forget to specify in the pom.xml hadoop version.

          People

          • Assignee:
            Jonathan Hsieh
            Reporter:
            Kristam Subba Swathi
          • Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development