HBase
  1. HBase
  2. HBASE-4683

Always cache index and bloom blocks

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.92.0, 0.94.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      This would add a new boolean config option: hfile.block.cache.datablocks
      Default would be true.

      Setting this to false allows HBase in a mode where only index blocks are cached, which is useful for analytical scenarios where a useful working set of the data cannot be expected to fit into the (aggregate) cache.
      This is the equivalent of setting cacheBlocks to false on all scans (including scans on behalf of gets).

      I would like to get a general feeling about what folks think about this.
      The change itself would be simple.

      Update (Mikhail): we probably don't need a new conf option. Instead, we will make index blocks cached by default.

      1. 0001-Cache-important-block-types.patch
        47 kB
        Mikhail Bautin
      2. 4683.txt
        9 kB
        Lars Hofhansl
      3. 4683-v2.txt
        10 kB
        Lars Hofhansl
      4. ASF.LICENSE.NOT.GRANTED--D1695.1.patch
        8 kB
        Phabricator
      5. ASF.LICENSE.NOT.GRANTED--D807.1.patch
        33 kB
        Phabricator
      6. ASF.LICENSE.NOT.GRANTED--D807.2.patch
        42 kB
        Phabricator
      7. ASF.LICENSE.NOT.GRANTED--D807.3.patch
        42 kB
        Phabricator
      8. HBASE-4683-0.92-v2.patch
        8 kB
        Jean-Daniel Cryans
      9. HBASE-4683-v3.patch
        3 kB
        Jean-Daniel Cryans

        Issue Links

          Activity

          Jean-Daniel Cryans added a comment -

          Sounds sophisticated! +1

          Lars Hofhansl added a comment -

          As a separate issue... index blocks could be treated with MEMORY priority in the LRU cache.

          Jonathan Gray added a comment -

          +1 on both ideas, Lars.

          Lars Hofhansl added a comment -

          Here's the simple patch.

          This has only a global setting. Might make sense to have this per CF, or maybe per CF and a global default setting.

          Lars Hofhansl added a comment -

          As for treating index blocks with MEMORY priority (not part of the patch), should we just always do that, or should that be configurable as well?

          Lars Hofhansl added a comment -

          passes all test

          Lars Hofhansl added a comment -

          v2 has a config option to cache index block with in-memory priority.

          Lars Hofhansl added a comment -

          Any more comments? Is useful for anybody? Should I add something else? Should this maybe be set per CF?

          Jean-Daniel Cryans added a comment -

          Is useful for anybody?

          I'm sure it would be.

          Should this maybe be set per CF?

          Good question, I can't tell really without a use case although. IIUC, currently with HFile v2 setting block cache to false doesn't even cache index blocks? If so, my opinion would be that we should always cache index blocks and don't even bother having a config for that. I'm curious as if there's ever a situation where you wouldn't want to cache index blocks since they are so small.

          Lars Hofhansl added a comment -

          That might be a better option (always cache index blocks), looks like that'd be some amount of refactoring (as CacheConfig.blockCache is currently null if cache size is set to 0).

          The 2nd part of this is classifying index blocks (optionally) as in memory, so they are less likely to be evicted due to churn of data blocks.

          Jean-Daniel Cryans added a comment -

          I'm fine with not caching index blocks if there's no cache, but maybe we should educate our users instead to disable block caching on their tables instead in order to have index caching.

          The 2nd part of this is classifying index blocks (optionally) as in memory, so they are less likely to be evicted due to churn of data blocks.

          Yeah... I wonder if it's really going to make a difference...

          Lars Hofhansl added a comment -

          So what I set out to do with this already possible by disabling BLOCKCACHE on the CF.
          I think I am just going to close this jira.

          Jean-Daniel Cryans added a comment -

          So just to be sure, in HFile v2, if you disable BC for a CF does it still cache the index blocks?

          Lars Hofhansl added a comment -

          Looks like it in the code. blockCache is only null if hfile.block.cache.size is set to 0. If it is not null, the cache setting is already overridden for index blocks in HFileBlockIndex.seekToDataBlock.

          I'll verify then close this if confirmed.

          Mikhail Bautin added a comment -

          This is from HFileBlockIndex.java, line 202 (trunk): boolean shouldCache = cacheBlocks || (lookupLevel < searchTreeLevel)

          On the other hand, in HFileReaderV2 we have: cacheBlock &= cacheConf.shouldCacheDataOnRead().

          So currently, when we disable block caching, we don't even cache data blocks, and there is a valid issue to be fixed in this JIRA.

          Lars Hofhansl added a comment -

          Thanks Mikkhail.
          So it's indeed not possible to achieve this currently (by setting disabling BLOCKCACHE on the CF).
          I'll post a patch when I get to this (unless you want to )

          Mikhail Bautin added a comment -

          Lars: we won't be able to cache index blocks if the block cache is disabled completely. However, if it is enabled, we should always cache index blocks. Please let me know if your understanding of this issue is different.

          Jean-Daniel Cryans added a comment -

          Mikhail, this line seems only to be used for bloom filters:

          cacheBlock &= cacheConf.shouldCacheDataOnRead().

          What about the other meta blocks?

          Jean-Daniel Cryans added a comment -

          Oh I see it's also in readBlock...

          Mikhail Bautin added a comment -

          Actually shouldCacheDataOnRead is weird. It is true by default as long as block cache is enabled, unless it is explicitly disabled in cacheConf. So I don't really know if that particular line ever becomes a problem when block cache is enabled.

          Jean-Daniel Cryans added a comment -

          This patch for 0.92 makes it work for me. I'm backporting a few things from trunk, adding the method that Lars had in his patch and doing an additional check in readBlock to make sure we always cache indexes if there's an LRU.

          Lars Hofhansl added a comment -

          Thanks for running with this Mikhail and J-D.

          Looks good to me. Does this also work if the blockcache was disabled through the HColumnDescriptor?

          Jean-Daniel Cryans added a comment -

          The test I did was with block cache enabled on the region server but disabled for the column family I was testing.

          Phabricator added a comment -

          mbautin requested code review of "[jira] HBASE-4683 Always cache index and bloom blocks".
          Reviewers: jdcryans, lhofhansl, JIRA

          Making sure that we always cache index and bloom blocks, as long as we have block cache, even if the cache is disabled for the CF. Adding a unit test to verify this using metrics. In process of doing this, I've factored out a region creation method in HBaseTestingUtility, and cleaned up a few things in HFile readers/writers. I have also categorized HFile v1 bloom blocks (that are technically meta blocks) as bloom blocks in metrics.

          TEST PLAN
          Unit tests

          REVISION DETAIL
          https://reviews.facebook.net/D807

          AFFECTED FILES
          src/main/java/org/apache/hadoop/hbase/io/hfile/CacheConfig.java
          src/main/java/org/apache/hadoop/hbase/io/hfile/HFile.java
          src/main/java/org/apache/hadoop/hbase/io/hfile/HFileReaderV1.java
          src/main/java/org/apache/hadoop/hbase/io/hfile/HFileReaderV2.java
          src/main/java/org/apache/hadoop/hbase/regionserver/metrics/SchemaConfigured.java
          src/main/java/org/apache/hadoop/hbase/regionserver/metrics/SchemaMetrics.java
          src/test/java/org/apache/hadoop/hbase/HBaseTestingUtility.java
          src/test/java/org/apache/hadoop/hbase/io/hfile/TestForceCacheImportantBlocks.java
          src/test/java/org/apache/hadoop/hbase/regionserver/CreateRandomStoreFile.java
          src/test/java/org/apache/hadoop/hbase/regionserver/TestHRegion.java
          src/test/java/org/apache/hadoop/hbase/regionserver/TestMultiColumnScanner.java
          src/test/java/org/apache/hadoop/hbase/regionserver/TestScanWithBloomError.java
          src/test/java/org/apache/hadoop/hbase/regionserver/TestSeekOptimizations.java

          MANAGE HERALD DIFFERENTIAL RULES
          https://reviews.facebook.net/herald/view/differential/

          WHY DID I GET THIS EMAIL?
          https://reviews.facebook.net/herald/transcript/1719/

          Tip: use the X-Herald-Rules header to filter Herald messages in your client.

          Phabricator added a comment -

          lhofhansl has commented on the revision "[jira] HBASE-4683 Always cache index and bloom blocks".

          Looks good to me generally. The metric changes are unrelated, though. Correct?

          INLINE COMMENTS
          src/main/java/org/apache/hadoop/hbase/regionserver/metrics/SchemaConfigured.java:192 This is an unrelated change it seems
          src/main/java/org/apache/hadoop/hbase/regionserver/metrics/SchemaConfigured.java:248 another unrelated change

          REVISION DETAIL
          https://reviews.facebook.net/D807

          Phabricator added a comment -

          mbautin updated the revision "[jira] HBASE-4683 Always cache index and bloom blocks".
          Reviewers: jdcryans, lhofhansl, JIRA

          Actually, the metrics changes are important. The unit test uses per-CF metrics to determine whether the blocks have been cached (or not cached, for data blocks), and when running the unit test I discovered some bugs in how table and CF name are passed down to HFile readers/writers, so I had to clean that up a bit.

          REVISION DETAIL
          https://reviews.facebook.net/D807

          AFFECTED FILES
          src/main/java/org/apache/hadoop/hbase/io/hfile/CacheConfig.java
          src/main/java/org/apache/hadoop/hbase/io/hfile/HFile.java
          src/main/java/org/apache/hadoop/hbase/io/hfile/HFileReaderV1.java
          src/main/java/org/apache/hadoop/hbase/io/hfile/HFileReaderV2.java
          src/main/java/org/apache/hadoop/hbase/io/hfile/HFileWriterV2.java
          src/main/java/org/apache/hadoop/hbase/regionserver/Store.java
          src/main/java/org/apache/hadoop/hbase/regionserver/StoreFile.java
          src/main/java/org/apache/hadoop/hbase/regionserver/metrics/SchemaConfigured.java
          src/main/java/org/apache/hadoop/hbase/regionserver/metrics/SchemaMetrics.java
          src/test/java/org/apache/hadoop/hbase/HBaseTestingUtility.java
          src/test/java/org/apache/hadoop/hbase/io/hfile/TestForceCacheImportantBlocks.java
          src/test/java/org/apache/hadoop/hbase/regionserver/CreateRandomStoreFile.java
          src/test/java/org/apache/hadoop/hbase/regionserver/TestHRegion.java
          src/test/java/org/apache/hadoop/hbase/regionserver/TestMultiColumnScanner.java
          src/test/java/org/apache/hadoop/hbase/regionserver/TestScanWithBloomError.java
          src/test/java/org/apache/hadoop/hbase/regionserver/TestSeekOptimizations.java
          src/test/java/org/apache/hadoop/hbase/regionserver/metrics/TestSchemaConfigured.java

          Phabricator added a comment -

          jdcryans has commented on the revision "[jira] HBASE-4683 Always cache index and bloom blocks".

          I only have one question with compactions, after that I'm +1

          INLINE COMMENTS
          src/main/java/org/apache/hadoop/hbase/io/hfile/HFileReaderV2.java:293 Are we caching even in the case of isCompaction?

          REVISION DETAIL
          https://reviews.facebook.net/D807

          Jean-Daniel Cryans added a comment -

          This needs to be in 0.92 too, the potential performance regression is too big.

          stack added a comment -

          The below...

          +    boolean shouldCache = isBlockCacheEnabled()
          +        && (cacheDataOnRead ||
          +            category == BlockCategory.INDEX ||
          +            category == BlockCategory.BLOOM);
          +    return shouldCache;
          

          should just be:

          return isBlockCacheEnabled() &&
            (cacheDataOnRead ||
              category == BlockCategory.INDEX ||
              category == BlockCategory.BLOOM);
          

          No need of intermediary local var. But no biggie...

          Is this SchemaConfigured stuff in 0.92 branch?

          Unused imports in TestHRegion?

          Otherwise patch looks ok to me. Is it enough?

          Ted Yu added a comment - - edited

          SchemaConfigured was introduced by HBASE-4768.
          Looks like backport is needed since this JIRA is marked against 0.92

          Jean-Daniel Cryans added a comment -

          Trunk patch ported to 0.92 without the metrics, tested on my cluster with BC disabled on the family and made sure the indexes were still cached.

          Phabricator added a comment -

          lhofhansl has commented on the revision "[jira] HBASE-4683 Always cache index and bloom blocks".

          Thanks for explaining Mikhail. Looks good to me. +1

          REVISION DETAIL
          https://reviews.facebook.net/D807

          stack added a comment -

          +1 on 0.92 version of patch. Apply and i'll cut RC.

          Phabricator added a comment -

          mbautin has commented on the revision "[jira] HBASE-4683 Always cache index and bloom blocks".

          INLINE COMMENTS
          src/main/java/org/apache/hadoop/hbase/io/hfile/HFileReaderV2.java:293 Compactions mostly consist of continuous reads and should not do a lot of seeks. But yes, this will cache index/bloom blocks even in case of compactions. I guess I could add a unit test to make sure we really don't utilize the block index during compactions, and we can explicitly disable them here. Or we could leave it as it is in case compactions do use the block index in a limited way (need to find out if that is the case).
          @jdcryans: any thoughts/suggestions on this?

          REVISION DETAIL
          https://reviews.facebook.net/D807

          Phabricator added a comment -

          lhofhansl has commented on the revision "[jira] HBASE-4683 Always cache index and bloom blocks".

          I would guess that even compactions do reseeks to the next column.
          Those reseeks would be slow without the index blocks in cache.

          REVISION DETAIL
          https://reviews.facebook.net/D807

          Phabricator added a comment -

          jdcryans has accepted the revision "[jira] HBASE-4683 Always cache index and bloom blocks".

          My testing of the 0.92 patch I put in the jira shows that it works as advertised, so +1. @mbautin would you mind giving a quick at that patch to make sure I didn't do anything weird?

          REVISION DETAIL
          https://reviews.facebook.net/D807

          Mikhail Bautin added a comment -

          +1 on J-D's patch for 0.92

          Phabricator added a comment -

          mbautin updated the revision "[jira] HBASE-4683 Always cache index and bloom blocks".
          Reviewers: jdcryans, lhofhansl, JIRA

          Rebasing up to r1214519.

          REVISION DETAIL
          https://reviews.facebook.net/D807

          AFFECTED FILES
          src/main/java/org/apache/hadoop/hbase/io/hfile/AbstractHFileWriter.java
          src/main/java/org/apache/hadoop/hbase/io/hfile/CacheConfig.java
          src/main/java/org/apache/hadoop/hbase/io/hfile/HFileBlock.java
          src/main/java/org/apache/hadoop/hbase/io/hfile/HFileReaderV1.java
          src/main/java/org/apache/hadoop/hbase/io/hfile/HFileReaderV2.java
          src/main/java/org/apache/hadoop/hbase/io/hfile/HFileWriterV2.java
          src/main/java/org/apache/hadoop/hbase/regionserver/Store.java
          src/main/java/org/apache/hadoop/hbase/regionserver/StoreFile.java
          src/main/java/org/apache/hadoop/hbase/regionserver/metrics/SchemaConfigured.java
          src/main/java/org/apache/hadoop/hbase/regionserver/metrics/SchemaMetrics.java
          src/test/java/org/apache/hadoop/hbase/HBaseTestingUtility.java
          src/test/java/org/apache/hadoop/hbase/io/hfile/TestForceCacheImportantBlocks.java
          src/test/java/org/apache/hadoop/hbase/regionserver/CreateRandomStoreFile.java
          src/test/java/org/apache/hadoop/hbase/regionserver/TestHRegion.java
          src/test/java/org/apache/hadoop/hbase/regionserver/TestMultiColumnScanner.java
          src/test/java/org/apache/hadoop/hbase/regionserver/TestScanWithBloomError.java
          src/test/java/org/apache/hadoop/hbase/regionserver/TestSeekOptimizations.java
          src/test/java/org/apache/hadoop/hbase/regionserver/metrics/TestSchemaConfigured.java

          Mikhail Bautin added a comment -

          Attaching the patch rebased on top of r1214519.

          Hudson added a comment -

          Integrated in HBase-0.92 #190 (See https://builds.apache.org/job/HBase-0.92/190/)
          HBASE-4683 Always cache index and bloom blocks

          jdcryans :
          Files :

          • /hbase/branches/0.92/CHANGES.txt
          • /hbase/branches/0.92/src/main/java/org/apache/hadoop/hbase/io/hfile/BlockType.java
          • /hbase/branches/0.92/src/main/java/org/apache/hadoop/hbase/io/hfile/CacheConfig.java
          • /hbase/branches/0.92/src/main/java/org/apache/hadoop/hbase/io/hfile/HFileReaderV1.java
          • /hbase/branches/0.92/src/main/java/org/apache/hadoop/hbase/io/hfile/HFileReaderV2.java
          Hudson added a comment -

          Integrated in HBase-0.92-security #39 (See https://builds.apache.org/job/HBase-0.92-security/39/)
          HBASE-4683 Always cache index and bloom blocks

          jdcryans :
          Files :

          • /hbase/branches/0.92/CHANGES.txt
          • /hbase/branches/0.92/src/main/java/org/apache/hadoop/hbase/io/hfile/BlockType.java
          • /hbase/branches/0.92/src/main/java/org/apache/hadoop/hbase/io/hfile/CacheConfig.java
          • /hbase/branches/0.92/src/main/java/org/apache/hadoop/hbase/io/hfile/HFileReaderV1.java
          • /hbase/branches/0.92/src/main/java/org/apache/hadoop/hbase/io/hfile/HFileReaderV2.java
          Jean-Daniel Cryans added a comment -

          Committed to branch and trunk, thanks for the quick work Mikhail!

          Hudson added a comment -

          Integrated in HBase-TRUNK #2548 (See https://builds.apache.org/job/HBase-TRUNK/2548/)
          HBASE-4683 Always cache index and bloom blocks

          jdcryans :
          Files :

          • /hbase/trunk/CHANGES.txt
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/io/hfile/AbstractHFileWriter.java
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/io/hfile/CacheConfig.java
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/io/hfile/HFileBlock.java
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/io/hfile/HFileReaderV1.java
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/io/hfile/HFileReaderV2.java
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/io/hfile/HFileWriterV2.java
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/regionserver/Store.java
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/regionserver/StoreFile.java
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/regionserver/metrics/SchemaConfigured.java
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/regionserver/metrics/SchemaMetrics.java
          • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/HBaseTestingUtility.java
          • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/regionserver/CreateRandomStoreFile.java
          • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/regionserver/TestHRegion.java
          • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/regionserver/TestMultiColumnScanner.java
          • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/regionserver/TestScanWithBloomError.java
          • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/regionserver/TestSeekOptimizations.java
          • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/regionserver/metrics/TestSchemaConfigured.java
          Hudson added a comment -

          Integrated in HBase-TRUNK-security #33 (See https://builds.apache.org/job/HBase-TRUNK-security/33/)
          HBASE-4683 Always cache index and bloom blocks

          jdcryans :
          Files :

          • /hbase/trunk/CHANGES.txt
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/io/hfile/AbstractHFileWriter.java
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/io/hfile/CacheConfig.java
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/io/hfile/HFileBlock.java
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/io/hfile/HFileReaderV1.java
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/io/hfile/HFileReaderV2.java
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/io/hfile/HFileWriterV2.java
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/regionserver/Store.java
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/regionserver/StoreFile.java
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/regionserver/metrics/SchemaConfigured.java
          • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/regionserver/metrics/SchemaMetrics.java
          • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/HBaseTestingUtility.java
          • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/regionserver/CreateRandomStoreFile.java
          • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/regionserver/TestHRegion.java
          • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/regionserver/TestMultiColumnScanner.java
          • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/regionserver/TestScanWithBloomError.java
          • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/regionserver/TestSeekOptimizations.java
          • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/regionserver/metrics/TestSchemaConfigured.java
          Phabricator added a comment -

          mbautin has abandoned the revision "[jira] HBASE-4683 Always cache index and bloom blocks".
          Added CCs: nspiegelberg, stack, tedyu

          @jdcryans: you committed this one, right? Closing the Phabricator revision.

          A reminder to committers (quoting @nspiegelberg) so that we can properly close Phabricator revisions when committed (cc: @tedyu, @stack).

          > since we've decided to allow more Metadata in our commit logs, it would be nice to use the patch comments when committing this diff. Namely, including 'Differential Revision: #' will allow Phabricator to automatically mark the review as closed.

          Here are the steps to set up Arcanist and Phabricator in your working directory so you can auto-generate the commit message:

          • mvn -Darc initialize
          • arc amend --revision <revision_number>

          You can install Arcanist (arc) by following the instructions at http://www.phabricator.com/docs/phabricator/article/Arcanist_User_Guide.html. More instructions about Phabricator/JIRA integration are available at https://cwiki.apache.org/confluence/display/Hive/PhabricatorCodeReview (that is a howto for Hive but it should be very similar for HBase).

          REVISION DETAIL
          https://reviews.facebook.net/D807

          Mikhail Bautin added a comment -

          @jdcryans: it looks like TestForceCacheImportantBlocks.java was not included into your trunk commit of this JIRA. I will verify that the test still works and post an addendum patch.

          Phabricator added a comment -

          mbautin requested code review of "[jira] HBASE-4683 Test that we always cache index and bloom blocks".
          Reviewers: JIRA, jdcryans, lhofhansl, Liyin

          This was reviewed D807 but was not checked in. Submitting unit test as a separate patch, and extending the scope of the test to also handle the case when block cache is enabled for the column family.

          TEST PLAN
          Run unit tests

          REVISION DETAIL
          https://reviews.facebook.net/D1695

          AFFECTED FILES
          src/test/java/org/apache/hadoop/hbase/HBaseTestingUtility.java
          src/test/java/org/apache/hadoop/hbase/io/hfile/TestForceCacheImportantBlocks.java

          MANAGE HERALD DIFFERENTIAL RULES
          https://reviews.facebook.net/herald/view/differential/

          WHY DID I GET THIS EMAIL?
          https://reviews.facebook.net/herald/transcript/3621/

          Tip: use the X-Herald-Rules header to filter Herald messages in your client.

          Phabricator added a comment -

          jdcryans has accepted the revision "[jira] HBASE-4683 Test that we always cache index and bloom blocks".

          +1, sorry about that. Please open a new jira.

          REVISION DETAIL
          https://reviews.facebook.net/D1695

          Mikhail Bautin added a comment -

          The new JIRA with the unit test is HBASE-5382.

          Hudson added a comment -

          Integrated in HBase-TRUNK #2658 (See https://builds.apache.org/job/HBase-TRUNK/2658/)
          [jira] HBASE-5382 Test that we always cache index and bloom blocks

          Summary: This is a unit test that should have been part of HBASE-4683 but was
          not committed. The original test was reviewed as part of
          https://reviews.facebook.net/D807. Submitting unit test as a separate JIRA and
          patch, and extending the scope of the test to also handle the case when block
          cache is enabled for the column family.

          Test Plan: Run unit tests

          Reviewers: JIRA, jdcryans, lhofhansl, Liyin

          Reviewed By: jdcryans

          CC: jdcryans

          Differential Revision: https://reviews.facebook.net/D1695

          mbautin :
          Files :

          • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/HBaseTestingUtility.java
          • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/io/hfile/TestForceCacheImportantBlocks.java
          Hudson added a comment -

          Integrated in HBase-TRUNK-security #108 (See https://builds.apache.org/job/HBase-TRUNK-security/108/)
          [jira] HBASE-5382 Test that we always cache index and bloom blocks

          Summary: This is a unit test that should have been part of HBASE-4683 but was
          not committed. The original test was reviewed as part of
          https://reviews.facebook.net/D807. Submitting unit test as a separate JIRA and
          patch, and extending the scope of the test to also handle the case when block
          cache is enabled for the column family.

          Test Plan: Run unit tests

          Reviewers: JIRA, jdcryans, lhofhansl, Liyin

          Reviewed By: jdcryans

          CC: jdcryans

          Differential Revision: https://reviews.facebook.net/D1695

          mbautin :
          Files :

          • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/HBaseTestingUtility.java
          • /hbase/trunk/src/test/java/org/apache/hadoop/hbase/io/hfile/TestForceCacheImportantBlocks.java

            People

            • Assignee:
              Mikhail Bautin
              Reporter:
              Lars Hofhansl
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development