Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-25019

check if we're impacted by MASSEMBLY-941 and mitigate if needed

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.0.0-alpha-1, 2.3.0, 2.3.1, 1.6.0, 1.7.0
    • Fix Version/s: 2.5.0, 1.8.0, 3.0.0-alpha-2
    • Component/s: scripts
    • Labels:
      None

      Description

      MASSEMBLY-941 notes a bug starting in version 3.2.0 of the assembly plugin where scripts lose their executable bit.

      We've had this version since updating to the apache parent pom version 22 in HBASE-23675. We should check our release artifacts to see if we are impacted and if so downgrade the assembly plugin in our poms to 3.1.1.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                busbey Sean Busbey
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated: