Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-22574

hbase-filesystem does not build against HBase 1

    XMLWordPrintableJSON

    Details

    • Hadoop Flags:
      Reviewed

      Description

      hbase-filesystem does not build against HBase 1 because HBase 1 does not provide a hbase-zookeeper module, which is a required dependency. This could be moved into a version specific build profile.

      $ mvn clean install package -Dhbase.version=1.4.10 -Dhadoop.version=2.9.2
      ...
      [ERROR] Failed to execute goal on project hbase-oss:
      Could not resolve dependencies for project org.apache.hbase.filesystem:hbase-oss:jar:1.0.0-alpha1:
      The following artifacts could not be resolved: org.apache.hbase:hbase-zookeeper:jar:1.4.10,
      org.apache.hbase:hbase-zookeeper:jar:tests:1.4.10:
      Could not find artifact org.apache.hbase:hbase-zookeeper:jar:1.4.10 in central (https://repo.maven.apache.org/maven2)

        Attachments

        1. HBASE-22574-sean.patch
          4 kB
          Sean Mackrory
        2. HBASE-22574.patch
          3 kB
          Andrew Kyle Purtell
        3. HBASE-22574.patch
          8 kB
          Andrew Kyle Purtell
        4. HBASE-22574.patch
          8 kB
          Andrew Kyle Purtell
        5. 0001-HBASE-22574-hbase-filesystem-does-not-build-against-.patch
          10 kB
          Sean Mackrory

          Issue Links

            Activity

              People

              • Assignee:
                apurtell Andrew Kyle Purtell
                Reporter:
                apurtell Andrew Kyle Purtell
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: