Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-20264

Update Java prerequisite section with LTS rec and status of current GA JDKs

VotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 1.5.0, 2.0.0
    • Fix Version/s: 3.0.0-alpha-1
    • Component/s: documentation
    • Labels:
      None

      Description

      Per the thread [DISCUSS] strategy on Java versions

      • Add Java 9 and Java 10 to the support matrix as NT
      • Add a NOTE to Java prereqs about "use a LTS version"

      For now, leave out talk about planning for timelines on LTS additions or dropping older JDK support. Once we get over the initial hurdle of prepping for Java 11 we'll hopefully have enough info to know how realistic the things talked about in the thread are and we can include a writeup.

        Attachments

        1. HBASE-20264.1.patch
          3 kB
          Sean Busbey
        2. HBASE-20264.0.patch
          3 kB
          Sean Busbey

        Issue Links

          Activity

            People

            • Assignee:
              busbey Sean Busbey
              Reporter:
              busbey Sean Busbey

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment