Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-20216

[thirdparty] Bundle commons-cli

VotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: thirdparty-2.1.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      commons-cli 1.2 and >=1.3.1 are incompatible. Hadoop is still on 1.2, while HBase 2.0 is beyond.

      Best to start bundling this internally.

        Attachments

        1. HBASE-20216.001.patch
          2 kB
          Josh Elser

        Issue Links

          Activity

            People

            • Assignee:
              elserj Josh Elser
              Reporter:
              elserj Josh Elser

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment