HBase
  1. HBase
  2. HBASE-1954

Transactional scans do not see newest put.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.20.1
    • Fix Version/s: 0.20.2, 0.90.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      In a transaction, if I do a put, then a put, then a scan. I will not see the latest put.

      The fix is to set the timestamp at put time.

      1. 1954.patch
        2 kB
        Clint Morgan

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        24m 9s 1 stack 03/Nov/09 19:41
        Resolved Resolved Closed Closed
        1073d 10h 32m 1 stack 12/Oct/12 07:13
        stack made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        stack made changes -
        Component/s contrib [ 12312986 ]
        Clint Morgan added a comment -

        I saw a failure in TestTHLogRecovery in that Hudson output. Ran the test locally 2 times on both trunk and branch, and it passed all 4 times.

        (I don't think this patch would mess with how TTHLR is testing)

        Is something else failing? Is there a way I can reproduce?

        That TTHLR does need some work, and I'm planning on redoing in 0.21 after the core WAL stuff has settled down.

        Jean-Daniel Cryans added a comment -

        The build is unstable since this commit.

        stack made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Hadoop Flags [Reviewed]
        Resolution Fixed [ 1 ]
        stack added a comment -

        Committed branch and trunk. Thanks for patch Clint.

        Clint Morgan made changes -
        Field Original Value New Value
        Attachment 1954.patch [ 12423940 ]
        Clint Morgan added a comment -

        This fixes the issue. Adds a test that fails without the patch, passes with.

        Clint Morgan created issue -

          People

          • Assignee:
            Clint Morgan
            Reporter:
            Clint Morgan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development