Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-19018

Use of hadoop internals that require bouncycastle should declare bouncycastle dependency

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-alpha-3
    • Fix Version/s: 2.0.0-alpha-4, 2.0.0
    • Component/s: dependencies, test
    • Labels:
      None

      Description

      The tests for HBASE-15806 rely on a Hadoop internal class, KeyStoreTestUtil, which in turn relies on the Bouncycastle library for certificate generation.

      when building / running with Hadoop 2.7.1, we accidentally get a bouncycastle implementation via a transitive dependency of hadoop-minikdc. When attempting to run against Hadoop 3.0.0-alpha4 and 3.0.0-beta1 (and presumably future Hadoop 3.y releases), this bouncycastle jar is no longer pulled in and we fail with a CNFE.

        Attachments

        1. HBASE-19018.1.patch
          0.9 kB
          Sean Busbey
        2. HBASE-19018.0.patch
          2 kB
          Sean Busbey

          Issue Links

            Activity

              People

              • Assignee:
                busbey Sean Busbey
                Reporter:
                busbey Sean Busbey
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: