Since we have a bit of a messy Filter API with KeyValue vs Cell reference mixed up all over the place, I recommend cleaning this up once and for all. There should be no KeyValue (or kv, kvs etc.) in any method or parameter name.
This includes deprecating and renaming filters too, for example FirstKeyOnlyFilter, which really should be named FirstKeyValueFilter as it does not just return the key, but the entire cell. It should be deprecated and renamed to FirstCellFilter (or FirstColumnFilter if you prefer).
In general we should clarify and settle on KeyValue vs Cell vs Column in our naming. The latter two are the only ones going forward with the public API, and are used synonymous. We should carefully check which is better suited (is it really a specific cell, or the newest cell, aka the newest column value) and settle on a naming schema.