Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-12956

Binding to 0.0.0.0 is broken after HBASE-10569

VotersStop watchingWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Blocker
    • Resolution: Fixed
    • 1.0.0
    • 1.0.0, 1.1.0
    • None
    • None
    • Reviewed

    Description

      After the Region Server and Master code was merged, we lost the functionality to bind to 0.0.0.0 via hbase.regionserver.ipc.address and znodes now get created with the wildcard address which means that RSs and the master cannot connect to each other. Thanks to Dima Spivak for reporting the issue.

      Attachments

        1. HBASE-12956-v3.txt
          7 kB
          Esteban Gutierrez
        2. HBASE-12956-v2.txt
          7 kB
          Esteban Gutierrez
        3. 0001-HBASE-12956-Binding-to-0.0.0.0-is-broken-after-HBASE.patch
          6 kB
          Esteban Gutierrez

        Issue Links

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            esteban Esteban Gutierrez
            esteban Esteban Gutierrez
            Votes:
            0 Vote for this issue
            Watchers:
            7 Stop watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment