HBase
  1. HBase
  2. HBASE-10447

Memstore flusher scans storefiles also when the scanner heap gets reset

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.98.0, 0.99.0
    • Fix Version/s: 0.98.0, 0.99.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      See the mail thread
      http://osdir.com/ml/general/2014-01/msg61294.html

      In case of flush we create a memstore flusher which in turn creates a StoreScanner backed by a Single ton MemstoreScanner.

      But this scanner also registers for any updates in the reader in the HStore. Is this needed?
      If this happens then any update on the reader may nullify the current heap and the entire Scanner Stack is reset, but this time with the other scanners for all the files that satisfies the last top key. So the flush that happens on the memstore holds the storefile scanners also in the heap that was recreated but originally the intention was to create a scanner on the memstore alone.

      1. HBASE-10447_0.98.patch
        14 kB
        ramkrishna.s.vasudevan
      2. HBASE-10447_trunk.patch
        14 kB
        ramkrishna.s.vasudevan
      3. HBASE-10447_trunk_1.patch
        0.7 kB
        ramkrishna.s.vasudevan

        Issue Links

          Activity

          ramkrishna.s.vasudevan added a comment -

          I verifed that the KVs from the store file are also getting flushed during a memstore flush. I think that is wrong and unintended. We only need the KVs from the memstore alone.

          Andrew Purtell added a comment -

          Blocker for 0.98.0.

          Lars Hofhansl added a comment -

          but this time with the other scanners for all the files that satisfies the last top key

          Now that is a problem. This needs to be fixed in 0.94 and 0.96 as well.

          Lars Hofhansl added a comment -

          I introduced this problem with HBASE-4241 I think.

          Lars Hofhansl added a comment -

          No I didn't. The StoreScanner constructor used did not register the change listener before, and doesn't in 0.94.

          Lars Hofhansl added a comment -

          So not a problem in 0.94.

          Lars Hofhansl added a comment -

          So we can either revive the old constructor or pass down a flag. I'd prefer the latter approach, since it makes it explicit.

          Ted Yu added a comment -

          or pass down a flag

          +1

          ramkrishna.s.vasudevan added a comment -

          +1 for the flag. That is what I had in mind.

          ramkrishna.s.vasudevan added a comment -

          Patch for 0.98. Will do some more testing once.

          Andrew Purtell added a comment -

          HadoopQA might be able to apply this against trunk.

          Andrew Purtell added a comment -

          +1, patch looks like it would work. Anyone have an issue with passing down a new flag?

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12626475/HBASE-10447_0.98.patch
          against trunk revision .
          ATTACHMENT ID: 12626475

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 12 new or modified tests.

          +1 hadoop1.0. The patch compiles against the hadoop 1.0 profile.

          +1 hadoop1.1. The patch compiles against the hadoop 1.1 profile.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 lineLengths. The patch introduces the following lines longer than 100:
          + byte[] dropDeletesFromRow, byte[] dropDeletesToRow, boolean scannerForFlush) throws IOException {
          + long earliestPutTs, byte[] dropDeletesFromRow, byte[] dropDeletesToRow, boolean scannerForFlush)

          +1 site. The mvn site goal succeeds with this patch.

          -1 core tests. The patch failed these unit tests:

          -1 core zombie tests. There are 2 zombie test(s): at org.apache.hadoop.hbase.TestAcidGuarantees.testMixedAtomicity(TestAcidGuarantees.java:351)
          at org.apache.hadoop.hbase.io.encoding.TestEncodedSeekers.testEncodedSeeker(TestEncodedSeekers.java:129)

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/8572//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8572//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop2-compat.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8572//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8572//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-client.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8572//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8572//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-protocol.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8572//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8572//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-examples.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8572//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-thrift.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8572//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/8572//console

          This message is automatically generated.

          ramkrishna.s.vasudevan added a comment -

          Both testcases passes - TestEncodedSeekers and TestAcidGuarentees. I think off late this TestAcidGuarentees is failing. Need to investigate?

          Andrew Purtell added a comment -

          Those two tests have been failing in precommit builds recently. I don't think they are related to the patch here.

          I have been looking into the precommit hangs but am not able to reproduce locally.

          ramkrishna.s.vasudevan added a comment -

          Patch for trunk. Truncated lines > 100.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12626599/HBASE-10447_trunk.patch
          against trunk revision .
          ATTACHMENT ID: 12626599

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 12 new or modified tests.

          +1 hadoop1.0. The patch compiles against the hadoop 1.0 profile.

          +1 hadoop1.1. The patch compiles against the hadoop 1.1 profile.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 lineLengths. The patch does not introduce lines longer than 100

          +1 site. The mvn site goal succeeds with this patch.

          -1 core tests. The patch failed these unit tests:

          -1 core zombie tests. There are 1 zombie test(s): at org.apache.hadoop.hbase.TestAcidGuarantees.testScanAtomicity(TestAcidGuarantees.java:341)

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/8574//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8574//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-protocol.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8574//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-thrift.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8574//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-client.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8574//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop2-compat.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8574//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-examples.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8574//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8574//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8574//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8574//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/8574//console

          This message is automatically generated.

          Andrew Purtell added a comment -

          +1

          ramkrishna.s.vasudevan added a comment -

          I would like to commit this into 0.98.0's next RC.
          Let me know if there are any objections on this patch, if not could go for commit.
          Thanks for the +1 Andrew Purtell.

          Lars Hofhansl added a comment -

          Looks good to me.
          As a nit I'd make this flag more explicit like registerChangeObserver or something. But this is fine too.

          +1

          ramkrishna.s.vasudevan added a comment -

          Thanks Lars.
          I was about to commit and once verified in 0.96 code. There we don't add the observers even while doing compaction.
          So should we make it like that in 0.98 and trunk also. In the sense only for user reads the observers are added. The current change would any way add observers for compaction also as it was in 0.98 and trunk. Would get this clarified once before I could commit it. Suggestions?

          ramkrishna.s.vasudevan added a comment -

          This should be the simplest patches. The constructor that is changed in this patch is the one that is called over in Compaction and flush. In 0.96 case it does not add the observers. So should be the case in 0.98 and trunk. Do we need the reset to happen in compaction? I don't think so.
          @apurtell,Lars Hofhansl, Anoop Sam John
          Pls review this patch and if we are ok we could commit this.

          ramkrishna.s.vasudevan added a comment -

          removing 0.96 from the fix and affected version.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12626849/HBASE-10447_trunk_1.patch
          against trunk revision .
          ATTACHMENT ID: 12626849

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 hadoop1.0. The patch compiles against the hadoop 1.0 profile.

          +1 hadoop1.1. The patch compiles against the hadoop 1.1 profile.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 lineLengths. The patch does not introduce lines longer than 100

          +1 site. The mvn site goal succeeds with this patch.

          +1 core tests. The patch passed unit tests in .

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/8589//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8589//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-protocol.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8589//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-thrift.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8589//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-client.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8589//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop2-compat.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8589//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-examples.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8589//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8589//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8589//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8589//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/8589//console

          This message is automatically generated.

          Andrew Purtell added a comment -

          v1 patch lgtm

          ramkrishna.s.vasudevan added a comment -

          Committed to trunk and 0.98. Thanks all for the reviews.

          Hudson added a comment -

          SUCCESS: Integrated in HBase-TRUNK #4881 (See https://builds.apache.org/job/HBase-TRUNK/4881/)
          HBASE-10447-Memstore flusher scans storefiles also when the scanner heap gets resetKVHeap(Ram) (ramkrishna: rev 1564377)

          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/regionserver/StoreScanner.java
          Lars Hofhansl added a comment -

          Probably needs to go into 0.96. stack

          Hudson added a comment -

          SUCCESS: Integrated in HBase-0.98 #127 (See https://builds.apache.org/job/HBase-0.98/127/)
          HBASE-10447-Memstore flusher scans storefiles also when the scanner heap gets resetKVHeap(Ram) (ramkrishna: rev 1564378)

          • /hbase/branches/0.98/hbase-server/src/main/java/org/apache/hadoop/hbase/regionserver/StoreScanner.java
          Hudson added a comment -

          FAILURE: Integrated in HBase-0.98-on-Hadoop-1.1 #119 (See https://builds.apache.org/job/HBase-0.98-on-Hadoop-1.1/119/)
          HBASE-10447-Memstore flusher scans storefiles also when the scanner heap gets resetKVHeap(Ram) (ramkrishna: rev 1564378)

          • /hbase/branches/0.98/hbase-server/src/main/java/org/apache/hadoop/hbase/regionserver/StoreScanner.java
          stack added a comment -

          I'm good w/ this in 0.96. I tried to apply the 0.98 but it fails. Thanks.

          Hudson added a comment -

          FAILURE: Integrated in HBase-TRUNK-on-Hadoop-1.1 #79 (See https://builds.apache.org/job/HBase-TRUNK-on-Hadoop-1.1/79/)
          HBASE-10447-Memstore flusher scans storefiles also when the scanner heap gets resetKVHeap(Ram) (ramkrishna: rev 1564377)

          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/regionserver/StoreScanner.java
          ramkrishna.s.vasudevan added a comment -

          Not needed in 0.96. It is fine there. That is why removed the fix/affected versions as 0.96.

          stack added a comment -

            People

            • Assignee:
              ramkrishna.s.vasudevan
              Reporter:
              ramkrishna.s.vasudevan
            • Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development