HBase
  1. HBase
  2. HBASE-10443

IndexOutOfBoundExceptions when processing compressed tags in HFile

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.98.0
    • Fix Version/s: 0.98.0, 0.99.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      As HBASE-10438 got closed, we still need to fix the Index out of bound exception that occurs. If we have a proper fix will fix this, if the bug was a false alarm would close this.

      1. HBASE-10443.patch
        4 kB
        ramkrishna.s.vasudevan
      2. HBASE-10443_1.patch
        4 kB
        ramkrishna.s.vasudevan

        Activity

        ramkrishna.s.vasudevan added a comment -

        We have these two exceptions trace

        org.apache.hadoop.hbase.DroppedSnapshotException: region: usertable,user5152654437639860133,1391056599393.654e89edf63813d2120e9d287afff889.
                at org.apache.hadoop.hbase.regionserver.HRegion.internalFlushcache(HRegion.java:1694)
                at org.apache.hadoop.hbase.regionserver.HRegion.internalFlushcache(HRegion.java:1556)
                at org.apache.hadoop.hbase.regionserver.HRegion.flushcache(HRegion.java:1471)
                at org.apache.hadoop.hbase.regionserver.MemStoreFlusher.flushRegion(MemStoreFlusher.java:456)
                at org.apache.hadoop.hbase.regionserver.MemStoreFlusher.flushRegion(MemStoreFlusher.java:430)
                at org.apache.hadoop.hbase.regionserver.MemStoreFlusher.access$800(MemStoreFlusher.java:66)
                at org.apache.hadoop.hbase.regionserver.MemStoreFlusher$FlushHandler.run(MemStoreFlusher.java:248)
                at java.lang.Thread.run(Thread.java:744)
        Caused by: java.lang.IndexOutOfBoundsException: index (16161) must be less than size (7)
                at com.google.common.base.Preconditions.checkElementIndex(Preconditions.java:305)
                at com.google.common.base.Preconditions.checkElementIndex(Preconditions.java:284)
                at org.apache.hadoop.hbase.io.util.LRUDictionary$BidirectionalLRUMap.get(LRUDictionary.java:139)
                at org.apache.hadoop.hbase.io.util.LRUDictionary$BidirectionalLRUMap.access$000(LRUDictionary.java:76)
                at org.apache.hadoop.hbase.io.util.LRUDictionary.getEntry(LRUDictionary.java:43)
                at org.apache.hadoop.hbase.io.TagCompressionContext.uncompressTags(TagCompressionContext.java:159)
                at org.apache.hadoop.hbase.io.encoding.BufferedDataBlockEncoder$BufferedEncodedSeeker.decodeTags(BufferedDataBlockEncoder.java:273)
                at org.apache.hadoop.hbase.io.encoding.FastDiffDeltaEncoder$1.decode(FastDiffDeltaEncoder.java:522)
                at org.apache.hadoop.hbase.io.encoding.FastDiffDeltaEncoder$1.decodeNext(FastDiffDeltaEncoder.java:540)
                at org.apache.hadoop.hbase.io.encoding.BufferedDataBlockEncoder$BufferedEncodedSeeker.next(BufferedDataBlockEncoder.java:262)
                at org.apache.hadoop.hbase.io.hfile.HFileReaderV2$EncodedScannerV2.next(HFileReaderV2.java:1063)
                at org.apache.hadoop.hbase.regionserver.StoreFileScanner.next(StoreFileScanner.java:137)
                at org.apache.hadoop.hbase.regionserver.KeyValueHeap.next(KeyValueHeap.java:108)
                at org.apache.hadoop.hbase.regionserver.StoreScanner.next(StoreScanner.java:509)
                at org.apache.hadoop.hbase.regionserver.StoreFlusher.performFlush(StoreFlusher.java:128)
                at org.apache.hadoop.hbase.regionserver.DefaultStoreFlusher.flushSnapshot(DefaultStoreFlusher.java:73)
                at org.apache.hadoop.hbase.regionserver.HStore.flushCache(HStore.java:786)
                at org.apache.hadoop.hbase.regionserver.HStore$StoreFlusherImpl.flushCache(HStore.java:1943)
                at org.apache.hadoop.hbase.regionserver.HRegion.internalFlushcache(HRegion.java:1669)
        
        java.lang.IndexOutOfBoundsException: index (63) must be less than size (9)
                at com.google.common.base.Preconditions.checkElementIndex(Preconditions.java:305)
                at com.google.common.base.Preconditions.checkElementIndex(Preconditions.java:284)
                at org.apache.hadoop.hbase.io.util.LRUDictionary$BidirectionalLRUMap.get(LRUDictionary.java:131)
               at org.apache.hadoop.hbase.io.util.LRUDictionary$BidirectionalLRUMap.access$000(LRUDictionary.java:76)
                at org.apache.hadoop.hbase.io.util.LRUDictionary.getEntry(LRUDictionary.java:43)
                at org.apache.hadoop.hbase.io.TagCompressionContext.uncompressTags(TagCompressionContext.java:151)
                at org.apache.hadoop.hbase.io.encoding.BufferedDataBlockEncoder$BufferedEncodedSeeker.decodeTags(BufferedDataBlockEncoder.java:270)
                at org.apache.hadoop.hbase.io.encoding.FastDiffDeltaEncoder$1.decode(FastDiffDeltaEncoder.java:522)
                at org.apache.hadoop.hbase.io.encoding.FastDiffDeltaEncoder$1.decodeNext(FastDiffDeltaEncoder.java:540)
                at org.apache.hadoop.hbase.io.encoding.BufferedDataBlockEncoder$BufferedEncodedSeeker.next(BufferedDataBlockEncoder.java:259)
                at org.apache.hadoop.hbase.io.hfile.HFileReaderV2$EncodedScannerV2.next(HFileReaderV2.java:1063)
                at org.apache.hadoop.hbase.regionserver.StoreFileScanner.next(StoreFileScanner.java:137)
                at org.apache.hadoop.hbase.regionserver.KeyValueHeap.next(KeyValueHeap.java:108)
                at org.apache.hadoop.hbase.regionserver.StoreScanner.next(StoreScanner.java:509)
                at org.apache.hadoop.hbase.regionserver.compactions.Compactor.performCompaction(Compactor.java:217)
                at org.apache.hadoop.hbase.regionserver.compactions.DefaultCompactor.compact(DefaultCompactor.java:76)
                at org.apache.hadoop.hbase.regionserver.DefaultStoreEngine$DefaultCompactionContext.compact(DefaultStoreEngine.java:109)
                at org.apache.hadoop.hbase.regionserver.HStore.compact(HStore.java:1074)
                at org.apache.hadoop.hbase.regionserver.HRegion.compact(HRegion.java:1382)
                at org.apache.hadoop.hbase.regionserver.CompactSplitThread$CompactionRunner.run(CompactSplitThread.java:475)
                at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
                at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
                at java.lang.Thread.run(Thread.java:744)
        
        Anoop Sam John added a comment -

        Strange part is DefaultStoreFlusher.flushSnapshot is using a StoreFileScanner

        ramkrishna.s.vasudevan added a comment -

        That too not every time a flush happens. Some flushes carry the storefilescanner in the kvheap.

        Andrew Purtell added a comment -

        The fix version needs to be 0.98.1 unless this sinks the RC. It does not in my opinion because tag compression is optional.

        ramkrishna.s.vasudevan added a comment -

        After a long fight with this issue, we have nailed down this.
        When the store file is being read, as part of reseek to a key if we find the if we have jumped a given key we do a move previous. Incase of DBEs we have already read this key and made an entry in the LRU dictionary for tags.
        Now after moving to previous we once again read this kv and again will make a duplicate entry in the KV in the next immediate index. Now there are two entries.
        Index 17 and 18 may have the same entry (for eg). Now another read tries to check what value is in index 18 expecting Tag B he may get back Tag A.
        Just tried out ruling out duplicate entries am able to overcome this bug.
        So better to disable compress_tags for this version?

        Anoop Sam John added a comment -

        So better to disable compress_tags for this version?

        +1 for disabling compress tag on HFile for 0.98

        Andrew Purtell added a comment -

        +1 for disabling compress tag on HFile for 0.98

        We won't compress tags unless HColumnDescriptor#shouldCompressTags returns 'true'. Unfortunately that is determined by this, in HColumnDescriptor:

          /**
           * Default compress tags along with any type of DataBlockEncoding
           */
          public static final boolean DEFAULT_COMPRESS_TAGS = true;
        

        I guess we have to make a change here (at least) and sink the RC. We should also modify HFileContextBuilder to disallow setting compressTags to true.

        Andrew Purtell added a comment -

        Raised priority to blocker, fix version 0.98.0

        Andrew Purtell added a comment -

        I'm +1 for forced disable of compressed tags in 0.98.0. Please leave the schema and configuration options around for when this is fixed in/for 0.98.1

        ramkrishna.s.vasudevan added a comment -

        Sorry..bit late to this today.. Will come up with a patch soon.

        ramkrishna.s.vasudevan added a comment -

        Patch that defaults COMPRESS_TAGs to false and also logs a msg before setting to HFileContext if found to be true.
        Should we add this in book also?

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12626465/HBASE-10443.patch
        against trunk revision .
        ATTACHMENT ID: 12626465

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 hadoop1.0. The patch compiles against the hadoop 1.0 profile.

        +1 hadoop1.1. The patch compiles against the hadoop 1.1 profile.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 lineLengths. The patch does not introduce lines longer than 100

        +1 site. The mvn site goal succeeds with this patch.

        +1 core tests. The patch passed unit tests in .

        Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/8571//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8571//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop2-compat.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8571//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8571//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-client.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8571//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8571//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-protocol.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8571//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8571//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-examples.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8571//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-thrift.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8571//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
        Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/8571//console

        This message is automatically generated.

        Anoop Sam John added a comment -

        +1

        Andrew Purtell added a comment -

        The patch is fine.

        We don't need a book update.

        +    if(family.shouldCompressTags()) {
        +      LOG.warn("Compress tags in HFiles disabled in 0.98.0");
        +    }
        

        Don't put in version specific messages. Instead, do something like this:

        +    if(family.shouldCompressTags()) {
        +      LOG.warn("HFile tag compression attribute ignored for '" + family.getNameAsString() + "', see HBASE-10443");
        +    }
        

        Can be fixed up at commit time.

        ramkrishna.s.vasudevan added a comment -

        Updated patch. Going to commit this.

        ramkrishna.s.vasudevan added a comment -

        Committed to 0.98 and trunk. While fixing HBASE-10451 needs to fix in trunk also. Thanks for the reviews Anoop and Andy.

        Hudson added a comment -

        SUCCESS: Integrated in HBase-0.98-on-Hadoop-1.1 #112 (See https://builds.apache.org/job/HBase-0.98-on-Hadoop-1.1/112/)
        HBASE-10443-IndexOutOfBoundExceptions when processing compressed tags in HFile (Ramkrishna S Vasudevan) (ramkrishna: rev 1563583)

        • /hbase/branches/0.98/hbase-client/src/main/java/org/apache/hadoop/hbase/HColumnDescriptor.java
        • /hbase/branches/0.98/hbase-common/src/main/java/org/apache/hadoop/hbase/io/hfile/HFileContextBuilder.java
        • /hbase/branches/0.98/hbase-server/src/main/java/org/apache/hadoop/hbase/regionserver/HStore.java
        Hudson added a comment -

        SUCCESS: Integrated in HBase-TRUNK #4874 (See https://builds.apache.org/job/HBase-TRUNK/4874/)
        HBASE-10443-IndexOutOfBoundExceptions when processing compressed tags in HFile(Ramkrishna S Vasudevan) (ramkrishna: rev 1563584)

        • /hbase/trunk/hbase-client/src/main/java/org/apache/hadoop/hbase/HColumnDescriptor.java
        • /hbase/trunk/hbase-common/src/main/java/org/apache/hadoop/hbase/io/hfile/HFileContextBuilder.java
        • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/regionserver/HStore.java
        Hudson added a comment -

        FAILURE: Integrated in HBase-TRUNK-on-Hadoop-1.1 #75 (See https://builds.apache.org/job/HBase-TRUNK-on-Hadoop-1.1/75/)
        HBASE-10443-IndexOutOfBoundExceptions when processing compressed tags in HFile(Ramkrishna S Vasudevan) (ramkrishna: rev 1563584)

        • /hbase/trunk/hbase-client/src/main/java/org/apache/hadoop/hbase/HColumnDescriptor.java
        • /hbase/trunk/hbase-common/src/main/java/org/apache/hadoop/hbase/io/hfile/HFileContextBuilder.java
        • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/regionserver/HStore.java
        Hudson added a comment -

        FAILURE: Integrated in HBase-0.98 #123 (See https://builds.apache.org/job/HBase-0.98/123/)
        HBASE-10443-IndexOutOfBoundExceptions when processing compressed tags in HFile (Ramkrishna S Vasudevan) (ramkrishna: rev 1563583)

        • /hbase/branches/0.98/hbase-client/src/main/java/org/apache/hadoop/hbase/HColumnDescriptor.java
        • /hbase/branches/0.98/hbase-common/src/main/java/org/apache/hadoop/hbase/io/hfile/HFileContextBuilder.java
        • /hbase/branches/0.98/hbase-server/src/main/java/org/apache/hadoop/hbase/regionserver/HStore.java
        Enis Soztutar added a comment -

        Closing this issue after 0.99.0 release.


          People

          • Assignee:
            ramkrishna.s.vasudevan
            Reporter:
            ramkrishna.s.vasudevan
          • Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development