HBase
  1. HBase
  2. HBASE-10419

Add multiget support to PerformanceEvaluation

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.96.2, 0.98.1, 0.99.0, hbase-10070
    • Component/s: test
    • Labels:
      None

      Description

      Folks planning to use multiget may find this useful.

      1. HBASE-10419.0.patch
        11 kB
        Nick Dimiduk
      2. HBASE-10419.1.patch
        9 kB
        stack
      3. HBASE-10419-v2-trunk.patch
        9 kB
        Jean-Marc Spaggiari
      4. HBASE-10419-v3-trunk.patch
        12 kB
        Nick Dimiduk
      5. HBASE-10419-v4-trunk.patch
        12 kB
        Nick Dimiduk
      6. HBASE-10419-0.96.patch
        12 kB
        Nick Dimiduk

        Issue Links

          Activity

          Nick Dimiduk added a comment -

          Here's a patch adding this feature. It runs with --nomapred; haven't tried yet with mapreduce.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12625170/HBASE-10419.0.patch
          against trunk revision .
          ATTACHMENT ID: 12625170

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          +1 hadoop1.0. The patch compiles against the hadoop 1.0 profile.

          +1 hadoop1.1. The patch compiles against the hadoop 1.1 profile.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 lineLengths. The patch does not introduce lines longer than 100

          -1 site. The patch appears to cause mvn site goal to fail.

          +1 core tests. The patch passed unit tests in .

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/8506//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8506//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop2-compat.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8506//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8506//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-client.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8506//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8506//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-protocol.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8506//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8506//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-examples.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8506//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-thrift.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8506//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/8506//console

          This message is automatically generated.

          stack added a comment -

          +1

          Jean-Marc Spaggiari added a comment -

          Any chance to get that commited soon? Will be nice to have it on all the versions.

          Liang Xie added a comment -

          skimmed over the patch, lgtm, +1

          stack added a comment -

          Fix a little bit of rot.

          stack added a comment -

          Attached patch fails with this Jean-Marc Spaggiari:

          [ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:2.5.1:testCompile (default-testCompile) on project hbase-server: Compilation failure
          [ERROR] /Users/stack/checkouts/trunk/hbase-server/src/test/java/org/apache/hadoop/hbase/PerformanceEvaluation.java:[1203,13] cannot find symbol
          [ERROR] symbol  : constructor DescriptiveStatistics(float[])
          [ERROR] location: class org.apache.commons.math.stat.descriptive.DescriptiveStatistics
          [ERROR] -> [Help 1]
          

          Sorry we let it rot. Mind fixing up? I'll commit it then.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12628950/HBASE-10419.1.patch
          against trunk revision .
          ATTACHMENT ID: 12628950

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          -1 hadoop1.0. The patch failed to compile against the hadoop 1.0 profile.
          Here is snippet of errors:

          [ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:2.5.1:testCompile (default-testCompile) on project hbase-server: Compilation failure
          [ERROR] /home/jenkins/jenkins-slave/workspace/PreCommit-HBASE-Build/trunk/hbase-server/src/test/java/org/apache/hadoop/hbase/PerformanceEvaluation.java:[1203,13] cannot find symbol
          [ERROR] symbol  : constructor DescriptiveStatistics(float[])
          [ERROR] location: class org.apache.commons.math.stat.descriptive.DescriptiveStatistics
          [ERROR] -> [Help 1]
          org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:2.5.1:testCompile (default-testCompile) on project hbase-server: Compilation failure
          /home/jenkins/jenkins-slave/workspace/PreCommit-HBASE-Build/trunk/hbase-server/src/test/java/org/apache/hadoop/hbase/PerformanceEvaluation.java:[1203,13] cannot find symbol
          symbol  : constructor DescriptiveStatistics(float[])
          location: class org.apache.commons.math.stat.descriptive.DescriptiveStatistics
          
          	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:213)
          --
          Caused by: org.apache.maven.plugin.CompilationFailureException: Compilation failure
          /home/jenkins/jenkins-slave/workspace/PreCommit-HBASE-Build/trunk/hbase-server/src/test/java/org/apache/hadoop/hbase/PerformanceEvaluation.java:[1203,13] cannot find symbol
          symbol  : constructor DescriptiveStatistics(float[])
          location: class org.apache.commons.math.stat.descriptive.DescriptiveStatistics
          
          	at org.apache.maven.plugin.AbstractCompilerMojo.execute(AbstractCompilerMojo.java:729)

          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/8694//console

          This message is automatically generated.

          Jean-Marc Spaggiari added a comment -

          Sorry we let it rot. Mind fixing up? I'll commit it then.

          Sure. I will try to rebase it in a minute.

          Jean-Marc Spaggiari added a comment -

          Nick Dimiduk I had to restore double instead of float to get it compile. Any specific reason why you used float?

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12629010/HBASE-10419-v2-trunk.patch
          against trunk revision .
          ATTACHMENT ID: 12629010

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          +1 hadoop1.0. The patch compiles against the hadoop 1.0 profile.

          +1 hadoop1.1. The patch compiles against the hadoop 1.1 profile.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 lineLengths. The patch does not introduce lines longer than 100

          -1 site. The patch appears to cause mvn site goal to fail.

          -1 core tests. The patch failed these unit tests:

          -1 core zombie tests. There are 1 zombie test(s):

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/8700//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8700//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-protocol.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8700//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-thrift.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8700//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-client.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8700//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop2-compat.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8700//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-examples.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8700//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8700//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8700//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8700//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/8700//console

          This message is automatically generated.

          Nick Dimiduk added a comment -

          Any specific reason why you used float?

          Nicolas Liochon / HBASE-10511 just slipped in the summary statistics business, which changed my floats into doubles.

          Jean-Marc Spaggiari added a comment -

          Got it! So we should be fine with the last attached updated version.

          Nick Dimiduk added a comment -

          Let me make sure it works in both mapred and nomapred modes and i'll get it committed. Thanks for reminding me of it Jean-Marc Spaggiari, stack.

          Jean-Marc Spaggiari added a comment -

          Are going to give it a try with both modes and confirm?

          Nick Dimiduk added a comment -

          This patch fixed mapred mode and adds a note about the new feature to the help output.

          I assume +1's cary forth. Will commit to trunk, 0.98, and 0.96 after a successful HadoopQA report.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12629179/HBASE-10419-v3-trunk.patch
          against trunk revision .
          ATTACHMENT ID: 12629179

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          +1 hadoop1.0. The patch compiles against the hadoop 1.0 profile.

          +1 hadoop1.1. The patch compiles against the hadoop 1.1 profile.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 lineLengths. The patch does not introduce lines longer than 100

          -1 site. The patch appears to cause mvn site goal to fail.

          -1 core tests. The patch failed these unit tests:
          org.apache.hadoop.hbase.master.TestDistributedLogSplitting

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/8716//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8716//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop2-compat.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8716//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8716//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-client.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8716//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8716//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-protocol.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8716//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8716//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-examples.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8716//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-thrift.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8716//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/8716//console

          This message is automatically generated.

          Nick Dimiduk added a comment -

          Once more, rebased onto trunk after cleaning up HBASE-10548. Patch v4 works for me with and without --multiGet in both MR and --nomapreduce modes.

          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12629693/HBASE-10419-v4-trunk.patch
          against trunk revision .
          ATTACHMENT ID: 12629693

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          +1 hadoop1.0. The patch compiles against the hadoop 1.0 profile.

          +1 hadoop1.1. The patch compiles against the hadoop 1.1 profile.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 lineLengths. The patch does not introduce lines longer than 100

          +1 site. The mvn site goal succeeds with this patch.

          +1 core tests. The patch passed unit tests in .

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/8741//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8741//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-protocol.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8741//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-thrift.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8741//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-client.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8741//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop2-compat.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8741//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-examples.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8741//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8741//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8741//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8741//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/8741//console

          This message is automatically generated.

          Nick Dimiduk added a comment -

          patch for 0.96.

          Nick Dimiduk added a comment -

          Coommitted to 0.96, 0.98, trunk. Thanks folks.

          Hudson added a comment -

          SUCCESS: Integrated in HBase-0.98 #169 (See https://builds.apache.org/job/HBase-0.98/169/)
          HBASE-10419 Add multiget support to PerformanceEvaluation (ndimiduk: rev 1569827)

          • /hbase/branches/0.98/hbase-server/src/test/java/org/apache/hadoop/hbase/PerformanceEvaluation.java
          Hudson added a comment -

          SUCCESS: Integrated in hbase-0.96 #303 (See https://builds.apache.org/job/hbase-0.96/303/)
          HBASE-10419 Add multiget support to PerformanceEvaluation (ndimiduk: rev 1569830)

          • /hbase/branches/0.96/hbase-server/src/test/java/org/apache/hadoop/hbase/PerformanceEvaluation.java
          Hudson added a comment -

          SUCCESS: Integrated in HBase-TRUNK #4933 (See https://builds.apache.org/job/HBase-TRUNK/4933/)
          HBASE-10419 Add multiget support to PerformanceEvaluation (ndimiduk: rev 1569826)

          • /hbase/trunk/hbase-server/src/test/java/org/apache/hadoop/hbase/PerformanceEvaluation.java
          Hudson added a comment -

          FAILURE: Integrated in HBase-0.98-on-Hadoop-1.1 #158 (See https://builds.apache.org/job/HBase-0.98-on-Hadoop-1.1/158/)
          HBASE-10419 Add multiget support to PerformanceEvaluation (ndimiduk: rev 1569827)

          • /hbase/branches/0.98/hbase-server/src/test/java/org/apache/hadoop/hbase/PerformanceEvaluation.java
          Hudson added a comment -

          FAILURE: Integrated in HBase-TRUNK-on-Hadoop-1.1 #94 (See https://builds.apache.org/job/HBase-TRUNK-on-Hadoop-1.1/94/)
          HBASE-10419 Add multiget support to PerformanceEvaluation (ndimiduk: rev 1569826)

          • /hbase/trunk/hbase-server/src/test/java/org/apache/hadoop/hbase/PerformanceEvaluation.java
          Hudson added a comment -

          SUCCESS: Integrated in hbase-0.96-hadoop2 #209 (See https://builds.apache.org/job/hbase-0.96-hadoop2/209/)
          HBASE-10419 Add multiget support to PerformanceEvaluation (ndimiduk: rev 1569830)

          • /hbase/branches/0.96/hbase-server/src/test/java/org/apache/hadoop/hbase/PerformanceEvaluation.java
          Nicolas Liochon added a comment -

          Any issue if I commit this in hbase-10070? ping Devaraj Das, Enis Soztutar

          Nicolas Liochon added a comment -

          There is a small defect btw: the multiget option does not show up in the printUsage. I will fix this as an addendum with the 10070 commit.

          Nicolas Liochon added a comment -

          Hum, the multiget doc is in HBASE-10791 if i understand correctly.

          Devaraj Das added a comment -

          Any issue if I commit this in hbase-10070? ping Devaraj Das, Enis Soztutar

          +1 for commit

          Nick Dimiduk added a comment -

          This and a couple others are necessary for HBASE-10791. See that ticket for details.

          Nicolas Liochon added a comment -

          Committed to hbase-10070 branch.

          Enis Soztutar added a comment -

          Closing this issue after 0.99.0 release.


            People

            • Assignee:
              Nick Dimiduk
              Reporter:
              Nick Dimiduk
            • Votes:
              0 Vote for this issue
              Watchers:
              11 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development